9 Replies Latest reply: Jun 19, 2013 8:32 AM by Joshonline
D M K Level 1 (0 points)
I have a podcast which I have deleted from iTunes which still shows (but not plays) in Front Row.
Looking at the iTunes Music Library xml file, it still shows there but if I open up the xml file, delete the offending entry, save and reboot it reappears.

The path of the Podcsat is listed as in (home folder)/.Trash/
I have enabled Show Invisible Files in Finder, checked the Trash folder - its not there.

Any thoughts?

Mac Mini (Early 2009)/MacBook (Late 2008)Mac Mini (2010), Mac OS X (10.6.7), LED Cinema Display
  • D M K Level 1 (0 points)
    Gave up trying to find a solution to this. Have trashed the iTunes Library File and started again importing all my stuff. Works now.
  • mc_razza Level 1 (0 points)

    I actually have this exact same problem. I posted a thread about it here:




    ...but I got no answers.



    Thanks for posting what you did. Will give it a go.

  • mc_razza Level 1 (0 points)



    I tried it and it did work. The problem is that it also deleted my playlists but that can be fixed my exporting my playlists from my iPod, saving it anywhere on the hard drive and then importing it into iTunes. The other problem was that my settings for iTunes e.g. columns, column placements, view settings etc were gone. I had these things set up a specific way. I decide to dive back into Time Machine and retrieve/restore the iTunes Library file.


    I'm now searching for a less disruptive way of eliminating the deleted podcast still showing up in Front Row.

  • andrewwoodward1966 Level 1 (10 points)

    Hi, what exactly did you try and what exactly did work. I have the same problem.


    The ones with exclamation marks don't exist but iTunes, iPhone/iPad remote and AppleTV reckno they do.


  • mc_razza Level 1 (0 points)

    The exclamation mark indicates that the items' names are in  iTunes but the actual files themselves are not in your music library/folder. For example if I were to delete a song/video/podcast directly from within the iTunes music folder, the file is gone from the system but the name still shows up in iTunes. The exclamation mark indicates that it cannot locate the file in its original folder. In response to that you can either redownload those podcasts, try and relocate the podcasts if it's somewhere in your system but in another folder or you can simply delete the names of the podcasts with the exclamation marks next to them if you don't need those podcasts anymore.


    As for my problem with Front Row and long gone podcasts, it doesn't concern me anymore. I have upgraded from Snow Leopard to Lion and with that Apple has removed Front Row from Lion. No worries for me now.

  • Michael Mills2 Level 1 (55 points)

    I had a similar problem in iTunes 10. The podcast episodes with the exclamation point did not show up under podcasts, however, only under smart playlists, such as "Recently Added". I only knew they were there because iTunes would pop up a notification each time I would sync an iPod or iPhone, letting me know it could not find the file. iTunes would not allow me to simply delete the name of these episodes once I found them in a smart playlists, even using option-delete.


    My solution was to "Get Info" (cmd-I) on each epsiode, which would prompt me to locate the missing file. I simply duplicated another episode and pointed the name to the duplicate file. After that I was able to delete the name from the smart playlist using option-delete, and chose to have the file moved to the trash. Far from intuitive!

  • drsjs Level 1 (0 points)



    This has been driving me crazy for almost a year... Use this solution and your problem will be solved.  Thank you dougscripts.com!



  • Tara Cravens Level 1 (5 points)

    This worked for me, altho I had to take the extra step to re-add the podcasts to the main podcast area to delete them, couldn't delete directly from the smartlist.

  • Joshonline Level 1 (0 points)

    In terms of deleting the podcast even after it being deleted from the icon view in iTunes it reappeared.  I managed to delete from the 'List' view in Podcasts.