Previous 1 2 3 Next 44 Replies Latest reply: Oct 21, 2014 8:36 PM by sam b.
Manas Rao Level 1 (0 points)
I recently added 2 x 4GB of OWC RAM to my Mac Pro 2009 quad, so that I now have 10GB of RAM (slots 1 & 2: 4GB; slots 3 & 4: 1GB). On booting up (after adding the new memory), the Memory Slot Utility popped up reassuringly, saying that the memory had been correctly installed. The problem is that it keeps doing so each time I boot the machine. I searched and found one other post - unanswered - that described the same problem.

Does anyone know how to stop this from happening?

2.66 GHz Quad-Core Intel Xeon, Mac OS X (10.6.2), 10 GB 1066 MHz DDR3 RAM
  • Grant Bennet-Alder Level 9 (56,531 points)
    There are two reasons that message can keep popping up:

    1) your memory size keeps changing because your memories are failing.

    2) The message also indicates something about "notifying your System Administrator". Readers have said that logging in with an Admin username, and seeing and dismissing the message, allows the Utility to decide that the Admin has been notified. Then it stops putting up the message.
  • Manas Rao Level 1 (0 points)
    And it worked! I re-booted and logged in as the administrator. The memory slot utility came up the first time and I clicked on OK. When I re-booted again and logged in as the user (not administrator), it was no longer there.

  • MajorMatt Level 1 (65 points)

    Worked for me as well. Log-in as root user and clicked OK on the "Memory Slot Utility".


    Added 32GB, matched set(8 x 4GB) to Mac Pro 8-core (2009), Was 10GB, with (6 x 1GB) & (2 x 2GB).


    How to log in as root user see:

  • orionexp Level 1 (0 points)

    I tried enabling root user and it didn't work.  My solution: delete Memory Slot Utility from CoreServices.  Worked like a charm.  Not the elegant solution I was hoping for, but it works.  If anyone has more details on the root user solution that i might have missed i'd be happy to try it.  Of course I saved MS Utility to another HD, so i can copy it back anytime.

  • Coxize Level 1 (10 points)

    Thanks for the info. Logging in as Admin worked for me also!

  • Grant Bennet-Alder Level 9 (56,531 points)



    Could you please help?


    A few Readers have not had any luck simply logging in as Admin. and have had to resort toriskier measures. WE need to try to establish a trend.


    What version of Mac OS X were you running when this fix worked ??

  • MajorMatt Level 1 (65 points)

    I added 32GB RAM from OWC ""

    Quantity: 1 OWC85MP3W4M32GK, $319.99 each

    32GB OWC Matched Set (8x4GB) DDR3 ECC PC8500 1066MHz SDRAM PC3-8500 ECC for 8-Core or better


    Current system, at time of issue>


    Mac Pro 8 core, 2.66Ghz,  Lion 10.7.1

  • Coxize Level 1 (10 points)


    I logged in as admin which is a seperate account nad clicked OK

  • X423424X Level 6 (14,215 points)

    You don't log with your admin id.  You log in as "root".  Enable root if it isn't already enabled.  See this discussion and this discussion.

  • Grant Bennet-Alder Level 9 (56,531 points)



    Your advice directly above is inaccurate and may be hazardous.


    Logging in as an Admin user was supposed to be all that is required, and the poster you replied to had already made it work that way.


    The users who could not make this work without resorting to Root were few, and the problem may have been limited to certain configurations or certain versions of Mac OS X.


    Most Users should not need to enable or use Root for anything. Susggesting it is needed for mundane activities is not correct, and may open your Mac to abuse.

  • X423424X Level 6 (14,215 points)

    Your advice directly above is inaccurate and may be hazardous.


    Logging in as an Admin user was supposed to be all that is required, and the poster you replied to had already made it work that way.


    Bull... I've believe I've gone through this discussion with you before and I'm not going to do it again.  If people want to listen to your paranoia then fine.  If others want to take the few minutes just to see if my method works then fine too.


    [I'm out of this discussion at this point.]

  • The hatter Level 9 (60,930 points)

    I would have to include a disclaimer,


    "There is a problem with the Memory Slot Utility" and the work-around, while it works, you should not have to use a root user account to do so, until it is fixed, this is the best we know and have learned from school of hard knocks and lots of errors and failures."


    And it likely won't be fixed on existing Mac Pro models, not via OS Lion only, not from firmware update which is where it needs to be patched.


    It may be linked to a specific EFI firmware version, but that piece of information hasn't been nailed down or pursued to know.

  • Morten Schmidt Level 1 (25 points)

    got the same here

    upgraded Macpro 8core, from 16 to 32GB, and I keep having this masageScreen Shot 2011-10-27 at 5.00.40 PM.png

    nice to know, but not everytime I boot..


    I am the only user on this mac, so I am admin, but I did the root trick with no luck, still same tning.


  • FatMac>MacPro Level 5 (4,420 points)

    Adding some data points:


    Mac Pro 6 core (5,1). Upgraded from 3 to 24 GB using OWC 8 GB DIMMs. Starting with OS 10.6.8, experimented with a couple of installs of Lion on separate partitions. One of the OWC DIMMs started to get flakey, generating the Memory Slot Utility message, which was actually a warning that my now 16 GB of RAM was in the correct slots. Same message on all three partitions appeared once. OWC promptly replaced the DIMM (remarkable customer service), new DIMM worked and am now back to 24 GB.


    However, Memory Slot message appeared once in Snow Leopard and one of the Lion partitions but continues to appear in the other Lion partition. EFI firmware version should be the same across all partitions. Am running as Admin.

Previous 1 2 3 Next