Previous 1 2 3 Next 44 Replies Latest reply: Oct 21, 2014 8:36 PM by sam b. Go to original post
  • Tom Kirsch Level 1 Level 1

    As you said, had I read your posts you would have convinced me as you did EasyRider 1976 that your solution was bullet proof.  Background: I first check the file and the .plists files had not been recreated as I thought they would be, and as you said the app was busted.  So I restored the Memory Slot Utility app from Time Capsule and verified the pesky msg did return as a user login.  Finally logging in as root user correctly and clearing the msg, then re-logging in as user did indeed clear the msg.  To verify I tested the app and it was not busted.


    You were assualted from many sides on this one and you prevailed.  I do believe you and, yes, your method is bullet-proof.  Also I learned in the process, but don't worry, as they say,  I will not attempt to be a repair tech with other peoples machines.  I will leave that to the professionals, such as yourself.

  • gPod Level 3 Level 3

    I used the Root method, it worked. Takes about 5 minutes or less.

  • t-hak Level 1 Level 1

    Grant's solution worked for me.


    1. Enable root user.

    2. Log out of current account.

    3. Log in as the root user.

    4. Click OK on the Memory Slot Utility when it appears.

    5. Log out of root.

    6. Log back in to your usual account.

    7. Disable root account.


    I had recently upgraded my Mac Pro (Early 2009, single Quad CPU, running Mountain Lion 10.8) from the factory's 6GB to OWC's 24GB. The computer worked fine, but I just kept getting the Memory Slot Utility opening shortly after login.

  • Promiceus Level 1 Level 1

    Worked for me too. Thanks!

  • Wolfgang Gaebler Level 1 Level 1

    Worked here also!



  • link6009 Level 1 Level 1

    Hi All,


    I see the spirited debate here, and I think there is value in all of these approaches.


    However, I chose a different, remarkably simpler approach, and it worked, as well as preserved the app for me in case I need to use it again in the future (for another memory upgrade...I went from 8GB to 16GB Memory).


    Here's what I did...


    Go to System/Library/Core Services/Memory Slot Utility


    and simply rename it...append it with 'temp' or something to that effect.


    So, the file is still there, only it is 'Memory Sot Utility_temp'


    This way, next time I install more memory, I can enable it so that it can report as to whether or not my configuration is okay.


    This worked for me, but I'd be interested in what others have to say about this approach.



  • Grant Bennet-Alder Level 9 Level 9

    Several Users have reported that the Memory Slot Utility popping up unexpecttedly tipped them off to a gross memory failure. Without the failed modules, the remaining memory DIMMs were not in optimum slots. Without the Utility installed and working, they would not have known there was a failure.


    For me, I will do what it takes to keep the Memory Slot Utility in place and working. When I am upgrading memory anyway is when I am willing to fiddle with it as one last step.

  • link6009 Level 1 Level 1

    Grant's Post works. I just used the 'root' approach and the problem has gone away.


    Thanks, Grant!

  • yumitsu Level 1 Level 1

    There is another one safe way to get rid of MSU.


    sudo chmod -x /System/Library/CoreServices/Memory\ Slot\
  • Grant Bennet-Alder Level 9 Level 9

    That changes its mode to non-executable.


    It will never run again and some users who copy your suggestion will not remember how to "make it go" when they need to run it again.

  • igloonaut Level 1 Level 1

    In OS X 10.8.2, deleting the following file resolved the issue on four of my systems:




    Keep in mind that this is the /Library/Preferences folder at the root level of your hard drive, not the one in your user folder. This solution may work for other versions of OS X as well.


    Other thoughts:

    -If the above fix doesn't work for you, and you need to enable the root user, remember to go back and disable the root user when you're done.


    -The Memory Slot Utility is not the issue here, it's being triggered by an external process. Moving the Memory Slot Utility or otherwise disabling it may prevent you from seeing future legitimate warnings about incorrectly or non-optimal memory installations. It would be like disabling your automobile's "check engine" light because there is an issue with your engine.

  • calipvp Level 1 Level 1

    Go to System/Library/Core Services/



    Memory Slot


    Memory Slot




    Let's keep it easy.


    If you add memory later remove the .old


    Screen Shot 2013-02-26 at 7.45.24 PM.png

  • osmanthus Level 1 Level 1

    I've just upgraded my Mac Pro 5.1 from 8GB (2GBx4) to 24GB (8GBx3) and like others I experienced the exact same problem.

    With two user-accounts installed ("admin" and a "normal" account; the latter being the one I normally log into) I followed the instructions of logging out of my normal account and into my admin account where the same message popped up. I clicked the message's "OK" button to dismiss it, rebooted (into my normal account) and no message popped up. So I can confirm that this works (at least for me).


    I've only just installed the new memory and rebooted a few times, but so far so good.

    I'm using OSX 10.6.8. Snow Leopard.

  • Grant Bennet-Alder Level 9 Level 9



    You have found it!




    Screen shot 2013-03-01 at 11.10.04 AM.png


    If the permissions on that file are such that it is not System Writeable, it cannot be updated after you dismisss the alert, and so the alert does not go away.

  • sam b. Level 1 Level 1



    I think that a long time ago I ran the Terminal command to make MSU a non executable. You are absolutely correct when you pointed out that some users like me may not be able to remember how to undo the mistake. You wouldn't happen to know the command to "make it go" again? I have seen two versions of the "stop" command:

    1) sudo chmod -x /System/Library/CoreServices/Memory\ Slot\


    2) sudo chmod -x "/System/Library/CoreServices/Memory Slot"


    Not too sure which I used though .........

    Thanks for any thoughts you may have,



Previous 1 2 3 Next