14 Replies Latest reply: Apr 16, 2011 11:48 PM by reekkeek
reekkeek Level 1 Level 1 (0 points)
Please help..

I am working in Iweb 3.0.03 on a macbook (chrome installed)..

When I set the colours of the hyperlinks they are in grey but when I ftp the pages all the browsers change the hyperlink text to red? How can I stop this from happening? I am formatting the colours and on my macbook and everything looks how it should how I upload?

Could anyone please help..

Many thanks

macbook, Mac OS X (10.6.2), snow leopard
  • Old Toad Level 10 Level 10 (121,930 points)
    What's the URL of your site so we can examine it first hand? What color combination should we be seeing?



    OT
  • reekkeek Level 1 Level 1 (0 points)
    Thanks so much for getting back

    the url is http://www.spaceuk.biz

    the hyperlinks should be dark grey, rollover in black and already visited in red.

    Thanks for looking and trying to assist..
  • Old Toad Level 10 Level 10 (121,930 points)
    Which links are you referring to? The navbar at the top, those at the left, About thru Contact?

    Those at the left, the About thru Contact, are the correct color in my Chrome V 10.0.648.204. The others are the same in both Safari and Chrome also but just not the colors you describe.

    Try clearing the cache files in Chrome (Preferences ➙ Under the Hood ➙ Clear Browsing Data button) and reload the site.

    Message was edited by: Old Toad
  • reekkeek Level 1 Level 1 (0 points)
    Hi there,

    That's the problem.. why are they not the colours I have chosen?

    In Firefox and Safari and Camino some of the hyperlinks are red and some are grey and it looks awful and really shoddy. How can I stop this from happening? Have you heard of this problem before?

    Thank you once again for assisting me. It's very kind of you.
  • Old Toad Level 10 Level 10 (121,930 points)
    Try the following:


    1 - close iWeb.
    2 - delete the iWeb preference file, com.apple.iWeb.plist, that resides in your Home/Library/Preferences folder.
    3 - go to your Home/Library/Caches/com.apple.iWeb folder and delete the contents.
    4 - reboot.
    5 - launch iWeb and try again.
  • reekkeek Level 1 Level 1 (0 points)
    Thanks for that..

    Before I do.. Is all of my web site contents going to be safe... ? I don't want to do that and the web site is gone

    Please reassure me first LOL
  • Old Toad Level 10 Level 10 (121,930 points)
    No. I won't affect your web site which is contained in a file named Domain.sites2 and located in your Home/Library/Application Support/iWeb folder.

    However, you can always make a temporary copy of that domain file before trying the fixes just to be on the safe side.
  • reekkeek Level 1 Level 1 (0 points)
    Hi,

    I tried your suggestions and it's still changing the text to red..

    check the site now.. http://www.spaceuk.biz

    I think maybe I,ll have to try and get rid of the red altogether and see if that makes any difference.

    Thanks anyway.
  • Old Toad Level 10 Level 10 (121,930 points)
    Are all of the hyperlinks at the left supposed to have the same color format? If so select one, reset all of the colors and click on the *Use for New Links on Page* button. Then publish your site to a folder on your hard drive and check it locally with your browser to see if the colors are as they should be.

    Are you hosting your site at a 3rd party server or on a MobileMe account? If it's a 3rd party hosting server publish to a folder on your hard drive and check the site locally with your browser. If the colors are good then the problem lies in the uploading of the file.

    H\how are you uploading the files? With iWeb or a 3rd party FTP client? If it's iWeb try using the free FTP client Cyberduck to upload the site folder and the index.html file.
  • David L Phelps Level 3 Level 3 (660 points)
    It looks to me that the colors are as they should be. You have "visited" set to red, so after you click the link, then those links turn red. All your links started out grey for me. Each time I clicked a link, that link turned red. This is as it should be. If you don't want them to be red after you visit the page, set the inspector "visited option" to grey, that way they will always be the same except upon roll over.

    Sincerely,

    David
  • reekkeek Level 1 Level 1 (0 points)
    Thank you David..

    What browser are you on?

    That's very strange as on Chrome, Firefox and Camino the colouring is all over the place?? I may just have to do as you say and make the visited links the same colour as normal just to get around this problem.

    Thanks for looking and trying to assist
  • reekkeek Level 1 Level 1 (0 points)
    Yes, all hyperlinks on every page are meant to be the same colour format.

    I use transit as an ftp

    I might just change all the colouring to look the same..

    Thanks alot
    -------------



    Are all of the hyperlinks at the left supposed to have the same color format? If so select one, reset all of the colors and click on the Use for New Links on Page button. Then publish your site to a folder on your hard drive and check it locally with your browser to see if the colors are as they should be.

    Are you hosting your site at a 3rd party server or on a MobileMe account? If it's a 3rd party hosting server publish to a folder on your hard drive and check the site locally with your browser. If the colors are good then the problem lies in the uploading of the file.

    H\how are you uploading the files? With iWeb or a 3rd party FTP client? If it's iWeb try using the free FTP client Cyberduck to upload the site folder and the index.html file.
  • David L Phelps Level 3 Level 3 (660 points)
    I'm on Safari on a mac.

    Are you using web safe colors?

    David
  • reekkeek Level 1 Level 1 (0 points)

    Hi David,

     

    Yes, all web safe colours..

     

    I gave up trying to do a different colour when visited and made it the same as the normal colour. works .. Thanks guys..