8 Replies Latest reply: Jul 23, 2012 1:58 AM by clintonfrombirmingham
defmuse Level 1 Level 1 (0 points)
Okay, so I have a brand new MacBook Pro, running the latest OS. Now, for some reason, I keep getting this error notice: "System Extension cannot be used."

I've been through DISK UTILITY, verified and repaired all "disk permissions," as well even "verified disk" (although nothing wrong or damaged have been found). I have even gone as far as ERASING my entire disk and RE-installing everything. However, no luck.

The thing is, verifying and repairing the disk permissions DO help, but there are still a number of extensions that do NOT get repaired. I don't know if this is significant, but I've had this problem 4 times in a row now, and after repairing the disk permission, the SAME EXACT extensions keep popping up as errors:

"System Extension cannot be used"

/System/libraryextensions/BJUSBLoad.kext
/System/libraryextensions/EPSONUSBPrintClass
/System/libraryextensions/hpdesignjetseries
/System/libraryextensions/hpDeskjet_ioenabler
/System/libraryextensions/hpfaxio
/System/libraryextensions/hpinkjet1_ioenabler
/System/libraryextensions/hpinkjet3_ioenabler
/System/libraryextensions/hpinkjet4_ioenabler
/System/libraryextensions/hpinkjet7_ioenabler
/System/libraryextensions/hpinkjet8_ioenabler
/System/libraryextensions/hpinkjet_ioenabler
/System/libraryextensions/hpio_printerclassdriverenabler
/System/libraryextensions/hpOfficejet_ioenabler
/System/libraryextensions/hpPhotosmart_ioenabler
/System/libraryextensions/hppsa640_ioenabler
/System/libraryextensions/hpqc_ioenabler

FYI: my ipod touch doesn't synch with itunes after the above errors are displayed, and I have to re-download itunes.

What do I do? Why is this happening? Is there a way to fix these extensions? Is this happening possibly due to 3rd-party plug-ins being used (am using Spectrasonics Trillian and Omnisphere with Logic Pro 9 - although this is running perfectly on my iMac AND on another MacBook Pro)?

Any help would be GREATLY appreciated, as I've got no more hair to pull out due to frustration! Thank you in advance!

MacBook Pro (2011 model), Mac OS X (10.6.6)
  • Kappy Level 10 Level 10 (252,820 points)
    Looks as though you may have installed a bunch of incompatible printer software - Bubble Jet, Epson, and HP.
  • defmuse Level 1 Level 1 (0 points)
    But that's the thing: I haven't installed anything besides that from the OS X Install DVD, the Applications Install DVD, and Logic Pro 9 with a few 3rd party plug-ins. I don't even own a printer.
  • Kappy Level 10 Level 10 (252,820 points)
    After you Repair Permissions (not Verify) do you do a restart? If you don't restart then the extensions will continue to report a problem until all the warning dialogs are dismissed. However, I suggest you locate and delete the named extensions. They are located in the /System/Library/Extensions/ folder. You have to select them then CTRL- or RIGHT-click and select *Move to Trash* from the contextual menu. Do not try dragging them to the Trash. Then reboot.
  • defmuse Level 1 Level 1 (0 points)
    Yup, had restarted the Mac after the permissions had been repaired. Once restarted (all 4 times I've had this problem), all permissions and extensions had been repaired EXCEPT the ones written above in my original post.

    I had, the first couple of times this problem occurred, also done what you suggested: deleting the un-repaired extensions. However, for some reason, it started messing with my iTunes (don't ask me how these are related!)... my ipod would not show up, and a few other small issues with itunes... all of which were dealt with by downloading and installing itunes again.

    Nonetheless, all this was for not, 'cause the exact same extensions problem arose once more a couple of days later. Hence my frustration.
  • RoCa Level 1 Level 1 (0 points)

    Hello,

    I have had the same problem for years now. It is a PITA.

    Each time I install something I have got a bunch of hundreds or errors :

    "system extension cannot be used..."

     

    Here is a short sample of them

    «/System/Library/Extensions/3Dconnexion.kext

    «/System/Library/Extensions/AppleAirPort.kext

    «/System/Library/Extensions/AppleAirPort.kext

    «/System/Library/Extensions/AppleAirPort.kext/Contents/PlugIns/AppleAirPortFWAP. kext

    «/System/Library/Extensions/hp_designjet_series.kext

    «/System/Library/Extensions/hp_Deskjet_io_enabler.kext

    «/System/Library/Extensions/hp_fax_io.kext

    «/System/Library/Extensions/hp_Inkjet1_io_enabler.kext

    «/System/Library/Extensions/hp_Inkjet3_io_enabler.kext

    «/System/Library/Extensions/hp_Inkjet4_io_enabler.kext

    «/System/Library/Extensions/hp_Inkjet5_io_enabler.kext

    «/System/Library/Extensions/hp_Inkjet8_io_enabler.kext

    «/System/Library/Extensions/hp_Inkjet_io_enabler.kext

    «/System/Library/Extensions/hp_io_printerclassdriver_enabler.kext

    «/System/Library/Extensions/hp_Laserjet_io_enabler.kext

    «/System/Library/Extensions/hp_Officejet_io_enabler.kext

    «/System/Library/Extensions/hp_Photosmart_io_enabler.kext

    «/System/Library/Extensions/hp_PhotosmartPro_io_enabler.kext

    «/System/Library/Extensions/hp_qc_io_enabler.kext

    «/System/Library/Extensions/HuaweiDataCardDriver.kext

    «/System/Library/Extensions/LexmarkUSBMerge.kext

    «/System/Library/Extensions/NovatelWireless3G.kext

    «/System/Library/Extensions/NovatelWireless3G.kext/Contents/PlugIns/NovatelWirel ess3GData.kext

    «/System/Library/Extensions/NovatelWirelessFilter.kext

    «/System/Library/Extensions/OSCulatorIOKit.kext

    «/System/Library/Extensions/RDUSB0009Dev.kext

    «/System/Library/Extensions/USBExpressCardCantWake_Huawei.kext

    «/System/Library/Extensions/Wacom Tablet.kext

    «/System/Library/Extensions/ZTEUSBCDCACMControl.kext

    «/System/Library/Extensions/ZTEUSBCDCACMData.kext

     

    But worse : all my new machines have been infected by the same error, because I did copy the oleder machine when installing them. Apple does not seem to care about this problem.

     

    The solution should probably be that apple should make a fix, looking for old and uncompatible extensions and delete them or get the new ones from all the makers.

    Apple! Who is going to face the problem ?

     

    RC

  • clintonfrombirmingham Level 7 Level 7 (29,975 points)

    You could do as Kappy suggested over a year ago and take out the extensions from your System/Library and restart to see if that will solve the problem. You have a ton of HP extensions that could be outdated, one for a Wacom tablet, a wireless adapter, some sort of "Huawei" data card driver, etc. Doesn't sounds like an Apple problem as much as some (possibly) old extensions that may need updating or could be deleted.

     

    Clinton

  • RoCa Level 1 Level 1 (0 points)

    Thanks Clinton,

    That sems to work.

    I reckon I hesitated trashing extentions.

     

    So the general solution to the system "extension cannot be used" problem seems to be :

     

    1) Copy manually the names of all extensions (.kext) from error messages in a text file (or find them one by one)

    2) Trash these extensions

    3) Empty trash

    4) Restart

     

    In case of problem with applisations I suppose you may have to update specific installs, but I suppose they would tel you to do so wen launching.

     

    Best regards

    RC

  • clintonfrombirmingham Level 7 Level 7 (29,975 points)

    Glad it worked - the kudos should really go to Kappy!

     

    Clinton