6 Replies Latest reply: Apr 14, 2011 10:27 PM by Madridfanatic
Madridfanatic Level 1 Level 1 (0 points)
Hello:

I am currently working on a project using Final Cut Studio 2, and I was able to send a clip to Motion 3 via Send To -> Motion Project... From there, I was able to apply the Optical Flow analysis on my selected clip successfully. I even to a RAM Preview to see how my clip looks like.

However, after I click Save and return to my Final Cut Pro 6 timeline and Render my Sequence, the clip with the label .motn that I used Optical Flow does not show any evidence of the Frame Blending. In fact, the clip looks choppy, as if I didn't analyze the clip in Motion.

Am I missing a step here in order to get Final Cut Pro to recognize and play my Optical Flow clip? I'm not sure what else to do ...

Thank you

iMac, Mac OS X (10.6.7), 2.4 GHz Intel Core 2 Duo
  • 1. Re: Optical Flow
    Alan Apple Mac Level 1 Level 1 (130 points)
    One thing I tend to do when using optical flow is:

    a) save the clip which will save it back into FCP
    b) move that clip to a higher track that has visibility turned off as I will not use this but it is handy as a backup.
    c) Render out the clip from within Motion and just import back into FCP.

    The reason I do this is two fold - first I used to get some stuttering a while back by doing what you have just done (rendering out solved that) and second you have a baked clip which cuts down the overhead and you always have it for any sequence if needed. Oh and hird it is very quick to do

    Worth a go to see if it fits in with your workflow.
  • 2. Re: Optical Flow
    Madridfanatic Level 1 Level 1 (0 points)
    Hi Alan:

    Thank you for your reply. When you say "Render out the clip from within Motion", do you mean Export? I've actually started to try that last night, Exporting my Frame Blending Optical Flow clip from Motion using the Apple Pro Res codec as a .mov file. Then, I import that new .mov file into FCP.

    That seems to work, although this is the first time I have had to try that option. However, I don't think that fixes the underlying problem: being able to Send To Motion as a project, perform Optical Flow, Save, and then return back to FCP to Render and see my footage with Optical Flow. This seems to be a quick round-about fix as opposed to a solution.

    Any ideas why FCP is not recognizing my .motn Motion project using Optical Flow? I bet if I do any other edits (such as graphical effects), that may not be recognized in FCP.
  • 3. Re: Optical Flow
    Alan Apple Mac Level 1 Level 1 (130 points)
    Yes, that is what I meant "Export" - like I said for me it works well for the reason I stated and at least it gets you back editing till you get an answer to the underlying problem you are experiencing.
  • 4. Re: Optical Flow
    Patrick Sheffield Level 7 Level 7 (29,175 points)
    Unless your timeline in FCP (⌘0) is set to Best render for Motion files, you will not get the optical flow render.

    Patrick



    P.S. Welcome to the discussions
  • 5. Re: Optical Flow
    Madridfanatic Level 1 Level 1 (0 points)
    Hi Patrick!

    Thank you for the insight! I think that actually worked. Using ⌘0 (or Sequence > Settings...), I clicked on Render Control, then under Master Templates and Motion Projects, toggled the Quality: to Best.

    I Render All on my Sequence timeline, and voilà, I can see my embedded .motn clips in all their Optical Flow glory!

    For future reference, I also went to Final Cut Pro > User Preferences > Render Control, and made the same changes under Master Templates and Motion Projects under Quality: Best.

    Thank Patrick and Alan for both your help!! :-D
  • 6. Re: Optical Flow
    Madridfanatic Level 1 Level 1 (0 points)
    Underlying problem solved via User Settings > Render Control > Master Templates and Motion Projects > Quality: > Best