Previous 1 2 3 Next 30 Replies Latest reply: Mar 25, 2006 11:49 PM by Doug Dellis
Doug Dellis Level 1 Level 1 (5 points)
Hi!

I've been using my iMac G5 with no problems for months now, but suddenly I've noticed that the volume controls on my keyboard don't work. Let me explain:

Upon pressing either the "volume up" or "volume down" buttons on the mac keyboard, the semi-transparent volume indicator appears on my screen, and the small white "cubes" indeed go "up and down," but there is no audible feedback, and the volume itself does not change. In short, I'm now forced to use the menubar volume slider to change my volume.

The following should be noted:

1) All of the other keyboard buttons work normally (brightness, expose, etc).

2) I have checked the sound preference pane, and nothing has changed--the preferences were exactly the same as when the buttons were functioning (ie: volume change "feedback" is checked, etc)

3) I recently added a new printer, but that was a month ago, and the volume controls have worked normally after installation for weeks--so that is not the problem.

4) I have repaired disk permissions several times.

5) I have started from the system CD and repaired the disk.

6) I have re-set the PRAM 3 times. Once, the volume control was restored, but it was subsequently lost again, and was unable to be recovered with further PRAM resets.

7) I have not installed/used any new programs and/or software in months.

Can someone please help with this? I know it's not an earth-shattering problem, but the buttons should work, and I've become reliant on them since my iMac purchase.

Thank you in advance!

Doug

iMac G5 2ghz, Mac OS X (10.4.3), 512 RAM
  • a brody Level 9 Level 9 (64,035 points)
    If you have Application Enhancer installed, you may need to update it. Check to make sure that your audio input and output are correctly set in Apple menu -> System Preferences -> Sound.

    Also check this User Tip:

    http://discussions.apple.com/thread.jspa?messageID=607533&#607533
  • Doug Dellis Level 1 Level 1 (5 points)
    Thanks for your info, but the problem still occurs... Here's a rundown of what I did in response to your suggestions:

    1) I do not have Application Enhancer installed, so that's not an issue.

    2) As I mentioned in my first post, my sound preferences are in the same state as they were before this problem began, so that also doesn't seem to be the issue.

    Also--As far as the document you pointed me towards goes:

    1) My keyboard is basically new, so there's no dirt. Besides, since I'm getting on-screen (false) feedback re: volume, the button itself is obviously functioning.

    2) The "keyboard" and "universal access" preference panes are in the same state they were in before the issue began--and they don't look to be the problem.

    3) "International" Keyboard settings are indeed set to US English, as they were when I bought the machine.

    4) As stated above, I do not have Application Enhancer.

    5) I do not use speech recognition, so that's not applicable.

    6) I just downloaded and installed the newest logitech driver for my mouse (a simple, 2-button USB mouse which was working perfectly before the issues began), and initially, the volume seemed to come back--but as before, the problem occured again.

    FYI: The volume button seems to return to normal functionality randomly after any restart-related actions (shut down, restart, P-RAM, reset permissions, etc), but nothing makes it CONSISTENTLY return to functionality.

    If anyone has any additonal thoughts as to why this is happeneing, please share! And please refer to my initial post to get any information you may need.

    Thanks in advance, everyone!

    Doug
  • a brody Level 9 Level 9 (64,035 points)
    If the problem began after installing those Logitech drivers, that would be my key suspect.
  • Doug Dellis Level 1 Level 1 (5 points)
    No, you mis-read my post. the problem has been occuring BEFORE and AFTER that recent installation. I tried a new installation because the Apple.com support document you pointed me towards suggested I try that to rectify my volume button issues--it did not.

    If anyone has any thought on why this is happening, please share. And again, please feel free to refer to my original two posts for details!

    Thanks all!!




  • Diane Benoît Level 2 Level 2 (360 points)
    I would try running Alsoft's DiskWarrior. It does wonders to the directory as it rebuilds it.

    You could also use Titanium Software's freeware OnyX (choose the right version for your OS X version to clean out a clogged system).

    And there is always Preferential Treatment to fish out corrupted pref files.

    That's about all I can think of at the moment.
  • Doug Dellis Level 1 Level 1 (5 points)
    Hi Diane! I just wanted to give you an update after reading your last post:

    I didn't bother using Diskwarrior--partly because they don't offer a free trial, and partly because I've heard as many real-world horror stories as I have real-world good reviews of that product (both from colleagues): I didn't feel confident trying it at this point

    That being said, I have used "preferntial treatment" in the past, so I tried that first. I noticed my Logitech preferences came up, but there was no OVERT indication that they were problematic, etc. Rather than take any chances, I trashed them. Unfortunately, after restart, the volume problem seemed to persist

    I then tried ONYX, checking just about every "system optimization" option in the menu. After restart, the volume button began working again. I've used other optimization tools before, but this seemed to have at least some effect.

    It's been several days, and the volume button is still working. I'm not sure if it was a combination of preferential treatment AND ONYX, or just ONYX, but I'm keeping my fingers crossed that my system works cleanly from this point on.

    Thanks again,

    Doug
  • Robert Wolf Level 2 Level 2 (210 points)
    Are you using any "Classic" applications?

    iMac G5 20" iSight & eMac 1.25 Ghz   Mac OS X (10.4.3)  
  • Doug Dellis Level 1 Level 1 (5 points)
    FYI: after a week of having no problems, the volume key stopped working again.

    I was forced to use ONYX again, and it seems fixed... FOR NOW.

    BTW, I noticed this recent occurance of the problem happened after running Windows Media Player... However, I've had Windows Media Player on my iMac for 8 months--and it's never caused any problems. I can't imagine it would suddenly cause the volume button to stop working this week.

    If anyone has any other suggestions (aside form just re-optimizing my mac every time the key stops working), let me know.... thanks!
  • Doug Dellis Level 1 Level 1 (5 points)
    I haven't launched/used a single classic app since taking the iMac out of the box months ago...
  • Doug Dellis Level 1 Level 1 (5 points)
    oh well... sigh
  • Doug Dellis Level 1 Level 1 (5 points)
    Update: This issue still persists, in case anyone has any other input.

    Thanks again!
  • E Leerentveld Level 2 Level 2 (230 points)
    When this happens to me, I just launch Garageband and close it again. That reinitialises the soundsystem and it works ok again.

    Good luck!
  • Doug Dellis Level 1 Level 1 (5 points)
    Hi "E!"

    First of all, thanks for the tip. I was just hoping someone would know how to stop it altogether

    That being said, I'll try your trick the next time this happens...

    Doug
  • Doug Dellis Level 1 Level 1 (5 points)
    E--

    I tried your idea recently, and launching GarageBand does NOT rectify this issue. Thanks for the suggestion, however.

    So, for the record, this problem still persists!

    Doug
Previous 1 2 3 Next