7 Replies Latest reply: Jan 28, 2013 3:05 AM by MrHk
Doug Huebner Level 2 Level 2 (200 points)

I have a Canon Pixma MP980 connected that I access through wireless connections fro two computers. It worked fine until the recent Canon driver update. Now every time I try to print a dialogue box pops up asking if I want to allow incoming connections. It goes away after a few seconds. If I do not move fast and click yes, printing fails because communications between the printer and driver are cut off - at least coming back from the printer. If I do click yes, then it works fine.

 

I have seen the "allow incoming connections" dialogue when using new programs for the first time, but once I click yes or no, it does not ask again and works appropriately. With the Canon diver, I am asked every time I try to print.

 

In the security>firewall  preferences printer sharing and all Canon entries are set to allow incoming connections.

 

The computer that does not have the "updated" driver continues to work fine.

 

Is there a cure or a way to undo the driver update that Software Update just installed? Reinstalling the driver that came with the printer is a real pain that I would like to avoid.


iMac intel 24" MacBook (10.5.8), Mac OS X (10.6.1), canon printer & scanner
  • 1. Re: Wireless printer problem w new canon driver
    Mark2006 Level 1 Level 1 (5 points)

    I am having the same problem with both my canon printers.  Both are wireless.  (MX860/MX340).  I have tried checking the security preferences but they are all green and allowing incoming connections as well.

  • 2. Re: Wireless printer problem w new canon driver
    PAHU Level 6 Level 6 (14,520 points)

    I just tested the new v10.42.1.0 driver, which is from the Canon Driver Update v2.5, to my wireless MP990 and with the Firewall enabled and only the setting "Automatically allow signed software" enabled I was able to print without a problem.

     

    Do you have the "Block all incoming connections" enabled? I did not test this because a warning appeared stating that all my shared services would be blocked. Also, for the record, I also don't normally use the built-in firewall as I have Intego's VirusBarrier X6 installed which has its own firewall app. So after the recent Canon driver update I never encountered the issue you and the OP are having.

     

    Also, reading your post, you mention the security preferences being all green and the applications set to allow incoming connections. With my test no Canon driver/utility was added to this exception list. If you have some Canon entry in the list, I wonder if this could be a left-over from the previous Canon driver and now it is not needed with the latest driver (as they are now signed to receive incoming connections)? So if you remove the Canon entry from this list does this let you print without being questioned?

  • 3. Re: Wireless printer problem w new canon driver
    Doug Huebner Level 2 Level 2 (200 points)

    I do not have "Block all incoming connections" set. I do have "Automatically allow signed software"  and enable Stealth mode" set.

     

    The Canon entries in the list are enabled and I believe they may be for the other Canon scanner that I have connected.

     

    I tried the integrated scanner on the MP980 and it also asks for permission to allow incoming access. I have also tried printing multiple documents quickly and am asked for permission for each document. 

     

    It appears that as soon as a document is printed, it goes into pause mode. When I tried to click on the arrow to make it active with no pending document, it says that I do not have authority, that I must be an admin. I am the admin and am logged in as such. I have repaired permissions recently but will try that again.

     

    I tried changing the access on the printer application and it allowed me to make it active after entering my password, but it still wants permission to allow incoming access each time I print. And goes back to paused mode.

     

    I did not update the driver on the Macbook Pro and it still works fine, so it seems the issue came with the update, which I now wish I had avoided.

  • 4. Re: Wireless printer problem w new canon driver
    Mark2006 Level 1 Level 1 (5 points)

    I  tried what PAHU suggested, I removed all of the Canon utilites from the security preferences exception list.  My printer works fine, no dialogue boxes and no communications problems. 

  • 5. Re: Wireless printer problem w new canon driver
    Doug Huebner Level 2 Level 2 (200 points)

    Thanks Mark for trying it and PAHU for the suggestion. It now appears to work for me also. I will have to try the scanner sometime to see if it still works. I use it rarely and have another scanner so it is not a big deal

     

    Thanks again

  • 6. Re: Wireless printer problem w new canon driver
    Shifty85 Level 1 Level 1 (0 points)

    It seems as though PAHU's suggestion to delete the Canon utilities from the exception list worked for me as well! Pay heed.

  • 7. Re: Wireless printer problem w new canon driver
    MrHk Level 1 Level 1 (0 points)

    Canon Pixma MX868 Scanning Issues

     

    Interesting, I am using Canon MX868 printer with Driver 10.67.1.0 (latest driver from canon for OSX 10.8.2) and have the same problem.  When I initially installed software all worked fine but when I activated the firewall and removed the “Canon IJ Network Scanner” from startup (login) services I started getting the error message

     

    I am not convinced that removing exceptions from firewall will make problem go away (as they are needed for firewall to work and will be added back in by default next time you allow permission). Nb Pahu was not using apple firewall

     

    Anyway here is what I did to cause and then resolve the problem

     

    I updated the driver and software to use Canon MR Navigator Ex 2.1 scanning software.  I prefer the canon software as I can scan from printer by pressing buttons with more advanced scanning PDF JPG features (than basic bonjour scaner which creates big files and is clunky to use). 

     

    After reviewing above, I removed exceptions from firewall (see below).  However every time I restarted the computer or restarted the Canon MR Navigator Ex 2.1 scanning software I still got the "allow incoming connections" window and scanner would not work until I allowed this.

     

    Here are the changes I made to Firewall Settings (the firewall options is under System Preferences / Security & Privacy you will need to press unlock button and use admin password to show firewall options):

    -   block all incoming connections - not ticked

    -  automatically allow signed software to receive incoming connections (ticked)

    - enable stealth mode - unchecked

    - I kept then removed all canon utilitiy permissions in firewall (nb if you remove but then "allow incoming connection" the exception  will reappear in the firewall exceptions), also if you remove other apps exception permission eg iphoto you will need to add permission back in)

     

    After I had done above and restarted a few times to test (unsuccessfully) I tried adding the Canon IJ Network Scanner app back into the login items (login items under system preferences/ User & Groups). When I restarted it asked for permission once more and from then on the Canon IJ Network Scanner loaded and allowed full scanning from computer and from printer buttons

     

    To add the Canon IJ Network Scanner app to login items, press “+” button then browse to the following file under the Main Library of  Mac HD:   /Library/Printers/Canon/IJScanner/Utilities.  Nb the main library has  full range of apps where as the User Library (located under your User profile /Users/[USERNAME]/Library) does not have the “Canon IJ Network Scanner app” (this confused me for a while)

     

    Another way to resolve the problem was to turn the firewall off (but I prefer it on)

     

    After several restarts with Canon IJ Network Scanner running in login items with out problem, I rechecked enable stealth mode and selected “allow applications downloaded from” “,mac store and identified developers” (under General Tab). The scanner and network tool still worked fine with no error messages