8 Replies Latest reply: Apr 19, 2011 9:11 PM by secretmak
secretmak Level 1 Level 1 (0 points)

Just get a spinning loading icon, then nothing happens after I click the buy or update buttons for an app.  I guess apple doesn't want my money.


MacBook Pro, Mac OS X (10.6.7)
  • Dah•veed Level 7 Level 7 (32,245 points)

    Perhaps your MAS app has been corrupted. Drag & Drop it in the Trash. Restart and empty the Trash.

     

    Download and install the Mac OS X 10.6.7 Update Combo and it should install a new MAS app.

    http://support.apple.com/kb/DL1361

  • Docwok Level 1 Level 1 (0 points)

    I Am having the same problem.

    App download hangs indefinately.

     

    I am running 10.6.7.

    repaired permissions

    Cleaned out library files as recommended. Installed combo over exsisting 10.6.7. restart.

    Mac App store loads fine but will not download. (whether signed in or out)

     

    Specifically, When you choose to purchase, a spinning 'gear' starts at the top lft of the window header bar and continues to run. I have left it running for 30 minutes at times wondering if its a traffic glitch at the server.

     

    Internet connection via Airport and via Ethernet cable has same results.

     

    Logging off and on makes no difference.

     

    Itunes store works perfectly.

     

    drag dropped to trash restart and reinstall cobo again....

    but nothing changes for the app store 4 me

     

    opening app store from itunes has no benift either.

  • Carolyn Samit Level 10 Level 10 (95,975 points)

    Hi,

     

    Help for troubleshooting the Mac App Store at this link.

     

    http://support.apple.com/kb/TS3624

     

     

     

     

     

     

     

     

     

    Carolyn 

  • Docwok Level 1 Level 1 (0 points)

    Thanks Carolyn but I have seen this recommendation and  been at this problem for more than 30 hours now and have Digested all the Troubleshooting tips, tried  all of your current recommendations, as well as those of Dah veed and tried the obscure fixes from jeffs thread and Uptimistik(?) repair.

     

    I have booted in Safe and fixed permissions, etc, etc, I have replaced the file and done the Combo install a few different ways- as per recommendations.

     

    Restarted my home modem w/wo router.

     

    I am not running Bootcamp.

     

    running a core 2 Duo @ 2.4 GHz macbook, with 4 GB ram and OS 10.6.7.

     

    as I stated I have tried cabled connection and airport.

     

    Itunes works flawlessly !!!!!!!!

    i do not get any messeges.  Just the spinning gear perpetually rotates after attemt to buy.

     

    I have NOT tried to create a new Apple ID.  However I will try that as well since I am totally out of current options and exhausted with the effort at this point.

     

     

    So far I have only seen 3 people listing this specific Symptom so I suspect I have some sort of Issue with my Software and Its not Apple. I have done all the Updates and so forth....I am really just so close to giving up or going to a genius. 

     

    In almost 25 years my mac has never frustrated me like a PC...pulling at my hair and yelling...that is untill now.

     

     

  • Docwok Level 1 Level 1 (0 points)

    Additionally Keychain settings are off.

     

    Starting a new account had no benefit

     

    Its probably something wrong in my settings but ....

     

    I am so done with the Mac app store!

  • secretmak Level 1 Level 1 (0 points)

    I figured it out for me after trying every solution out there it was actually pretty simple...I installed "Hands Off!" app which is a firewall type of tool much like Little Snitch and the various Apple related MAS internet permissions were turned off in the program.  I set them to "Allow" and now everything is working fine.  Hope this helps others.

  • Dah•veed Level 7 Level 7 (32,245 points)

    A US$25 app seems a bit drastic. Are you saying that this app is now controling your Mac's Firewall and this has resolved your issue? If so, what ports in your Firewall were obstructing your usage of the Mac App Store?

  • secretmak Level 1 Level 1 (0 points)

    Sorry, I should have clarified "Hand's Off!" settings were blocking MAS from communicating from Apple, which was the cause of the spinning wheel.