Previous 1 2 3 Next 69 Replies Latest reply: Sep 26, 2013 2:33 PM by Chris Watts1
himynameismarek Level 1 Level 1



I have an early-2008 MacBook Pro 4,1; 17" 2.5GHz Core2Duo and I upgraded the hard drive to a Kingston SV100S2 128GB SSD drive.


It worked perfectly for the first 4 months after purchase but 3 weeks ago the problem started when I tried to start my MBP and the grey Apple logo appeared with a kind of progress bar underneath it and then it would just power off (SMC and PRAM reset didn't help). The disk utility showed an "invalid node structure" problem which it wasn't able to fix and later the disk would be unreadable. Since the first time, this has recurred about 6 times. Each time I had to format the drive, install Mac OS X 10.6.3 again from either original DVD or it's image on hard drive (which is much faster), and transfer files from a Time Machine backup.


The drive would subsequently fail again after a couple of days each time. I have discovered that Kingston has released and official URGENT firmware upgrade, which I have installed after the 3rd failure, but it apparently didn't help. Also disabling hibernation and sudden motion sensor had nothing to do with it. Last time it failed (today), I was installing some updates and it failed after I was restarting, but I don't think it has anything to do with it either.


I am taking the drive back next morning to the retailer, where I bought it cheaply as a business owner, and I will ask them for a replacement, however I am still not sure if it could be my mac causing this chaos with the drive or the SATA cable being faulty.


I would welcome and be thankful for any constructive thoughts. Right now I had to replace the drive with the original one and everything is literarily at least 5 times slower and takes as much longer time to load, what is really bothering me. Thanks again.


Marek (Slovakia/UK)

MacBook Pro 17" 2.5GHz Penryn, Mac OS X (10.5.3)
  • himynameismarek Level 1 Level 1

    and btw, I have used DiskWarrior before to restructure the drive. It lost some files and managed to make it readable, but the system was just noticably slower, same as if I would restore from an image or another drive. It has to be installed freshly and transferred, in order to run at full speed.

  • dechamp Level 4 Level 4

    I would have recommended Diskwarrior, but now that you mention you've used it, then I suspect the drive is either already damaged, or the firmware is still incompatible with your Mac. Hopefully you are keeping good Time Machine backups for your user account.


    Getting a new drive would probably be the best advice, and making sure the latest firmwares are installed is always a good idea. Who knows... maybe the old firmware caused the damage. SSD manufacturing methods and drive/file management firmwares are really still in development. Even Apple's support for TRIM is limited to drives they provide.


    For the best support for Macs and hard drives I use OWC. They stand behind their products and provide great technical support. My problem is that the larger drives are just too expensive to play with just yet.


    SSD's are very attractive, and I'll keep looking, but I can't depend on one for my existing Mac's in a business as a boot drive.

  • Linc Davis Level 10 Level 10

    I am still not sure if it could be my mac causing this chaos with the drive or the SATA cable being faulty.


    You could try running the Apple Hardware Test from the Applications disc that came with your Mac. It's not very reliable, though. The only way to be sure is to replace the SSD with a known-good one.

  • tomlon Level 1 Level 1

    Hi, I ran into exactly same problem (MacBook Pro + Kingston SSDNow V100 Series 128GB).

    I published a detailed description in the following forum (it is in Czech but you as a Slovak will understand):,5188215


    Not even a Kingston SSD firmware update solved the problem.

    The only way was using DiskWarrior and even that did not solve the problem in all cases it happened.


    I will ask the seller for replacement and next time I will choose another SSD brand (probably Intel or OWC).

  • The hatter Level 9 Level 9

    There is some work to be done to restore SSD runnning OS X; and there is a 3rd party TRIM diver but a lot of SSDs really need new firmware, even OWC with theirs has only recently provided the latest firmware 2.0 for Sand Force controller.


    The road to SSD has had a lot of changes and pitfalls and of course now faced with SATA3 for some. And are now often but not always use Marvell chip.


    I'd also look at Corsair, which is what I use and uses SF-1200 and Micron NAND, pretty much the same as OWC was.

  • gumbi2400 Level 1 Level 1

    I'm having a similar problem with my MacBook 4,1, but with an Intel 510 series 120GB drive. Actually, the error occured on two of them. The first time, I installed from a known good backup, after a day or two I had various minor problems in Disk Utility (ivalid file count, invalid inode number, etc..). After repairing in single user mode (my wonderful wife accidentally threw away the original install disks ages ago), the same errors would come back up a few days later. I finally tried rebuilding the catalog B tree using fsck in single user mode, which made the orginal errors disappear seemingly permanently.


    3 months later, things went horribly wrong. The computer died suddenly, with the error "Invalid node structure." I wiped and restored from a backup, but same thing 2 days later. Got a new drive from Intel, and 4 days in had the exact same problem.


    Is this possibly a problem with how OS X handles the drive itself?

  • gumbi2400 Level 1 Level 1

    Oh, I forgot to mention, when using the same backup on a standard HDD, I have no issues whatsoever.

  • himynameismarek Level 1 Level 1

    Ok, so it took them about a month to decide to give me a replacement drive. I was out of the country and had time to go and get it just now 2 weeks ago. I installed 10.6 and transferred everything from my time capsule. No problems so far. I forgot how much faster this machine is with an SSD. I was getting ****** off at it so many times with the original hard drive. They gave me the same Kingston SV100S2 drive but this one already had the latest firmware and is from a whole different newer batch. I hope it will run well without any problems. If not, then you will see some more posts from me.

  • jeremyjaytaylor Level 1 Level 1

    I've had the EXACT same series of events as himynameismarek, in the last week... I even noticed that it consistently seems to be happening right after an update and restart... In fact, I'm not so sure it isn't related (somehow) to the update process, because of something that happened tonight:


    Since my last crash/reformat/reinstall (about three days ago), I've been verifying the hard disk a few times a day to monitor things. Tonight, I received a notification to install the Safari 5.1.2 update. After it finished (and it prompted me to restart), it occurred to me that I should check my disk before restarting... Sure enough, when I verified with Disk Utility, it said I had a disk error and needed to repair (which of course fails also, and the cycle begins again). HOWEVER, before I restarted, I copied all the logs from my console from today, so I'm hoping I might find some clues there (although I'm fairly novice, so it may not be realistic).


    If anyone had any additional info (beyond disk warrior and/or get a new drive), it'd be greatly appreciated. BTW, my drive is also a 256 GB Kingston (only 8 weeks old) and was supposed to have the firmware upgrade already... My MacBook is a late 2009 13-inch MacBook Pro.

  • cbong69 Level 1 Level 1

    I have the same problem with Kingston SSDNow V100 Series 128GB installed on my late 2008 Macbook unibody running Snow Leopard. This is the 3rd time I resinstalled the OS/X, excluding the other 3 times it manage to repair the disk itself. All these happen within 3 months of using Kingston. My friends who use Intel and Corsair don't seem to have this problem. I'm so p*ssed off with Kingston since I've spent about $200 on this drive.


    I have even upgrade the firmware according to Kingston's support. Its strange that the manual on firmware upgrade from Kingston solely mention how to do it on PC, and never mention about Mac. The firmware is in a Freedos format and can run on all OS. Does it mean this drive only support Windows???


    Anyway, I start to monitor closely on what I did everytime the SSD crash. My suspect is the database file from Microsoft Outlook for Mac 2011. It seems the SSD give me problem when I do something with my emails, e.g. download lot of emails from server, or close Outlook while downloading emails. Are all of you using Outlook?


    For those who manage to get a replacement disk, which supposely newer batch. Does it help?

  • himynameismarek Level 1 Level 1



    So my first disk lasted from November 2010 to April 2011. The second one from May 2011 to end of September 2011. I am currently using the third drive (second replacement) from November, so it's about a month now. If it happens again I will ask for a different brand and if that doesnt help either, I will have it replaced with a 7200rpm drive with 16 or 32MB cache. Drives are much faster nowadays and definitely faster than the original slow and loud Hitachi. Sad, very sad. Good thing I own a Time Capsule. Had to use it many many times.


    The Outlook thing - I don't think so. Happened to two of us in this forum after apple software updates with restart. My guess is that it's simpy power/electric current related, therefore it's probably because of hardware not being compatible with SSDs in general or just this specific drive's power management that disturbs it.


    BTW I had an incident about a week ago when I shut my MBP down and took out the battery to clean it with alcohol completely and when I was starting it up, the progress bar appeared but it started up slowly after a minute. I restarted and had no problem since. I will report back in case it breaks again.


    What I do now is just to not shut it down every night as I used to but just let it sleep. My uptime right now is 6 days and 13 hours which I never had before this drive. I restart it once a week or after updates only but I try to avoid it. The drive's warranty lasts for 3 years so there's enough time for it to break again even if I am this gentle to it.


    Oh and this might be worth mentioning - this drive is the first one where I did a fresh and clean install of Lion using the bootable recovery usb drive. The previous ones were Time Capsule restores or fresh installs + TC file transfers in Snow Leopard. TRIM support or something possibly? IDK

  • cbong69 Level 1 Level 1

    This make sense to me. My Macbook battery is bloated ( that's another story ) so I took it out. I'm using my Macbook on power supply alone, and sometimes the power is off suddenly. So this maybe the source of the problems if the SSD cannot handle the power/current properly. My original 2.5" and my external WD drives never had problems when power is off suddenly. Too bad I cannot use my bloated battery as it affect the track pad.


    Another point to note is I use uTorrent to download files, and I let it run overnight most of the time. Now I download to my external WD drives directly and also use it as time machine backup. Now I start to wonder if I would encounter the same problem had I bought Intel or Corsair in the first hand......

  • artemych Level 1 Level 1

    I have exactly same problem with Kingston SV100S2 128 GB. Invalid Node Structure, couldn't boot up my MBP 2008. Every time used Disk Warrior to recover. Put old HDD back - no problem for about a month, but it is so sloooowwww after even Kingston SSD, I also have OCZ 60GB Vertex 2 on my desktop and never had any problems with it during last 18 months of continuous usage. Installed SSD back, did a fresh install of Lion, turned off hybernation, thinking about what else to do. BTW, it's worth mentioning that I have very old battery and it usually holds not more than a 45 min.  I'm currently thinking about turning TRIM on. Any ideas if this helps? I also had a problem with SSD after updating OS X, or installing MS Office package. It looks like SSD was doing something on its own and then got interupted by rebooting (after update installation, or other software installation), may be that was Garbage Collection... Still investigating...

  • cbong69 Level 1 Level 1

    Almost can conclude that the SSD problem is caused by my bloated battery. My last restoration was 2 weeks ago and I was using my Macbook on power supply without the bloated battery. This seems ok ( i verify the disk everyday ) until last Thursday when I put back the bloated battery in. After few hours of usage ( from bloated battery alone ) and recharge, I found my SSD has invalid node structure again.


    It seems that the unstable power from old or bloated battery that cause the SSD to fail. If the SSD work without the bloated battery, I'll keep using this until i upgrade my Macbook when the new pro come out next year. Tired of the restoration process.....

Previous 1 2 3 Next