10 Replies Latest reply: May 1, 2011 8:03 AM by omaether
omaether Level 1 Level 1 (0 points)

My LaCie USB hard drive will not mount or show up in the disk utility or hardware listing.  The drive was attached when the last update ran but has not worked since.  Clearing pram did not make any difference.  The Drive is FAT32 and does show up on Windows machines but will no longer show up on my mackbook pro, os 10.6.7.

 

Any suggestions welcome.

thanks


MacBook Pro, Mac OS X (10.6.7)
  • iVmichael Level 6 Level 6 (13,725 points)

    Is the drive bus powered or does it have its own supply ?  If bus you might try giving it power from somewhere else or trying a different USB socket (or a powered hub).

     

    Have you tried connecting everything and then rebooting the MBP to see if that helps mount it ?

     

  • omaether Level 1 Level 1 (0 points)

    Thank you.  The drive uses usb power.  I have tried a different port, and rebooted with it connected, it still wouldn't show up anywhere.

  • omaether Level 1 Level 1 (0 points)

    Will it help to do "defrag" or anything from the Windows side since the disk still works on PCs?  It just feels like there's a flag or some sort of block on the MAC side that's preventing it from showing, I didn't know it should have been disconnected before running the updates.  Any ideas welcome.

  • omaether Level 1 Level 1 (0 points)

    Well, Clearing PRAM on the laptop did not make any difference.  Trying another device's power supply didn't either, though I'm not sure the drive wasn't still using USB power anyway.

     

    Is there any way in terminal or any system tool to just wipe the MBP's records of prior disks? 

     

    Is there a particular file it wrote onto the drive that I could delete and force it to show again? 

     

    The drive works OK on different Windows machines, there must be a way to get the macbook to see it again...

     

    Before that ill fated morning, it had been attachend, mounted and working the night before (I'd also let automatic updates run that night as I recall) and in the morning it did not show on the desktop so I thought it had been ejected and detatched on it's own, and I unplugged it.

     

    I can't be the first to encounter this but so far haven't found the answer in here yet.

    Any ideas?

  • omaether Level 1 Level 1 (0 points)

    add-on:

    oh and the drive does not show up in Disk Utility either so those tricks haven't been an option. It lights up, and nothing happens.

  • iVmichael Level 6 Level 6 (13,725 points)

    Run /Utilities/Terminal and enter the following command

     

    sudo fdisk -l

     

    Does it show the external drive or not ? Post the result here if it helps.

     

    If it does you can get more information on the Logical Volumes using the command

     

    sudo lvdisplay

     

  • omaether Level 1 Level 1 (0 points)

    thank you Michael, I couldn't get those commands to run they just returned Invalid Command error.  I'll post more about it below.

  • omaether Level 1 Level 1 (0 points)

    I really want to know how to fix this on my own.  If you know please do post, it seems the LaCie disk just unmounts itself from time to time.

     

    What I did

    - ran defrag on the the disk from Windows

    - begged a neighbor and connected the drive to his machine, waited for it to fully scan and the disk finish reading and light stop flashing

    - reconnected to my own MBP and it came up.

     

    I'm not sure the defrag was a factor.

     

    I'm glad it's back, but do not trust it.  This if the first experience of anything unreliable in my MBP, I don't like it but must shuttle between Windows for work.

    So if you do know how to fix this without a second MAC please let us know.

     

    appreciate all the help and keeping my fingers crossed.

  • omaether Level 1 Level 1 (0 points)

    Well it just happened again.

     

    Worked fine last night, this morning and was ejected properly, worked fine at the office all day.

    Now back from work and it will not mount again.  But it will work on Windows.

     

    WHY?

     

    back to the drawing board...

  • omaether Level 1 Level 1 (0 points)

    Seems if I always use the same USB port and connect directly without a cable it works best.  From your earlier post, it might have something to do with power.  Will post anything more I find out, but connecting to another MAC when it goes invisible and this manner of connecting it has worked so far.

    thank you again.