3 Replies Latest reply: Oct 10, 2011 5:10 AM by rsailer
skarmac Level 1 (0 points)

Hi, i'm using an iPhone4 (4.3.1) and it was everything fine till yesterday.

 

This morning I woke up and i saw that the iPhone was working only in 3G so I tried to connect to the wifi network (I've got an airport extreme) manually but it said "unable to connect to wifi network XXX" altough I can see the networks in the wifi menu pannel.

 

So I turn off the iPhone in order to restart it, or smth else, but it was all the same... Then I have removed the wpa/wpa2 password from the network but the problem already exist.

 

I tried to create a new wifi network from my macbook pro, but the iPhone can't connect to it... I hope that it's not an hardware problem, and it'll be strange since i can see the networks around me but i can't connect to them: i think that if it would be an hardware problem, i couldn't see them.

 

Could you help me, please?!? I don't know what could I do now... The last chance is to contact the applecare..............

 

Thank you

 

Gian


iPhone 4, iOS 4.3.1
  • Alexander Hazel Level 1 (45 points)

    Two things.

     

    1. unplug power to router. Unplug power to modem. Let sit for 10 seconds. Plug in power to modem. Wait for modem to finish it's boot process and wait for all the lights to stop flashing. Plug in power to router and wait for it to connect. Shutdown iPhone and turn back on and try to reconnect to the internet.

     

    2. On the iPhone go to "Settings > General > Reset > Reset Network Settings" and then restart the phone and then try connecting to the Wi-Fi hotspot again.

  • skarmac Level 1 (0 points)

    It seems ok now, thank you very much

  • rsailer Level 1 (0 points)

    My wifi network seemed to be working fine (accessible by my Mac Book Air). So I just tried #2 and it worked great. Didn't realize there was a reset in that location. I believe you do loose your various saved passwords for wifi networks if you do #2.

     

    Thanks!