Previous 1 2 3 Next 32 Replies Latest reply: Nov 30, 2015 7:41 AM by Tumum
Hans Eklundh Level 1 Level 1

When ever I am recieving a meeting invitation by mail it goes into the wrong calendar. I have several personal calendars in iCal, some subscriptions and we have a common shared meeting calendar for the company.


My personal invites through mail always goes into our common meeting calendar. I have found no settings to change that. Once the invitation is in iCal, I can't change calendar, they are all dimmed, nor can I answer the invitation. Nor does these invitations sync to my iPhone, iPad or Mobile Me.


Has anyone experienced this problem and found a sollution?

Solved by vkbs on May 21, 2013 7:43 PM Solved

ical takes the first account mentionned in the settings/accounts. It's sorted alphabetically. I just renamed the account which I wanted as default so it was first in the order.

Reply by Tumum on Nov 30, 2015 7:41 AM Helpful

I have the same problem.
For me the best solution would be the following:
If I open a ics attachment from Apple Mail, Calendar should ask me what calendar account to use. In addition, Calendar should allow me to change the calendar account later on.

All replies

  • mv4 Level 1 Level 1

    I had a similar issue, with work-related invites getting added to my personal calendar instead of the work one, with no ability to "move" once added.


    I solved this by making my work calendar "primary" in iCal, by dragging it to the top of the calendar list in iCal. Now all my work meeting invites get automatically added to the work calendar.  As far as personal calendar events go - I don't get many formal meeting invites on those, or I am usually the organizer anyway, so I can move them around.


    In your case, sounds like your common shared meeting calendar is "primary".  If you figure out how to easily move events between calendars (without having to change the default cal back and forth), please let me know.

  • LitmusJustine Level 1 Level 1

    Same thing is happening to me. I have 6 calendars in iCal:

    • Two personal calendars to track birthdays and bills (under "On My Mac")
    • My work calendar, which is under a Google Account
    • My personal Gmail calendar
    • Two subscriptions


    iCal won't let me drag the Work calendar (which appears second in the list) above the "On My Mac" calendars. This didn't happen until a week or two ago, and is VERY frustrating. Anyone find a fix?

  • François Mottaz Level 1 Level 1

    I stumbled on this thread while battling a similar problem. My answer comes late, so it includes the solution when you have your calendars shared through iCloud.

    Essentially, my problem was similar or even worse as iCal would bring the invites in one of the calendars I am subscribed to but read only. This calendar was not even checked for visibility. The event would be added and I would have no way to accept or refuse or even delete it afterwards.


    What I found out is that you can reorder your calendars only in the online iCloud interface, not in iCal. Once I reordered and put one of my calendars first everything was fine. Even if I want to change calendar after getting the invitation, I have the right to do so.


    Ical has settings for a Default calendar in its preferences. One would think this default calendar is used for every new event, be it an event or an invitation.

  • bediddleby Level 1 Level 1

    This didn't help me; the online iCloud interface only shows 'iCloud' calendars. My problem is that new invitations default to calendars found "On My Mac". If I manually create an appointment, it properly defaults to my iCloud/Work calendar which is what I have configured in Preferences. Invitations seem to ignore this setting and default to the first calendar found "On My Mac."


    VERY annoying. Anyone find a fix?

  • blackbirdway Level 1 Level 1

    I have the identical problem.  Haven't found the fix.  Called Apple support today - they seemed surprised to hear about it.

  • blackbirdway Level 1 Level 1

    I've researched the problem and have a workaround.  I'm running 10.7.3 on two machines, each with identical behavior in regards to the iCal problem.  I also set up a new user on one of my machines, synced it to my iCloud calendar, with the same results.  In a nutshell, the iCal preference selection for the default calendar ONLY applies to newly created calendar events in Lion.  It does NOT apply to calendar events in iCalendar ICS files that are created on another machine and clicked on or dragged into iCal. 


    When entering an event contained in an ICS file, whether the file arrives in Mail or some other manner, iCal defaults to the top calendar displayed after clicking on "Calendars" in the upper left corner of the app.  For default configurations, that will be the "Home" calendar "On My Mac."  If you want the default calendar to be an iCloud calendar, and don't have a use for calendars "On My Mac," then right click and delete the "On My Mac" calendars using the drop down window displayed when clicking "Calendar."  After doing so, the calendars displayed at the top of the list will be your iCloud calendars.


    In iCloud, you can order your calendars by dragging them. (Different design team, obviously.)  Drag your default calendar to the top of the list, and that will also appear at top of your iCloud calendars in Lion. 


    Not the elegant behavior I've come to expect from Apple, but it works.  Hopefully, Cupertino will wake up and one day make the default selection in iCal Preferences also apply to events created by iCalendar ICS files.

  • bediddleby Level 1 Level 1

    Thanks. I can't think of a time I'd ever want a calendar "on my Mac" to NOT sync with the cloud, so this works for me!

  • mdh98368 Level 1 Level 1

    Not sure if anyone is monitoring this thread anymore, but after upgrading to Mountain Lion, I am now having this problem: incoming invitations go to the incorrect calendar.


    I have no calendars on my Mac, only iCloud calendars. The calendar that shows at the top of my list in both iCal and iCloud are the same "Work." And I have iCal default calendar preference set to "Work." It seems like I've got all the bases covered, but no luck.


    Has anyone run into this issue on Mountain Lion and, if so, any luck in finding a solution?

  • David R T Level 1 Level 1

    I have the exact problem using Mountain Lion.  I have my defalt calendar through Microsoft Exchange...and when people email me an invite to that exchange email address, they are now defaluting to a gmail calendar that I have also managed in Calendar.  This happened when i reciently added this new gmail calendar, but didn't make it my default or anything, but now all invites are defaulting there (the events i create new default to the correct one).

  • Spartacus916 Level 1 Level 1

    I am in the same boat. My exchange calendar is my default and I have deleted all "On my Mac" calendars. I have 5 iCloud calendars listed below my Exchange calendar. Imported iCal skip over the Exchange option and attempt to open in the first iCloud calendar. Help!

  • Alan Sill Level 1 Level 1

    I also have the same issue, as a user of both Exchange and other calendar servers. Just as the last two posts above, no matter what I do, the incoming invite gets sent to the wrong calendar if I accept it, and I can't move it to my main calendar, which is an Exchange one.  This is driving me nuts!

  • Spartacus916 Level 1 Level 1

    I may have a solution or at least a work-around. Accept the appointment as Maybe instead of Accept. Doing this allowed the appointment to go to the top listed calendar (my Exchange calendar) and then I was able to Accept it outright. Good luck!

  • theimr Level 1 Level 1

    Thank you so much!  I don't need any "On My Mac" calendars - this was the perfect solution for me.

  • Geo242 Level 1 Level 1

    I am also having this issue and haven't found a solution. All my gmail invites are duplicated on my Exchange calendar. Apple needs to fix this!

Previous 1 2 3 Next