Previous 1 2 Next 26 Replies Latest reply: Feb 10, 2015 4:53 AM by Master Joda Go to original post
  • vkbs Level 1 Level 1 (10 points)

    ical takes the first account mentionned in the settings/accounts. It's sorted alphabetically. I just renamed the account which I wanted as default so it was first in the order.

  • Mitra Earth Level 1 Level 1 (0 points)

    I have the same problem, but in my case the solution was to log into icloud and drag the calender to the BOTTOM not the TOP as suggested in other posts. (inconvenient of course)

     

    Its a bug obviously, since OSX-preferences has a place to define the default calender, but equally obviously noone from Apple monitors these forums or anywhere else you could report a bug :-(

  • hallpower Level 1 Level 1 (0 points)

    @apple:

     

    Same problem.

    I only have one Exchange and two Google Calendars setup.

    Renamed the Exchange to appear first in Settings.

    Defined the Exchange Calendar as Default.

    None of these calendars appear online in iCloud, so I couldn't change any preferences there.

     

    When I click on an ICS file in my Exchange mail account, it opens the invite in Calendar using my Google Account. When I right-click the event, I can only move it to the second Google account. When I drag the event to my Exchange calendar, the event is duplicated in Exchange (without the Accept/Reject options). From there, if I try to delete the original Google invite, I'm asked if I'm sure I want to decline the event.

     

     

     


  • kmcital Level 1 Level 1 (0 points)

    Didn't solve for me using iCloud. After a long time of searching plists, settings, etc. I finally found that when I reordered my calendars on iCloud, then the meeting invite would be created in different calendars.  Strangely I found that the "default" meeting invite calendar (when receiving an invite attachment via email) is stuck to go to the 3rd position on my calendar list in iCloud. Whichever calendar was third down on the list, would get the meeting.  I played around for a long time reordering them, hoping it would clear out some bad setting, and hoping it would adhere to either the default calendar setting or the alphabetical rule or the first in the list rule...but in the end, I just put the calendar I wanted as the default meeting invite recipient in the 3rd slot.

  • seb100 Level 1 Level 1 (0 points)

    when having all calendars in icloud, running ML, moving the desired calendar to the BOTTOM of the list in icloud solved my problem. thanks!

  • keithdoc Level 1 Level 1 (0 points)

    I have same issue - Exchange work calendar invites are automatically accepted from mail.

    My exchange work calendar is NOT iCal, so there is no way to move it to the top of the list.

     

    The ONLY workaround I've found is to accept them from iOS device (they work perfectly, and update appropriately). 

     

    I changed the setting in mail to "Add invitations to Calendar", set to 'never'.

    As long as Calendar has the exchange account set to refresh, they will show up (changes too).

     

    Crappy workaround - CMON Apple.  Fix this, please!!!!!!

  • RickyB. Level 1 Level 1 (35 points)

    I'm having the same issue - when I accept an Exchange invitation in Mail, a duplicate event is created in my Gmail account in Calendar.

     

    I've filed a bug report with Apple (#: 17434464).  If any of you have the same issue, please file a bug report at bugreport.apple.com - contrary to popular belief, every single one of these reports is read.  The more they get, they more likely an issue will be fixed.  Forums are not the best way to report bugs, other than to verify that others have the same issue.  I reported the issue under 'Mail' as opposed to 'Calendar' because it appears that's where the issue is.

     

    Good luck!

  • jeesau111 Level 1 Level 1 (0 points)

    Hello, having the same problem.  Invites going to a shared google calendar with no way to move them.  I reported to Apple as a bug.  Amazing that this has been an issue for people for 3 years!

  • Master Joda Level 1 Level 1 (0 points)

    Somehow this is still not fixed. Although default calendar is set to Exchange, we invites are added to the first iCloud calendar. I can reorder iCloud calendars. iCal always takes the first iCloud calendar, but ever the exchange.

     

    If I go a step further, I can also disable all iCloud calendars. If I double click add a new calendar invite, nothing happens!

     

    But at least there is a workaround with OS X 10.10. I can add a new invite to iCloud and move it to exchange. That was not possible with 10.9.

  • davideglin Level 1 Level 1 (0 points)

    Same issue here. I have an Exchange account that i use as my primary work (email & calendar) account and I have a Gmail (calendar only) account. When i receive an ics file in my email, right click and open in Calendar it defaults to my Gmail account. I've gone through all of the suggestions in this thread and still have the same issue.

     

    I have found a simple workaround though which seems to work well. I also have an iPad and also use that for my Exchange email and calendar. It appears that when you click on the ics file in mail on the iPad and click on the link Add To Calendar it gives you an option which calendar you want to add it to.. You need to have calendars deactivated from your iCloud settings on your iPad as well.

     

    Its not ideal but the only other approach that I found (on my Mac) was to disable the Gmail calendar before clicking on the ics file which was a royal pain.

     

    Eagerly awaiting Apples response.

  • Csound1 Level 8 Level 8 (40,175 points)

    Open iCal (or Calendar) Preferences, go to the General Tab and choose your default calendar (the one you want to be)

    Screen Shot 2015-02-10 at 11.55.01.png

  • Master Joda Level 1 Level 1 (0 points)

    If that would be so easy, we would not discuss that in a thread. The problem starts, if you have more than just local or iCloud calendars. It is basically a problem with Exchange account. As I wrote before, it does not work if disable all calendars, but not exchange. You will not be able to add a new event from a .ics file.

Previous 1 2 Next