Previous 1 2 Next 16 Replies Latest reply: Apr 19, 2011 7:54 PM by Old Toad
Tom Kirkman Level 3 Level 3 (800 points)

When I upgraded to the latest version of Snow Leopard, my iPhoto software disappeared and now I no longer have the problem on my computer. I cannot find the individual application on my Snow Leopard disk. How can I restore the software? Can it be downloaded from Apple? My iPhoto library is still intact on my computer but the program itself has disappeared. Thanks.

  • T5GP5Ox32 Level 3 Level 3 (590 points)

    It will be on the Applications Install DVD that originally came with your Mac, found in the Purchases tab on the Mac App Store or on the iLife disc you purchased.

     

    For reinstall via the Applications DVD which is what I believe you need then do the following.

    Drop it in, go to Optional Installs and then follow through the installer. Might be a good idea to click the Customize button when you get to the Installation Type screen just to make sure it is installing -only- iPhoto.

  • Terence Devlin Level 10 Level 10 (129,325 points)

    Did you erase the disk when you installed 10.6? Iphoto is not part of 10.6 and is not on the disk. It should be on the System Restore disks that came with your Mac

     

    Regards

     

     

    TD

  • Tom Kirkman Level 3 Level 3 (800 points)

    The #2 disk that came with my iMac only contains something called XCode package. No applications.

  • T5GP5Ox32 Level 3 Level 3 (590 points)

    What year is this Mac from?

    Pre-2008 will have it on Disk #1 under "Install Bundled Software Only" or "Optional Installs"

  • Tom Kirkman Level 3 Level 3 (800 points)

    Post 1998. Apple said there was an issue with those install disks and are sending good disks. Thanks.

  • Tom Kirkman Level 3 Level 3 (800 points)

    Crap. They overnighted an applications disk but it has iPhoto '11. I installed it and it does nothing by lock up my iMac. I have to unplug it to get it restart.

     

    Any idea where an older version of iPhoto might be found?

  • T5GP5Ox32 Level 3 Level 3 (590 points)

    Are you running 10.6.3 or higher? Would assume so but never know if you went back to Leopard in between then and now. Just want to make sure.

     

    Also I would suggest deleting the files below and reinstalling.

    /Applications/iPhoto.app

    /Library/Application Support/iPhoto

     

    Then reinstall from the disc and when you get to the Installation Type menu click on Customize. Make sure you're only installing the help files and iPhoto for now. If you want the rest to be updated to iLife '11 (if you weren't already on it) then you can do that after we get iPhoto working.

     

    Install the iPhoto 9.1 update and then upgrade the iPhoto Library, if necessary, and then run Software Updates.

    9.1 Update: http://support.apple.com/kb/dl1322

     

     

     

     

    If you also want the original iPhoto delete the same files from above and put the Install DVD 1 in. Choose "Install Bundled Software Only" and you should be able to install iPhoto at the Installation Type -> Customize window again.

  • Tom Kirkman Level 3 Level 3 (800 points)

    I don't have those disks, my iMac didn't come with what everybody says it was supposed to - my install #1 disk asks me to install disk #2 in order to install any applications, but disk #2 only contains something called XCode. There are no applications on either disk.

     

    Apple told me that there was a mistake on the disks that shipped with these machines for a while and I must have gotten a set of them. Thus I do not have access to iPhoto 9.1. Only '11 as supplied in the replacement disk sent by Apple yesterday.

     

    I am running 10.6.4

     

    I got iPhoto 11 running long enough to see that all my extensive slide shows did not hold their original settings - everything has been changed. I'd be looking at months and months of work to redo each one of them one slide at a time.

     

    I'll have to find a copy of iPhoto 9 somewhere.

  • T5GP5Ox32 Level 3 Level 3 (590 points)

    I would suggest calling AppleCare back and specifically requesting either your original install discs that it was supposed to come with or an iLife '09 disc. Not sure why you were provided with an '11 disc if you originally had '09.

  • Tom Kirkman Level 3 Level 3 (800 points)

    They told me that this is the only disk they can supply me with.

  • T5GP5Ox32 Level 3 Level 3 (590 points)

    All right then. Was worth a shot. Let's see if we can get it solved with what we have then? Unless you would prefer going back to '09.

     

    First thing I should ask. Do you have a Time Machine backup?

     

    Second. Have you tried deleting the folders I mentioned previously and installing again to see if it works?

     

    Third. Are you able to update to 10.6.7? Would be beneficial if you're fully up to date before installing again.

  • Tom Kirkman Level 3 Level 3 (800 points)

    For whatever reason, downloaded updates never successfully install. I have to go to the Apple store and have them the updates on a disk and use that.

     

    I have been on the phone with iPhoto tech support this afternoon, and for whatever reason iPhoto 11 is not going to be compatible with my iPhoto 9 slideshows - the settings are all messed up in '11 and it won't allow any resets to stick - it keeps reverting back to the defaults every time. So they said they can get me a copy of iPhoto 9 to install. Thanks.

  • T5GP5Ox32 Level 3 Level 3 (590 points)

    If you'd prefer not to go to the store you can download the updates from the Apple website. The 10.6.7 combo update should solve most problems.

  • Tom Kirkman Level 3 Level 3 (800 points)

    As I said, downloads never successfully install for me. I have no idea why. I have to have a disk. The Apple store doesn't keep them, but if I hang around for a couple hours they get it downloaded to a disk and let me take it home.

     

    I have suggested they keep a download disk on hand and make copies for folks like myself. But I guess with the torrent of daily updates and upgrades these days it wouldn't make much sense - anything they downloaded to burn to disk would be obsolete in a couple days' time.

Previous 1 2 Next