0 Replies Latest reply: Apr 18, 2011 12:19 PM by jaimefromsurfers paradise
jaimefromsurfers paradise Level 1 Level 1 (0 points)

though i have the mac since christmas ,i only been learning about mac for the last two months , i am just starting to appreciate the difference ,but yesterday after verifying battery charge was at 97% I shut it down using the aple icon ,turning the modem off and accepting shut down . about five hour latter the power swithch does nothing at all .I read the previous entries on this problem and there is a few entries from someone that had a similar problem but i observed that he did not have a mac air . never the less , there is a lot of coments and i tried them all , at same stage there is a way of force quiting that i tried and then noticed tha the fans are working ,they switched of pressing power for ten seconds ,and after trying the other steps unsuccefully i did the restore sugested specific for mac air books with non removable batteries ( tried about 3 times) but nothing happens . i still can'not turn it on . this is very fustrating . i hope someone can give me advise before i take it to a shop or repair person , i have only joined today because unfortuntelly i need your support , but is very good to know there is people out there kind and generous with their time . thank you all before hand ,just for being out there ,together ,in times to come any kind ok global community will strengten our human condition on this planet of ours,   


MacBook Air, 1.86Ghz 2gb on board 256 flash