2 Replies Latest reply: Sep 1, 2012 8:44 AM by ldmdl
Seii Level 1 Level 1 (0 points)

I just purchased Facetime for my desktop computer and it does not want to sign in.

 

Exactly same network at home, and yet Facetime works perfectly fine on my iPad 2 and it won't sign in on my Intel iMac. It will keep trying until I get notification message I should check my network. There is really nothing to check since Facetime on my iPad 2 worked out of the box. I tried both, wireless as well as my wired connection. Still same problem.

 

I turned my iPad off and tried signing to Facetime with same Apple ID on my iMac. Still won't sign in. I tried my wife's account, still no go. I tried my wife's account on my iPad and it works like a charm.

 

What is that on my iMac that it does not allow Facetime to connect? All updates installed (OS X 10.6.7). Firewall is completely shut down, never even used it. I have Little Snitch but I don't believe that's the problem since I have Little Snitch with same configuration and rules on my work iMac. Facetime works perfectly fine on my work iMac at the office.

 

This is driving me nuts.


iMac, Mac OS X (10.6.7), 1Tb Seagate HD, 4Gb RAM
  • 1. Re: Facetime sign in problem on my iMac. Works perfectly fine on my iPad 2 (?!)
    Seii Level 1 Level 1 (0 points)

    Hi everybody!

     

    I think I solved this problem and I believe it could help to thousands of other people desperately try getting Facetime to work on their machines (that is when it comes to Mac, still not sure what is causing iPhone/iPad Facetime problem some people are having).

     

    Anyway... this is what I did and it solved it immediately. I am having this issue with Facetime on my iMac for the last two months and no solution provided on the internet in various forums helped a bit. Changing DNS servers, erasing com.apple.imagent file from the user Library/LaunchAgents folder, even adding loads of ports to port forwarding section of my router... nothing.

     

    Simple solution worked for me! I'm thinking what's so different from my home iMac and my office one (BTW, exactly the same configuration, and almost the same applications installed).

     

    Problem was in my PeerGuardian settings. I have it installed on both machines, but only one option was different. On my office machine, option was checked and Facetime worked without any problems. On my home machine this same option was unchecked and Facetime was never ever able to connect. After I checked this option (see link for screenshot), Little Snitch immediately popped up asking me to allow "applepushserviced" to connect. I allowed it and Facetime connected in a matter of seconds.

     

    This is the setting in PeerGuardian you need to have checked so Facetime is able to connect.

    http://i.imgur.com/ViprD.jpg

     

    Trust me, even when PeerGuardian is not running, this setting if unchecked will screw your Facetime login.

     

    And this is what LittleSnitch popped up with after I checked this option and tried signing in with my Facetime again. I allowed it and Facetime connected. Problem solved, at least on my end.

    http://i.imgur.com/C16fW.jpg

     

    Cheers!

  • 2. Re: Facetime sign in problem on my iMac. Works perfectly fine on my iPad 2 (?!)
    ldmdl Level 1 Level 1 (10 points)

    Thanks Seii good one!!

     

    In Mountain Lion with Little Snitch you have to create a new Rule for 'apsd' allow any connection and that's it!

     

    Regards!