Previous 1 2 Next 15 Replies Latest reply: Sep 8, 2015 10:11 AM by Margrit
ddavis8 Level 1 (0 points)

The magic mouse will move the cursor but cannot left-click.  I connected a wired mouse and the same thing happened.  The keyboard works fine.  Right-clicking with the mouse works.


Here are my specs: iMac 21.5" 3.2 GHz i3 running 10.6.7

iMac, Mac OS X (10.6.7)
  • twoplanker Level 2 (180 points)

    Go to System Preferences>Mouse and make sure that the left click on the mouse is set to "Primary Button".

  • ddavis8 Level 1 (0 points)

    Thanks for the reply, twoplanker.  I was able to navigate to Sys Prefs using the right click but there was no choice given for primary button, only secondary, which is set to right.  It seems to be working now after another restart, however, it has stopped working other times after a restart.  It's an intermintent issue.

  • twoplanker Level 2 (180 points)

    Do you get the interface with the video's etc? The primary button will only work on the old Apple mouses and not the Magic Mouse as the whole top of the mouse is a click.  Does the mouse actually click physically and it just does not respond on the screen?  Or will the top of the mouse not phsically click down?

  • springfieldstudio Level 1 (0 points)

    I have the same problem. At the moment I am turning my mouse off and on again to continue working but the same happens after a period of time.


    I have checked my system preferences also and everything seems to be in order. This is very frustrating.

  • tranquilrage Level 1 (0 points)

    Same experience here, been looking everywhere for a solution, just started happening late last week.


    I've got a late 2008 mbp with the old apple wireless mouse connected via bluetooth.  Mouse moves curson on screen, when the cursor is over a button it responds with the mouseover effect but it won't read the clicks.  Even swapped out the mouse with same result.  Hard reboot used to be a temp fix but even that stopped working, currently using the trackpad.

  • das33 Level 1 (0 points)

    Same experience here, which started after an upgrade from OS X10.5.8 to 10.6.7. Trashed what I hoped would be the Apple USB mouse prefs at [Home]/Library/Prefs/ and rebooted. It worked, I rebooted again, and it still works.

  • tranquilrage Level 1 (0 points)

    I read in another thread or forum about the battery when (when warm) can expand and press against something that effects the mouse function?  Anyway decided to remove the battery and noticed it is bulged and wasn't allowing the cover to go on correctly.  Removed it and have been running the MBP with no mouse issues ever since.  Works for me because I use it as a desktop with external monitor anyway but not a great solution if I actually  needed it to be a laptop.

  • MCAC Level 1 (0 points)

    I suddenly had problems with the mouse click. Using the trackpad (buttons) or an external mouse didn't make a change, it just wouldn't click anymore. Also the the dock wouldn't appear when moving towards it. The arrow would move though...Pretty useless...


    So I just tried the 'remove battery' hint and my MacBook Black worked like normal again. Battery is in perfect shape (no bendings). Then put the battery back, restarted and it's fine again... (don't know for how long) so thanks!

  • Harris11235 Level 1 (5 points)

    I came across this thread and thought I'd reply with my fix.


    My setup:  Macbook Pro, Thunderbolt Monitor, Wireless Magic Mouse, Wireless Trackpad, Wacom Tablet


    I had exactly the same issue - the mouse and trackpad would move the cursor around the screen, but the left-click function wouldn't work on either device.  The Wacom tablet (pen tablet) left click would work.  I scratched my head about it, came across this forum, checked my mouse preferences and noticed that there was ANOTHER mouse connected to my Mac.  I carry another magic mouse around in my bag for offsite meetings, and the mouse was in range of the mac.  The button on the mouse was pressed down by other stuff in my bag, causing a constant left-click signal to be sent to my Mac.  I turned the mouse in my bag off and everything is back to normal!


    To see if you have other bluetooth devices that could be interfering with your mouse, head to System Preferences > Bluetooth and look to make sure you don't have a conflicting device connected to your computer.

  • PLottaz Level 1 (0 points)

    Thank you Harris, that was my problem indeed.


    Both, my magic mouse and a usb mouse that I had connected to my system were not working. I already thought I'd have ot reinstall my mountion lion. But your tip was right.


    Using a remot desktop client, I opened the system preferences, klicked on bluetooth, only to find that indeed two magic mice were connected to my system. I deleted one and That resolved the issue instataniously. Both, my usual magic mouse and my usb mouse started working working properly again.


    Thanks a lot man.

  • hoyadoctor Level 1 (0 points)

    My problem was slightly different.  I have both a trackpad and mouse.  There was a book leaning on the unused (but connected) trackpad.  As soon as I moved the book, all was well!

  • jabyrd Level 1 (0 points)

    I had the problem on a white macbook3.1.   After reading this I noticed the battery had bulged.  Took it out and it all works again.  Looks like it was causing just enough pressure above the battery to make the trackpad stick. 

  • sloddybell Level 1 (0 points)

    I was having this problem and it was baffling me.  My magic mouse just stopped clicking.  It would move but not click.  I reset the mouse and restarted the iMac using keyboard command and it fixed it but then it happened again.  The answer above was the answer for me.  I use multiple mice with multiple keyboards for my iMac and I had my back up mouse in a bag close the iMac and when I pulled it out, it was on and trying to connect.  I shut the back up mouse off...Shazaam - my mouse is now working great.  ahhhh - Logic!

  • arshid Level 1 (0 points)

    Exact same issue mouse in the computer bag was the cause ! Thanks mate now I don't have to restart every time I wake the mbp up. Apple should treat this more ekegantly ad lots of people seem to have the issue.

Previous 1 2 Next