Previous 1 2 Next 18 Replies Latest reply: Apr 14, 2014 8:55 AM by jenevenej
birddogdesign Level 1 (0 points)

While attempting to fix syncing this message appeared and has hung up ical indefinitely. I can force quite but cannot fix. Any suggestions?

Mac OS X (10.6.7)
  • Ferd II Level 7 (25,700 points)



    Quit iCal, go to your Macintosh HD/Users/yourusername/Library/Calendars folder, and delete all files with the name "Calendar Cache."


    Then log out/in or restart and see what happens when you restart iCal.

  • Sunny0000 Level 1 (0 points)

    Excellent, thank you Ferd II, this worked for me :-)

  • Ferd II Level 7 (25,700 points)

    Glad to hear that helped you.

  • canderson001 Level 1 (0 points)

    I have a similar problem, but when I look for the noted files (Macintosh HD/Users/yourusername/Library/Calendars) the folder "library" is missing.

  • Ferd II Level 7 (25,700 points)



    Open Finder and select Go>Go To Folder...>and enter ~/Library/Calendars into the "Go to folder" text entry field.


  • slicedapple Level 1 (0 points)

    wish to god I had found this post 3 days ago! I have spent over 6 hours on chat calls with 4 different apple support staff and got no resolution. They made me reinstall Mavericks (twice!!!!), boot into safe mode 3 times, performed an SVC and NVRAM test (twice), deleted other 3rd party software that has never caused any issues before. And then the final call just cut off. They did send an email apologising for the hassle, but added a bunch of links that did not help. Right at the start I asked if there was not some easier steps to try before reinstalling Mavericks, but no one suggested deleteing a simple cache file. ***!!!! So big thanks Ferd.

  • slicedapple Level 1 (0 points)

    this info was also a major help to me Ferd. BUT I cannot see how to award points for your efforts - you deserve a few thousand after the rubbish I have been through with apple support!!

  • Ferd II Level 7 (25,700 points)

    You are welcome...glad to help.


    Only the original poster can award points, but your comment means more to me than the points!

  • slicedapple Level 1 (0 points)

    no worries - you deserve it for help that is clear and "just works" ... now where have I heard that expression before?

  • fancy2270 Level 1 (0 points)

    This helped me. But When I rstart iCal only a few entries appear. (They are also the only entries that synched with iCloud to may iPad.) If I import the saved file from Library, they all re-appear. But still won't synch with iCloud. When I try, I return to the dreaded "Upgrading" purgatory.

  • okeeusa Level 1 (0 points)

    Thank you - thank you - thank you.  I can only repeat something from another seeking help: 

    "This info was also a major help to me, Ferd. BUT I cannot see how to award points for your efforts - you deserve a few thousand after the rubbish I have been through with apple support!! "  Very much appreciate your help!

  • Ferd II Level 7 (25,700 points)

    You are welcome...your comments are all the reward I need.

  • jr0bert Level 1 (0 points)

    Hi, my problem is a slight variation of the above.

    The message that is there with my iCal is 'Moving calendars to server account'. It sits there in 'purgatory' as someone said above and I have left it for quite a while. I have struggled to even force quit the program and just hit the off button for 5 seconds to kill the whole computer.

    I've gone looking for the cache file mentioned above but don't seem to have the ~/Library/Calendars folder when I do a search in Finder.

  • Ferd II Level 7 (25,700 points)



    The advice that was given for the OP was offered almost three years ago, and the OP was using OS X 10.6. You are most likely using a newer version of OS X. Try this updated list of instructions.


    1. Disconnect your computer from your internet connection.


    2. From the  Menu, select Force Quit...>Calendar.


    3. Paste this text ~/Library into the Finder>Go>Go to Folder...window and select "Go." This will open the Users Library Folder.


    4. Then open the Calendars Folder in that Library Folder, and move any any files with "Cache" listed in the name field to your Desktop.


    5. Next open the Preferences Folder in the same Library Folder, and move the file to the Desktop.


    6. Log out/in or restart, and open Calendar.


Previous 1 2 Next