Previous 1 2 Next 16 Replies Latest reply: Feb 14, 2013 2:10 PM by Hadil3
donnafromrocky river Level 1 Level 1

Had been using the Itunes Store just fine.  I am running MacOSX 10.4.11 and Itunes 7.  Now there is an ad that says to download to Itunes 10. I cannot download Itunes 10 with my operating system.  It won't let me open the Itunes Store, though.


I Tunes, Mac OS X (10.4.11)
  • BDAqua Level 10 Level 10

    Sadly, iTunes now requires at least...

     

     

    Macintosh hardware

    • Mac computer with an Intel, PowerPC G5 or G4 processor
    • Intel, PowerPC G5 or 1.0 GHz PowerPC G4 or faster processor is required to play Standard Definition video from the iTunes Store
    • 2.0 GHz Intel Core 2 Duo or faster processor is required to play HD video, an iTunes LP, or iTunes Extras from the iTunes Store
    • 512MB of RAM; 1GB is required to play HD video, an iTunes LP, or iTunes Extras
    • Screen resolution of 1024x768 or greater; 1280x800 or greater is required to play an iTunes LP or iTunes Extras
    • Playing videos also requires at least 16MB of video RAM
    • Broadband Internet connection to use the iTunes Store
    • Apple combo drive or SuperDrive to create audio, MP3, or back-up CDs; some non-Apple CD-RW recorders may also work.
    • Apple SuperDrive to back up your library to DVDs; some non-Apple DVD-RW drives may also work.

    Macintosh software

    • Mac OS X version 10.5 or later
    • QuickTime 7.6 or later
    • Support for HE-AAC requires QuickTime 7.6.4 and Mac OS X version 10.5 or later
    • Safari 4.0.3 or later
    • 200MB of available disk space

    Leopard requirements/10.5.x...

     

        *  Mac computer with an Intel, PowerPC G5, or PowerPC G4 (867MHz or faster) processor

     

    minimum system requirements

     

        * 512MB of memory (I say 2GB at least)

        * DVD drive for installation

        * 9GB of available disk space (I say 30GB at least)

     

    You have to call Apple & likely ask for a Product Specialist to get it, if they still have it! Helps to tell them you have an iPad/iPhone & you can't run 10.6.

     

    There are workarounds if the 867MHz is the only hangup...

     

    http://sourceforge.net/projects/leopardassist/

     

    If you have an Intel Mac, 10.6 is cheaper/easier to get.

     

    Snow Leopard/10.6.x Requirements...

     

    General requirements

       * Mac computer with an Intel processor

        * 1GB of memory (I say 2GB at least)

        * 5GB of available disk space (I say 30GB at least)

        * DVD drive for installation

        * Some features require a compatible Internet service provider; fees may apply.

        * Some features require Apple’s MobileMe service; fees and terms apply.

  • Jim VanLeeuwen Level 6 Level 6

    iTunes 9.2.1, http://support.apple.com/kb/DL1056

     

    It will work with OS X 10.4.11 and let you in the store.

  • Daniel Duvall Level 1 Level 1

    iBook G4, 10.4.11

     

    I upgraded to itunes 9.2.1 but I still cannot get into the store because it says I need Safari 4.0.3 but I cannot upgrade to that unless I go to 10.5, but to do that I need a newer computer as I understand it.

     

    Thanks for any pointers.

     

    Dan

  • Jim VanLeeuwen Level 6 Level 6

    You can find Safari 4.0.5 here: http://support.apple.com/kb/dl877

     

    It will work with 10.4.11

  • a brody Level 9 Level 9
    expertise.classicmacos
    Classic Mac OS

    Unfortunately the news is that the store only supports iTunes 10 and later now.

  • Klaus1 Level 8 Level 8

    a brody wrote:

     

    Unfortunately the news is that the store only supports iTunes 10 and later now.

    I have no problems using the iTunes store using iTunes 9.2.1.

     

    Where did you see this news?

  • a brody Level 9 Level 9
    expertise.classicmacos
    Classic Mac OS
  • Klaus1 Level 8 Level 8

    That seems to refer specifically to 'decade old G3s'.

     

    I do not get the warning page on the iTunes store referred to in the link from your link. In fact I purchased music only last week!

  • a brody Level 9 Level 9
    expertise.classicmacos
    Classic Mac OS

    Was that purchase after the 26th?

  • Klaus1 Level 8 Level 8

    Time flies when you are having fun - turns out is was on March 30th!

     

    I will try to buy something in a day or two.

  • Klaus1 Level 8 Level 8

    Just wondering if it is relevant that I am connecting to the UK iTunes store, whereas you are connecting to the US iTunes store?

  • a brody Level 9 Level 9
    expertise.classicmacos
    Classic Mac OS

    I wouldn't know.

  • Klaus1 Level 8 Level 8

    Try this version:

     

    iTunes 8.2.1 for G3 PPC Macs:

     

    http://support.apple.com/kb/DL857

  • GGPP Level 1 Level 1

    I just discovered the same thing. Can't do the iTunes upgrade because I'm still on 10.4.11. Maybe if I ever get any work again I'll be able to keep up with all of Apple's cats. Hard to believe they think we can all upgrade whenever they do.

Previous 1 2 Next