Previous 1 2 Next 16 Replies Latest reply: Jan 30, 2015 5:59 AM by bronstaf
passion8 Level 1 (0 points)

When trying to use my HP OfficeJet 6500A Plus I get an error ( -9931.)  It can't scan.  Also, after taking a screen shot, I can't view it in Preview.  Basically, preview is not working.  Anyone know how to fix it?

  • PabloinAZ Level 1 (0 points)

    I am having exactly the same problem. I have run the software update process and have contact HP. They tell me that it is a problem with the image capturing function on the Apple. I have a brand new iMac and my router and HP printer are brand new.

    Any help appreciated!

  • MadisonP Level 5 (4,765 points)



    Did you use migration assistant to come from an older Mac to the one you have perhaps?

    Did you install any HP software from an included disk when you got the printer?


    I'm not familiar with that error message directly but I agree with your conclusion that Preview does not appear to be working as well as Image Capture.  I'd be curious to know if Quicklook works on the screen shot.  Click on the picture once and then tap the space bar and see if the picture shows up.  If it doesn't then we may have a Quicktime / video driver issue.


    Preview is part of the OS so you would need to reinstall the Mac OS to restore it and its background core services.  Image Capture is what does the scanning and it too is an OS level component.


    1. Try repairing disk permissions first just in case:
    2. Back up all important information:
    3. Reinstall 10.6:


    Hope that helps!

  • passion8 Level 1 (0 points)

    I actually traded in my printer for a new one (just six weeks after purchasing) and I started getting other errors.  What finally fixed everything was attaching the printer to my router with an ethernet.  Seemed there could be a chance that wifi was having issues with so many wifi devices.  BUT my printer worked, just not the scanner. Then uninstalling all software and reinstalling software.  All works well for now.  Fingers crossed.  I had done the repair disk permissions thing and uninstalled the printer and added it again etc.... but the ethernet and complete uninstall of software and reinstall seems to be working.  Hope this helps.

  • esveha Level 1 (0 points)

    Same problem, same hardware. It occurs quite frequently.

    'Scan to' my computer from the printer also does not work anymore in those cases.


    So it does seem to be a communications problem. I cannot connect the printer using ethernet, so I cannot rule out the possibility WiFi is causing it.


    What always solves the issue (all issues) is simply rebooting the printer.


    Allthough rebooting the printer is easier than reinstalling the OS, it still does not fix it.



  • joae1975 Level 1 (0 points)

    This just happened to me.  It happened on my imac.  I got out my macbook and no problem, so it's a communications/network error with the imac.  But what fixed it was weird.  I went to my printer, reconnected it to the network router and presto!!  Problem solved.  I don't know if that helps but that's what worked for me.


    Using HP Envy 100



  • Ravindra Holalkere Level 1 (105 points)

    I use Epson all in one and started getting the same error recently. Try the following to resolve it (worked for me)


    in scanner pane, uncheck the 'use custom size' check box and it should work fine.


    I was able to select different 'kind' (color/b&w etc) and I used resolution upto 1200 dpi and was able to get it to scan.

  • belbot Level 1 (0 points)

    This worked for me. Unchecking "Use Custom Size" fixed it instantly. Thanks!

  • MurkysMom Level 1 (0 points)



    Hope you've solved your problem.  If you've not, maybe this will help.  I'm using OS 10.7.3 on a MacBook Pro with an Epson 2450.


    I received the same error this morning, and tried unchecking the custom size box.  Didn't work.


    Since I repair permissions weekly, didn't try that thread.


    What I did do - that worked - was to restart, and zap the Parameter RAM.  You do that by holding down command-option-P-R immediately after the restart 'bong.'


    I usually let it bong 3x more (takes several seconds for each), and then let the normal restart occur.


    Good luck.

  • FloridaFlash Level 1 (0 points)

    HAving the same problem with a NEAT ADT 2800 scanner.  Talked to tech at NEAT -- bewildered.  The only common thread is an iMac is involved.  I have another portable NEAT scanner .. No problems.  Take the troublesome scanner and hook it up to MacBookPro .. No problems.  When I tried to scan directly from Print/Scan in sys prefereces, got error -9931 in com.AppleImageCaptureCore.  I have cleared ram, caches, reinstalled sotware, reseet PRam ... All to no avail.

  • f8ful Level 1 (0 points)

    My HP Envy printer/scanner has the same problem suddenly with my iMac - but only since the update from 10.7.3 to 10.7.4.  Haven't had time to see if it still works with MacBook (10.6.8)  If anyone has suggestions, I'd be appreciative.

  • joae1975 Level 1 (0 points)

    My Envy prints okay now but all my scans/copies are black.  I think it needs fixed.  Piece of Junk imho

  • ajazak Level 1 (0 points)

    YES! Unchecking that box worked for me too. Lion, HP Printer C7280, Scanning from Preview.

  • halof Level 1 (0 points)

    The same problem with Epson 2480 on Lion. My solution: Software Update -> Driver Update. It helped me!

  • Richard 17 Level 1 (0 points)

    I had same 9931 error problem and unchecking '' Use Custom Size'' worked. Now however when I erase ''scan'' in the ''name'' box and enter a new subject the printer will not scan this. Any help with this one?

Previous 1 2 Next