8 Replies Latest reply: May 16, 2012 3:47 AM by RUQRU
dds2001 Level 1 Level 1 (0 points)

I continue to get a network error when trying to use the sirius/xm app since doing the update last night.

Any ideas


iPhone 4, iOS 4.2.7
  • 1. Re: sirius xm app network error after update
    christopherfromsioux falls Level 1 Level 1 (85 points)

    Did you try reset network settings, or competely powering off phone, and then back on? Power phone off, wait a minute and power back on first. I have no problem on my verizon iphone. I always power off and on after an update.

  • 2. Re: sirius xm app network error after update
    dds2001 Level 1 Level 1 (0 points)

    yep tried it all nothing seem s to make it work.

    They told me I could go through my web browser however the flash is no longer compatible with new OS

  • 3. Re: sirius xm app network error after update
    christopherfromsioux falls Level 1 Level 1 (85 points)

    You may need to hook your phone back up to itunes and do a restore from backup then, because the app is working fine on my phone with the same OS you have. So it is not the app, but likely something corrupted on your iphone. You will probably start having problems elsewhere.

  • 4. Re: sirius xm app network error after update
    dds2001 Level 1 Level 1 (0 points)

    My only problem with that is the number of people having the same issue all over the web.

    But your right might be my only option.

  • 5. Re: sirius xm app network error after update
    Siriusxm_Girl Level 1 Level 1 (0 points)

    Hello,

    I've been having a lot of problems with the SiriusXM app on my iphone 3GS.  It is constantly buffering and or stops and much of the time I get the error, "Data Connection Lost, please check your connection"

     

    As you can imagine this is very frustrating.  I have restarted the phone and I've also tried resetting the network settings.  I tried running Pandora today and that seemed to work fine.  Maybe it is the App itself?  Is anyone else having similar issues?

     

    This has been pretty bad for about a month or two - seemingly getting worse each day.

  • 6. Re: sirius xm app network error after update
    candi7378 Level 1 Level 1 (0 points)

    I purchased my iPhone4 yesterday and to my dismay, the Sirius app is not loading. I am stuck at a checking credentials message. It works fine on my iPod and I pay for the online streaming. I highly doubt that my phone is corrupted. This is rather embarrasing for Apple, IMO. Good thing I kept my Android phone for backup.

  • 7. Re: sirius xm app network error after update
    PrinceJ Level 1 Level 1 (0 points)

    I know this is an old post, but I just experienced the same "network error" with the most recent Sirius app update on my 4s.  After powering down didn't work, I deleted the app from the phone, which is done by pressing and holding your finger on the app.  When it starts wobbling, press the "x" on the app to delete it.  Go sync your phone, and when that's done, go into your apps list in iTunes, check the Sirius app box and re-sync.  The app is reinstalled on the phone and you can log in to Sirius.

  • 8. Re: sirius xm app network error after update
    RUQRU Level 1 Level 1 (5 points)

    Followed your instruction on my iPad 3rdGen and it worked! Thanks