Previous 1 2 Next 15 Replies Latest reply: Dec 18, 2012 9:44 PM by rockeeeeeee
curtisfromchandler Level 1 Level 1 (0 points)

How do I display text messages to reflect the contact names?


iPhone 4, iOS 4.3.2
  • John_D_NH Level 1 Level 1 (50 points)

    When I tell you - you're going to slap your head and say "Oh - I knew that"

     

    Open up that text message.  If there is a conversation with many texts back and forth, go to the top of the message thread... You'll probably see a phone number, like"123-555-1234" (whatever)...  At the top of the page, press "Add to Contacts"..  After that, you can add that number to existing contact - or create a new contact..  Once you do that, your messages will appear from that number as that "Contact Name"...

     

    Make sense?

     

    Hope this helps,

     

    John

  • applefandan Level 4 Level 4 (1,040 points)

    When a person texts you who is in your contacts, there name automatically appears. If they are not in your contacts, scroll to the top of a conversation and click the add to contacts button.

  • curtisfromchandler Level 1 Level 1 (0 points)

    Thanks to all.  I appreciate it.

  • curtisfromchandler Level 1 Level 1 (0 points)

    After trying the advice given above as well as elsewhere, nothing worked. It turns out that Apple is working on a solution.   Apple told me yesterday that they have determined this is a problem and expects to provide a solution this week or shortly thereafter. I told them that I have 2 other iPhone 4's in the family, but they show the contact names when sending and receiving text messages. They said that not all phones are experiencing this problem.

  • jonfromkanata Level 1 Level 1 (0 points)

    I just started experiencing the same problem.  Went to send a text and now all of the names have switched to phone numbers even though all of the numbers are associated to contacts.

     

    Super annoying... I don't know anyone's phone numbers!  lol

  • GEASTW Level 1 Level 1 (0 points)

    I have the same problem....... its 19th January - so much for Apple resolving this!!!!!!

  • curtisfromchandler Level 1 Level 1 (0 points)

    I fixed the problem awhile back.  Honestly, I forgot how I fixed it exactly, but I seem to recall that I had to make sure that I did not have any double entries for a contact.  Other family members use the Mac and they had additional entries for the same phone number.  I am guessing that it did not know which name to use.  I deleted the double entries and it began showing the contact names.

  • Onanonanon Level 1 Level 1 (0 points)

    I turned off cloud contacts and it fixed it. Have not turned back on yet but worked for me. Settings cloud contacts and copy to phone ;)

  • KOBOB Level 1 Level 1 (0 points)

    I am sorry but that does not work.  The number still appears and it has a +1 in front of it even though I was told that was the problem and removed ALL the country codes from my contacts and asked my husband to send me a new text AFTER I added to the contact it still came in as a phone number.  Also it was working before...

  • Konania818 Level 1 Level 1 (0 points)

    Go to settings --> messages --> turn on iMessage

  • KOBOB Level 1 Level 1 (0 points)

    Been there done that.   No luck.   I am about to go to a droid. 

  • Onanonanon Level 1 Level 1 (0 points)

    Hi kobob,

     

    In the end I found the actual problem was where you have a number in your phone and perhaps you amend it. The final fix I found by trial and error was to delete the thread in messages. Then send a new text by selecting the latest entry. This then worked a treat.

     

    From then on it associates the new MSG thread with the latest version of the contact.

     

    Since deleting the offending messages this has not happened again.

     

    If you want to get your contacts tidy and have a mac I found it best to switch on iCloud duplicate everything and then sit down with the contact app on screen, delete, merge or tidy up that way.

     

    I hope that sorts it and the Samsung latest option is tempting but if you have invested much into I tunes apps or music it may be worth thinking about sticking apple. A friend pointed that out to me! ;)

     

    Good luck.

     

    Cheers

  • rockeeeeeee Level 1 Level 1 (30 points)

    If you're still having probs, I know it's almost a year since OP posted.

     

    If you don't want the phone number displayed in messages, simply go to VIEW>BUDDY NAMES> and then set it to either SHOW FULL NAMES or SHOW SHORT NAMES.   When it is set to SHOW BUDDY HANDLES

    then it displays the phone number. Hope that helps you or anyone else following this.

  • Meg St._Clair Level 8 Level 8 (43,790 points)

    rockeeeeeee wrote:

     

    If you're still having probs, I know it's almost a year since OP posted.

     

    If you don't want the phone number displayed in messages, simply go to VIEW>BUDDY NAMES> and then set it to either SHOW FULL NAMES or SHOW SHORT NAMES.   When it is set to SHOW BUDDY HANDLES

    then it displays the phone number. Hope that helps you or anyone else following this.

    It's not at all clear what you're talking about. None of these things are options in the Messages app.

Previous 1 2 Next