14 Replies Latest reply: May 3, 2014 4:44 PM by OzziesMAC
OzziesMAC Level 2 (150 points)

Came home from work and turned on AppleTV, my mac wakes up on que and the AppleTV MENU is on the screen, but it can't find my library?


I turn iTunes off and then back on and now the library is back to working normally.  Is this the way it's suppose to work or am I forgetting to set something here?



  • Winston Churchill Level 10 (95,708 points)

    This seems to happen to number of users, until a fix is provided, workarounds seem to be restarting iTunes, restarting homesharing or switching to a second library and back again on the Apple Tv.

  • Tim Staab Level 1 (10 points)

    Same with me. I quit and restart iTunes. This fixes the problem for me. Apple needs to address issue.

  • OzziesMAC Level 2 (150 points)

    I think they did with iTunes 10.2.2, give it a try then turn off home share in the Apple TV and sign back on.

    So far it appears to have worked for me, but I am still keeping fingers crossed.


    Let us know if it worked for you.

  • OzziesMAC Level 2 (150 points)

    Well 10.2.2 did nothing, since my problem is back again.  AppleTV can not see the library on the mac unless you turn home sharing off then back on.  I thought the problem was when the mac went to sleep, but it appears to be when the AppleTV itself goes to sleep.  Currently it is set to go to sleep after an hour, this is when the problems starts, it is able to wake up the mac but unable to see the library on itunes.


    If I place the mac in sleep mode appleTV will wake it up and see the library but if the AppleTV box itself goes to sleep then forget about it.  It will not work unless you do one of the resets that Winston Churchill suggested.

  • Winston Churchill Level 10 (95,708 points)

    So far after 10.2.2 My libraries have always loaded when required, perhaps i'm just getting lucky but itonly ever was an occasional issue for me, I'll keep watching and see what happens.

  • Paul Summergrad Level 1 (0 points)

    I am having the same problem even with 10.2.2  - it seems to occur after my ATV2 goes to sleep


    by the way, i have my computer set to wake on network call - is there another way for my ATV2 to wake it up - it doesn't seem to happen

  • CGHayes Level 1 (0 points)

    This is happening to me too but switching Home Sharing on and off (both in iTunes and on the ATV2) doesn't do anything, neither does restarting or reinstalling iTunes. I've wasted time today trying to get it working,


    This is no good at all! I guess we just have to wait for an update? Good luck to everyone having this issue.

  • John Lowry Level 1 (30 points)

    same thing here, was going to show my mother some photos from our trip down south on mothers day and can't get any of my computers to show up in Computers on the ATV 2.  did a restore on the ATV2, along with unplugging it, turn on/off home sharing on computers & ATV, switching to ethernet for the computer instead of wifi.  nothing seems to work.  i can however stream music to the ATV & watch Netflix.  this is extremely annoying.  everything is up to date and firewalls on the computers are off. 

  • Jon Walker Level 6 (18,378 points)

    This seems to happen to number of users, until a fix is provided, workarounds seem to be restarting iTunes, restarting homesharing or switching to a second library and back again on the Apple Tv.

    Winston, if you are having this problem, can you do me a favor? The next time it happens, can you check to make sure the iTunes library drive is awake and spun up to normal speed (i.e., wake it if necessary) before attempting to open a file via the TV device and let me know if the device then works without any other workaround action. I moved everything to a RAID drive that is kept "spun up" at all times and don't have this problem. Just wanted to know if this might be the reason why.



  • Winston Churchill Level 10 (95,708 points)

    Hi Jon.


    The thread is quite old and recent updates seem to have resulted in my library being available all the time now, there were also a fair number of people reporting the same issue at the time and I haven't seen too many since, although there are a couple of new additions to this thread very recently.


    There may have been some mileage in your suggestion though:


    My library is on 3 internal green enterprise drives which are software raided (separately from my system drive), being green they spin down independently of system settings. Occasionally I have to wait a second or two to use iTunes on the mac and probably about one in fifty times on the Apple TV 1, after selecting a movie it will give me the message 'no content found', and I have to press menu and select the video again. It's not all that inconvenient and I love the silence when working at my mac.


    I'm guessing the time the Apple TV 1 allows to find the movie is maybe a fraction longer than it takes my drives to spin up on average and why on occasions I get the 'no content' message.


    Assuming the previous software version running on the Apple TV 2 gave less time to locate the library (slightly different I know but a little similar) than it took the drives to spin up then it could have been the reason for the no library message.


    Further assuming more recent software is allowing more time to locate the library, I can't really test your suggestion anymore.

  • Winston Churchill Level 10 (95,708 points)

    Actually I've just realised the update I was talking about was an iTunes update not an Apple TV update, not sure how that fits in with all I've just said.

  • Jon Walker Level 6 (18,378 points)

    Thanks for the info, Winston. Have not had the exact problem but noted all of the comments here are only a few weeks old. Was previously using a CalDigit 4 TB RAID and never had a problem with any TV devices. In any case, that drive became full last month and I switched to an 8-bay unit with initial set-up of eight WD20EARS (Western Digital 2.0 TB Green drives) which gives me 12.41 TB of useable space in RAID 5 configuration (switchable to RAID 6 "on the fly" if desired with a loss of another 1 and a half or so capacity). In any case, it too over 24 hours to copy the iTunes library form the CalDigit unit to the new unit and it finished on Easter Sunday while we were all out at a family dinner. When I arrived home the unit had spun down and took an extended period to spin back up. Checked the settings and learned that although my unit was defaulted for spin down after 15 minutes of idle time, the same set-up configured as a network drive (I'm using mine in the direct access mode) was defaulted to never spin down. So I simply changed the setting and haven't had any problems no matter how many times I fall asleep in my chair watching content even when the TV2 goes to sleep on its own. Was hoping to get some feedback on the issue to see if library access timeouts might be the cause of this problem.


    Oh, well, take care...




  • OzziesMAC Level 2 (150 points)

    My external drive is nowhere nearly as full, and the wake does cause the external drive to spin up, but my problem is still there.  Apple TV 2 eventually can't find the library after it goes to sleep for a day or two.  It will wake up the Mac and spin up external drive on it but that's it.


    Work around of turning Sharing off then on on the AppleTV 2 still does seem to work, but it is just that a work around. This thread is not really that old, but this problem does seem to be.  My other iDevices do not seem to have this issue with sharing, only the Apple TV, so I have to assume it uses a different protocol that needs updating but it appears to be low on the priority list.

  • OzziesMAC Level 2 (150 points)

    No fixes yet.


    Apple TV looses the Shared Library.  Another work around seems to to work for me is a reboot of the ATV.

    Just wished they would fix this.