10 Replies Latest reply: Mar 15, 2016 3:42 PM by Dazysal
Tim Hassett Level 1 Level 1

I'm installing from a 10.6.3 server install disc onto a Mac Mini.  However, the battery on this Mac Mini is pretty much dead, forcing the system time back to 1/1/2001.  Through some research, this has created a problem in that I cannot move beyond the Welcome screen during setup of OS X server.  It looks like the binary has issues with the system time being older. 

 

But I'm stuck in that I don't know how to adjust the system time from the Terminal Utility on the boot CD.  Can anyone help? 

  • Camelot Level 8 Level 8
    expertise.macosx
    Mac OS X

    Once booted, launch Terminal from the Utilities menu, then use the command line tool date:

     

    > date 042109582011

     

    which, believe it or not, sets the date to 09:58 on Apr 21st, 2011

     

    (man date has the details on the date format)

  • Tim Hassett Level 1 Level 1

    Thanks Camelot!  I actually gave that a try this morning, and received an error that the framework resources were not available and that the command was not valid.  (I'm paraphrasing)  I also tried:

     

    sudo date 1104211137

     

    date 1104211137

     

    $ date 1104211137

     

    Also using those same operators I tried the date format as:  201140211155.00

     

    (I have no idea what I'm doing in the terminal, so I just took those commands based on various Google search results)

     

    I also tried man systemsetup and going that route through those commands, with no success unfortunately. 

  • jenniferfrombeverly Level 1 Level 1

    You need to put full year in if you didnt figure that out already. I personally keep forgetting this old terminal command, beause I come accross this a lot.

     

    Terminal:

    date 112611052013

     

    translated to lamens terms.:

    date nov 26th 11:05 2013.

     

    Hope this helps for anyone else coming across this posting.

  • Eustace Mendis Level 7 Level 7

    Once you have the D & T corerctly set, go to Apple menu / System Preferences / Date & Time, click the Date & Time tab, and check the box to set date and time automatically.

     

    As long as you have an internet connection you will have the correct D & T.

  • rchu89 Level 1 Level 1

    Just want to say that I was having this same problem, and your solution has worked perfectly! Mavericks is finally starting to install. Thank you thank you thank you!!!!!!

  • djtmx Level 1 Level 1

    Hey, i just run in to something similar, tonight while trying to fix a computer.

     

    The user set the time and date on his computer to 1998 and computer locked everything including time and date in system preferences, and his user account basicly making him from administrator to guest. he could not almost any program properly that required administrator privilages.

     

    to fix this we used this comand in terminal " sudo date 201703162014 "    todays time and date

     

    20:17 03/16 2014

     

    we tryed everything and this fixed in 2 seconds

     

    ps: when you type sudo in terminal it whil give you a warning the improper use of this command is bad.... click continue.otherwhise you will not be able to execute the command.

     

     

    thanks again for this post and have a great day

  • NicholasDDD Level 1 Level 1

    Hey guys!

     

    I was been this problem, I changed date & time to 1995... and the mac blocked all application, so try in terminal:

     

    sudo date 032913152015

     

    Using this format:

    usage: date [-jnu] [-d dst] [-r seconds] [-t west] [-v[+|-]val[ymwdHMS]] ...

                [-f fmt date | [[[mm]dd]HH]MM[[cc]yy][.ss]] [+format]

     

    THANKS A LOT OF!

  • 340jetglo Level 1 Level 1

    Jen, your post is just what I needed for Mavericks. And thanks for putting it in "layman's" terms.  ;-)

  • starkeef Level 1 Level 1

    Perfect thanks. I guess I was looking at old posts and only put in the last two numbers of the year.

  • Dazysal Level 1 Level 1

    thank you Camelot