13 Replies Latest reply: May 28, 2011 3:30 PM by paulofachinetti
555films Level 1 Level 1

I think it might be since I updated to XCode 4, but I can't backup my iPhone 3GS anymore. I keep getting "Back session failed" as a message. I tried a restore but it has not restored my address book and I had to manually copy my iTunes songs.

 

All I have have found in support is updating iTunes should fix the problem, only it doesn't I am running iTunes 10.2.2

 

I did manage to get 4.3.2 updated to the iPhone, but i don't want to manually input my phonebook, when the phonebook is on my iMac which is running 10.6.7

 

I did try deleting backup file and that has not fixed the problem. Any other ideas?

Solved by 555films on Apr 22, 2011 4:23 PM Solved

OK I am obviously not explaining things properly. There is no backup file and iTunes just creates an empty directory.

 

If I try sync or backup iTunes gives me a message saying the backup session has failed.

 

If I choose the option to sync contacts in info in itunes, it fails with a message saying backup session failed.

 

In fact whatever I do I get a message telling me that the backup session has failed. No actual backup.

 

I have had some music transfer when I turned off manual music sync. Other than that nothing.

 

I do develop software so I have Xcode 4 installed on both my iMac and Laptop.

 

Backup and sync fail on the iMac and the Laptop. I've tried any fix for this mentioned that I could see on any Apple support pages.

 

My guess is Apple has broken something that may fix itself when they release a bug fix..  I mean update of iTunes, but the current version still has the bug.

  • Ingo2711 Level 7 Level 7
    expertise.iphone
    iPhone

    Is the backup folder empty?

    Mac: ~/Library/Application Support/MobileSync/Backup/


    Before you delete anything inside this folder, copy it to a safe place, just in case...

  • 555films Level 1 Level 1

    Yes, I don't have a backup of the iPhone anymore. It doesn't bother me, what I need is my address book from the iMac back on the iPhone so I can call people.

     

    I get the error if I try and sync or if I try a manual backup.

  • Ingo2711 Level 7 Level 7
    expertise.iphone
    iPhone

    If you don't care anymore, delete all content from the backup folder. Empty the trash, restart your Mac and try again to backup manually, to make sure step one in the sync process is working. If success, make sure there is at least one contact on your phone and start to sync.
    You can also use the option to replace all contact info on the phone by choosing this in the info pane, advanced section.
    Before you start, make sure to backup your address book on your Mac.
    If your sync fails after step one backup, you may have corrupt data on your phone, for example podcasts or photos. Delete the podcasts and copy your photos to your HD and delete them afterwards on your phone. This will also speed up your backup/sync process.

  • 555films Level 1 Level 1

    OK I am obviously not explaining things properly. There is no backup file and iTunes just creates an empty directory.

     

    If I try sync or backup iTunes gives me a message saying the backup session has failed.

     

    If I choose the option to sync contacts in info in itunes, it fails with a message saying backup session failed.

     

    In fact whatever I do I get a message telling me that the backup session has failed. No actual backup.

     

    I have had some music transfer when I turned off manual music sync. Other than that nothing.

     

    I do develop software so I have Xcode 4 installed on both my iMac and Laptop.

     

    Backup and sync fail on the iMac and the Laptop. I've tried any fix for this mentioned that I could see on any Apple support pages.

     

    My guess is Apple has broken something that may fix itself when they release a bug fix..  I mean update of iTunes, but the current version still has the bug.

  • 555films Level 1 Level 1

    I have tried reseting iPhone and I am able to reload Apps and music, all I can't get to transfer is the address book.

     

    Even using the info option on iTunes, the information just doesn't transfer.

     

    I'm out of ideas thanks for help so far.

  • Ingo2711 Level 7 Level 7
    expertise.iphone
    iPhone

    Did you already try to reset the sync history in iSync/Settings on your iMac?

  • 555films Level 1 Level 1

    No I didn't try that yet. OK I've reset sync history and it doesn't fix problem but thanks for idea.

     

    All I'm not getting is the address book information now, I have apps and music on iPhone.

  • Ingo2711 Level 7 Level 7
    expertise.iphone
    iPhone

    Did you try to log in as a new user on your Mac and see what you can do?

  • CyberGemini Level 1 Level 1

    I have the same situation. After install the latest Xcode, I can't backup any of my i-devices. Any fix for it ? I can't restore the setting and address book to my iPhone now.

    Thanks.

  • CyberGemini Level 1 Level 1

    Did you try to re-install iTunes 10.2.2 ?

    I have downloaded and re-installed iTunes 10.2.2. Then when I connect my iPhone and the error disappear, and I am restore my backup now!

  • 555films Level 1 Level 1

    OK I was using iTunes 10.2.2, but I went to Apple's website and downloaded 10.2.2 again and installed it.

     

    This did clear the error and I have now synced my iPhone and transferred my phonebook back to my iPhone.

     

    Thanks for everyone that helped with answers.

     

    Very strange why installing the same version software again should clear the problem, but it worked.

  • jjgodha Level 1 Level 1

    I had the same problem while updating my iPhone (3g S) software to version 4.3.3. It kept on giving the error that my backup session failed. It also gave some weird remote sync related error when my phone was connected to it. I could not see any backups in the Devices section of the iTunes Preferences. I deleted the existing backups manually to no avail. Finally I reinstalled iTunes again (version 10.2.2) and that worked. This is really odd. I'm running iTunes on my MBP (OS X 10.6.7).

  • paulofachinetti Level 1 Level 1

    I had a macbook pro and try to update my iphone 4 with it and got the same error. I also have a mini mac and the backup/update operation of my iphone worked just fine. The problem is that if you have a computer which the "LATEST BACKUP FAILED"(for example if you use time capsule or other device to do it) that's the reason because your update of iphone is not working. First backup your computer, than try to update/backup your iphone, I think it will work fine.