7 Replies Latest reply: Apr 29, 2011 3:29 PM by cosmichobo
cosmichobo Level 3 Level 3 (515 points)

G'day,

 

Issue One:

 

A few weeks ago my Powermac 1.8Ghz dual G5 running 10.5.8 began having somewhat erratic sounding fans. Not flat out - they just sound like they can't quite reach a stable speed... every 5-10 seconds or so adjusting their speed.  No other noticed issues however, so didn't pursue it.

 

Issue Two:

 

After installing the latest updates (security and... Java?), my Mac wont wake fully from sleep.  The CPU wakes, fans resume normal (as per above) operation, and the light on the Apple Studio Display holds solid instead of dimming in/out, but there is no image (ie completely blank screen, no sign of any image), and the keyboard caps lock key does not illuminate...   (I am waking the computer by either clicking the mouse or hitting the space key on keyboard, so it does see them when it's asleep... just not when it tries to wake).

 

Only way out is to hold the power key and force shutdown...

 

Any ideas on either of these issues? 

 

Think I'm about ready to toss this supposed upgrade out and go back to the eMac...

 

 

cheers

 

cosmic


PowerMac 2004 dual 1.8GHz, Mac OS X (10.5.8), 1.25GHz RAM, 2x 1TB WD Green Drives, Stock Vid Card
  • 1. Re: Fans odd idling and Wont wake from Sleep
    japamac Level 7 Level 7 (24,390 points)

    Hi-

     

    Have you run Disk Utility or Disk Warrior to repair the startup drive?

    That may be what is needed for either issue, but the Green drives may also be part of the wake from sleep issue.

     

    Try the hard drive directory repairs first.

    If you have a copy of the ASD, run thermal calibration for the fans.

  • 2. Re: Fans odd idling and Wont wake from Sleep
    cosmichobo Level 3 Level 3 (515 points)

    (Yikes this new forum format is confusing!)

     

    Thanks for the reply, japamac.  And good memory re Green Drives. 

     

    I tried running Disk Utility, from the startup disk.  (Thought I'd try it first that way and see if it found any issues, then look at digging out the instal disk).  There was plenty of permission repairs (always is, and never helps), but nothing else of not.  I also ran Drive Genius, with same result.

     

    I tried forcing sleep (have set the computer not to sleep due to this issue), then tried to wake, and the problem is still in effect.

     

    After rebooting, I left the computer unattended... then returned to find that it Mac OS had crashed, and the computer restarted itself, then produced this error log:

     

    -------------------------------------------------------------------------------- ---------------------------

     

    Interval Since Last Panic Report:  8832785 sec

    Panics Since Last Report:          1

    Anonymous UUID:                    33D1C32F-F13D-4E3B-A070-DC8B992A2364

     

    Mon Apr 25 17:50:19 2011

     

     

    Unresolved kernel trap(cpu 0): 0x300 - Data access DAR=0x00000000907F0028 PC=0x00000000001157EC

    Latest crash info for cpu 0:

       Exception state (sv=0x24696280)

          PC=0x001157EC; MSR=0x00009030; DAR=0x907F0028; DSISR=0x00200000; LR=0x001157EC; R1=0x24703D30; XCP=0x0000000C (0x300 - Data access)

          Backtrace:

    0x001157EC 0x002B6248 0x002B6434 0x003100AC 0x000B4448 0x4964656E

             backtrace terminated - frame not mapped or invalid: 0xF0184E30

     

    Proceeding back via exception chain:

       Exception state (sv=0x24696280)

          previously dumped as "Latest" state. skipping...

       Exception state (sv=0x2d1aaa00)

          PC=0x938B76A0; MSR=0x0000D030; DAR=0xA061AC60; DSISR=0x0A000000; LR=0x0000AA54; R1=0xF0184E30; XCP=0x00000030 (0xC00 - System call)

     

    BSD process name corresponding to current thread: fseventsd

     

    Mac OS version:

    9L31a

     

    Kernel version:

    Darwin Kernel Version 9.8.0: Wed Jul 15 16:57:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_PPC

    System model name: PowerMac7,3

     

    System uptime in nanoseconds: 33671453471586

    unloaded kexts:

    com.apple.driver.Apple02DBDMAAudio    2.5.8f1 - last unloaded 3436912066

    loaded kexts:

    com.apple.filesystems.afpfs    9.0.2 - last loaded 69021181473

    com.apple.nke.asp_tcp    4.7.1

    com.apple.filesystems.msdosfs    1.5.5

    com.apple.filesystems.autofs    2.0.2

    com.apple.driver.AppleTopazAudio    2.5.8f1

    com.apple.driver.AppleTAS3004Audio    2.5.8f1

    com.apple.GeForcePPC    5.4.8

    com.apple.driver.AudioIPCDriver    1.0.6

    com.apple.driver.AppleK2Fan    1.0.10f1

    com.apple.driver.AppleFCU    1.3.2b0

    com.apple.driver.AppleUSBOpticalMouse    3.2.0

    com.apple.driver.AppleSlewClock    1.5.2d0

    com.apple.driver.AppleI2S    1.0.1f1

    com.apple.nvidia.nv30hal    5.4.8

    com.apple.driver.AppleHWSensor    1.9d0

    com.apple.driver.AppleCPUVoltage    1.5.2d0

    com.apple.iokit.IOFireWireIP    1.7.7

    com.apple.driver.AppleUSBDisplays    2.0.2

    com.apple.driver.AppleVSP    2.2.2

    com.apple.driver.AppleK2Driver    1.7.2f1

    com.apple.driver.AppleHWClock    1.5.2d0

    com.apple.driver.PowerMac7_2_PlatformPlugin    3.4.0d0

    com.apple.driver.InternalModemSupport    2.4.0

    com.apple.driver.AppleMaxim6690    1.9d0

    com.apple.driver.AppleAD741x    1.9d0

    com.apple.driver.AppleLM7x    1.9d0

    com.apple.driver.AppleUSBMergeNub    3.5.2

    com.apple.iokit.IOUSBMassStorageClass    2.0.8

    com.apple.iokit.IOSCSIReducedBlockCommandsDevice    2.1.1

    com.apple.driver.Oxford_Semi    2.0.9

    com.apple.iokit.IOSCSIMultimediaCommandsDevice    2.1.1

    com.apple.iokit.SCSITaskUserClient    2.1.1

    com.apple.driver.XsanFilter    2.7.91

    com.apple.iokit.IOATABlockStorage    2.0.6

    com.apple.driver.AppleUSBHub    3.4.9

    com.apple.iokit.IOUSBUserClient    3.5.2

    com.apple.iokit.IOATAPIProtocolTransport    1.5.3

    com.apple.driver.ApplePMU    2.5.6d2

    com.apple.driver.AppleK2SATA    1.0.4f2

    com.apple.driver.AppleGPIO    1.3.0d0

    com.apple.driver.AppleVIA    1.5.1d1

    com.apple.driver.MacIOGPIO    1.3.0d0

    com.apple.driver.AppleMPIC    1.5.3

    com.apple.driver.AppleI2C    4.0.0d2

    com.apple.driver.AppleK2SATARoot    1.0.5b1

    com.apple.iokit.AppleGMACEthernet    1.5.9f1

    com.apple.driver.AppleFWOHCI    3.9.7

    com.apple.driver.AppleKauaiATA    1.2.1f4

    com.apple.driver.AppleUSBEHCI    3.4.6

    com.apple.driver.AppleUSBOHCI    3.4.6

    com.apple.driver.AppleK2    1.7.2f1

    com.apple.driver.AppleSPU    2.5.6d2

    com.apple.driver.AppleMacRiscPCI    3.4.0

    com.apple.driver.AppleFlashNVRAM    1.0.5

    com.apple.security.seatbelt    107.12

    com.apple.nke.applicationfirewall    1.8.77

    com.apple.security.TMSafetyNet    3

    com.apple.BootCache    30.4

    com.apple.driver.DiskImages    199

     

     

    -------------------------------------------------------------------------------- ---------------------------

     

    I'm afraid my IT degree only went as far as first year undergrad... :}

     

    Haven't tried running ASD yet... but am thinking I'm going to have to do a full OS re-instal anyway...

  • 3. Re: Fans odd idling and Wont wake from Sleep
    japamac Level 7 Level 7 (24,390 points)

    I hate these "Unresolved kernel trap(cpu 0): 0x300 - Data access/frame not mapped or invalid:" reports.

    It's almost like saying, "Yep, you're sick"...... vague.

     

    Software is a possibility, so reinstall is a good idea.

     

    Hardware in the form of any cache or memory component is also suspect, so a one pass of zeros on the hard drive and a reseat and test of the RAM can also be in order.

    (Yikes this new forum format is confusing!)

    Agreed.

    Worse than change for the sake of change is that it doesn't "just work".

  • 4. Re: Fans odd idling and Wont wake from Sleep
    cosmichobo Level 3 Level 3 (515 points)

    G'day Japa,

     

    I ran ASD... no thermal issues/help there, but it did identify the RAM as an issue.  Which reminded me that when I was having my little search for reasons why my G5 was running slower than when I first bought it, I swapped the RAM around... which resulted (again) in 2x128GB sticks "disappearing".

     

    Well, the Mac was actually recognising the RAM now... as instead of being invisible, it was registering a total of 1.25GB, but obviously not working properly.

     

    I swapped the RAM back around, and now both problems have been resolved.

     

    I think defrag and write O's to free space just to see if that helps things out too.

     

    Hopefully within the next 12 months I'll have funds to buy a modern iMac instead of dealing with this old beasty... will just need a Raid enclosure now for all the extra hard drives.

  • 5. Re: Fans odd idling and Wont wake from Sleep
    japamac Level 7 Level 7 (24,390 points)

    Good news on finding the source.

    Keep an eye on it, as the RAM problem may be intermittent (marginal chip) and the issue may once again appear.

     

    Drive "maintenance" is pretty much required after RAM issues.

     

    Put a "sticky" up somewhere to test the RAM first should issues arise!

  • 6. Re: Fans odd idling and Wont wake from Sleep
    romko23 Level 2 Level 2 (395 points)

    Hi, sorry to interrupt.. Just because you change computer platforms you can STILL get kernel panics - the Intel Macs are not immune to kernal panic attacks either.. Just wanted to make that clear.

  • 7. Re: Fans odd idling and Wont wake from Sleep
    cosmichobo Level 3 Level 3 (515 points)

    Hi romko,

     

    The platform isn't my issue... nor having a few kernal panics (1).  I purchased the G5 for $100 hoping for a good speed bump up from my eMac.  Initial tests while plugged into my LCD TV (and $50 for a DVI-HDMI cable) showed benchmarks twice as fast as the eMac... I  spent another $100 for a monitor, and then $65 for a new set of processors because 1 was overheating... and then found the bench tests had dropped 50% - ie back to eMac levels...

     

    In reality, I'd say it is outperforming the eMac marginally, and the extra HDD slot is useful, and the 17" Studio Display I picked up is marginally larger than the eMac's 17" CRT...  But it's all so marginal, and now my wife has finished studying, hopefully we'll have our finances sorted out for the first time since 2005, and buying a new Mac again may be feasible... though likely not a Mac Pro...