Previous 1 2 Next 23 Replies Latest reply: Jun 24, 2011 10:37 AM by gioros
flookoco Level 1 Level 1

Mac App store takes ages to load up, then open or search for any apps. It works fine but just very slow. It wasn't always like this, just recently.


iMac, Mac OS X (10.6.7)
Solved by gioros on Jun 24, 2011 10:37 AM Solved
IMPORTANT UPDATE================= Hi All, The upgrade to SL 10.6.8, and consequently of the associated Mac App Store (1.0.2), has cured the problem.Therefore, if you have previously disabled the CRL check in the Keychain Access/Preferences, you canenable it again.When you launch Mac App Store with the CRL on, it will take a while to connect (spinning beachball) on the first run and then it will operate normally. From the second launch, it will run at normal speed. Thanks Apple (finally)
Reply by gioros on May 12, 2011 1:38 PM Helpful
For a brief note on the security aspect, see this page:<http://securityskeptic.typepad.com/the-security-skeptic/2011/04/mac-users-listen -up-enable-certificate-checking.html>Pls also read the last paragraph of the article and consider that both "Online Certificate Status Protocol (OCSP) and "Certificate Revocation List (CRL)" are disabled (off) by default in Mac OS X.Anyway, you could always disable/re-enable the settings in question when you need to have a decent use of MAS.
Reply by Matthew Barker on May 12, 2011 1:41 PM Helpful
BackgroundThe CRL is a "Certificate Revocation List" which is maintained by the CA ("Certificate Authority") that issued the certificate.  This can be a multi-layer thing, starting with the "Root CA" and through successive "CA's" until you get to the server in question.  The client can also have a certificate chain attached that the server verifies, but we'll keep it simpler by deferring that.   You can see a graphic depiction of a certificate chain by logging into the apple discussions using Safari and then clicking on the little padlock symbol on the right end of the Safari window.  You'll see something like:"GTE CyberTrust Global Root" -> "Akamai Subordinate CA 3" -> "discussions.apple.com"This is a certificate chain.  The very first certifier, who has taken responsibility to verify the next certificate Authority is "GTE CyberTrust Global Root".  If you highlight that line at the top of the window, you'll see that you can expand the window and see information about the certifier, their certificate, and often links to further information.  You'll see that the certificate says it is "self-signed".  This means that GTE created the certificate themselves and they are (hopefully) a trusted Certificate Authority.  Note that if it's not a server inside your house or your company, this is not OK unless it is a genuine Root CA. Now, if you highlight "Akamai Subordinate CA 3" and look through the fields, you can see a field called "Usage" which says "Verification".  That certificate is valid for verifying subordinate certificates, like "discussions.apple.com".   Poke around in the certificates and you'll see a bunch of gobbledygook, but also some intelligible information.   If you look through the GTE root certificate, you'll see a link to information on the Verizon web site, some of which may be of interest (or not).   If you're wondering how you know that GTE can be trusted, open up the Keychain Access application (it's in /Applications/Utilities or Cmd+Shift+U from Finder) and look at the list for "System Roots".  If you search the list, you'll find the GTE root CA certificate.  Apple has preloaded the certificates for all of the trusted root CAs here. And the point...Each CA has a Certificate Revocation List which can be consulted by any party wanting to know if the certificate is still good.  Each time a certificate exchange happens, then each CRL for each CA in the change is queried (I don't think a local copy is saved for consultation). If someone has a revoked certificate, either it's been revoked because there was a problem discovered with their identity or because the certificate expired as all certificates have an expiry date.   In practice, some of the intermediate Certificate Authorities do not meticulously update their Revocation Lists, so it may not be a problem.  If there is no chain to the root authority or any of the certificates in the chain are expired, you should see a notation next to the certificate to show that it is no longer valid.  In the case where Safari put's the site name in the right end of the address bar (usually in green), I think the site name will show in red to indicate an invalid certificate or certificate chain, thus a possibly risky situation. So if you want simplicity, look for red and green.  If you want meticulous validation of each site (which is only as good as the most weakly maintained CRL list in the certificate chain), then turn on CRL checking for those times.   As a safety measure, you can, perhaps, just specifically turn off the checklist when you are using AppStore. I hope this helps a little.Kind regards,Matthew

All replies

  • Benoit Garbinato Level 1 Level 1

    Yes, same thing here. This is almost unusable.

  • Armando Stettner Level 2 Level 2

    I answered, or rather commented, elsewhere....

     

    This has also been happening to me and only started happening recently.

     

    From my observations, it is not due to anything local but rather App Store seems to be causing  downloading several tens of megabytes of stuff from Apple web sites (developer.apple.com, among others) and also seems to involve the program ocspd.

     

    Apple, we await a fix from you....

     

      aps.

  • idanno67 Level 1 Level 1

    I use a guest account with fast user switching until someone figures out this bug.

    AppStore seems to work fine with my guest account, which would suggest a corrupt file somewhere.

    So I would think

  • flookoco Level 1 Level 1

    Thanks for the replies.

     

    It looks like we'll just have to wait for a fix from Apple. It's a shame really, as it definitely puts me off using the App Store. Ah well I don't suppose Apple will miss my measly few purchases:)

  • smartpuppy Level 1 Level 1

    HI everyone,

     

    This thread contains some additional things you might try:

     

    https://discussions.apple.com/thread/2799405?threadID=2799405&tstart=15

     

    Hope that helps

  • Carolyn Samit Level 10 Level 10
    expertise.safari
    Safari

    The v10.6.7 combo update includes some MAS bug fixes that may help.

     

    http://support.apple.com/kb/DL1361

     

    Restart your Mac after the combo is installed.

     

    It's ok to do this even if you are already running v10.6.7

  • flookoco Level 1 Level 1

    Thanks for your advice. I followed it and the App Store is improved but still takes an age to load and move between categories etc.

  • smartpuppy Level 1 Level 1

    Unfortunately, none of the solutions so far have worked for me including the 10.6.7 combo update.  Keeping my fingers crossed.

  • Carolyn Samit Level 10 Level 10
    expertise.safari
    Safari

    Shouldn't be that slow...

     

    Login to another user account on your Mac. See if the MAS is slow loading there.

  • flookoco Level 1 Level 1

    Thanks for the suggestion.

     

    I created another user account and launched App Store and the program just flew like it was on steroids. Is there something wrong with my main user account? I can't believe the speed difference.

     

    What can I try now?

  • Carolyn Samit Level 10 Level 10
    expertise.safari
    Safari

    From your Applications folder move the App Store app to the Trash. Empty the Trash.

     

    Now open a Finder window. Select your Home folder in the Sidebar on the left then open the Library folder then the Caches folder.

    Move the com.apple.appstore and the com.apple.storeagent files from the Caches folder to the Trash

    From the same Library folder open the Preferences folder.

    Move these files Preferences folder to the Trash: com.apple.appstore.plist and com.apple.storeagent.plist

    Same Library folder open the Cookies folder. Move the com.apple.appstore.plist file from the Cookies folder to the Trash.

    I know you already installed the v10.6.7 combo but you need to do this one more time. If you still have the original .dmg file, move that to the Trash.

    Reinstall new:  http://support.apple.com/kb/DL1361

     

    If that didn't reinstall the App Store app, follow these instructions.

     

    Get Pacifist

     

    Pacifist is a utility that can extract files from a .dmg folder.

     

    Open Pacifist after you install it. In the Pacifist window click Open Package.

     

    Navigate to the MacOS XUpdCombo10.6.7.pkg. Select that then click Open.

     

    In the next window click the gray disclosure triangle where you see: Contents of manual

     

    Then click the triangle next to: Contents of MacOSXUpdCombo10.6.7.pkd

     

    Then click Applications, then right or control click: App Store.app

     

    Then click: Install to Default Location. That will reinstall the MAS to your Applications folder.

  • flookoco Level 1 Level 1

    Thanks for trying to help Carolyn, unfortunately after doing all of the above it is no better.

     

    The Mac App Store came back up on its own after reinstalling the v10.6.7 combo so I didn't need to go the 'Pacifist' route.

     

    I have timed the application carring out particular actions as follows, before doing this I closed absolutely every program that was running on my iMac and anything running in the background (Dropbox etc):

     

    My own account (best time recorded)

    Time to open after clicking icon in dock = 1 min 16 secs

    Time to switch from 'Featured' tab to 'Top Charts' = 1 min 14 secs

     

    From a new test account

    Time to open after clicking icon in dock = <5 secs

    Time to switch from 'Featured' tab to 'Top Charts' = 2 secs

     

    This is starting to make me paranoid, as I can't understand why most people have no problems with the App Store.

     

    I don't suppose this has anything to do with it but here goes:

     

    I have a warning dialogue that has been popping up every hour or so for the last few months, I don't know what app is causing it so I just click 'OK" and it disappears for a time.

     

    This is the dialogue:

     

     

    screenshot-1.png

     

    Puzzled ??? I know I am.

  • gioros Level 1 Level 1

    The painfully slow behavior of Mac App Store is related to a security setting in the Keychain Access, namely the "Certification Revocation List (CRL)".

    If you are willing to disable it (if I'm not wrong, it should be off by default), the MAS application will regain the original responsiveness.

     

    To modify the setting in question:

    - Quit the Mac App Store application

    - Open Keychain Access > Preferences > "Certificates" Tab

    - Set "Certificate Revocation List (CRL)" on OFF

    - Close the Keychain Access' Preferences pane and quit it

    - Open Mac App Store

  • Matthew Barker Level 1 Level 1

    Yup, that fixed the problem for me.

    Too bad.  Having worked with web security, I like to see that a certificate hasn't been revoked.

Previous 1 2 Next