Previous 1 2 3 Next 65 Replies Latest reply: Feb 7, 2015 7:43 PM by BenTaylow
airharvey Level 1 Level 1 (0 points)

I have owned an iPad (gen.1) for over a year and have no issues with maps, google, etc. determining my "current location"...at home WiFi only, and I know how to fully navigate the iPad software.

 

I now have an iPad 2, and it "Cannot Determine Location" using the same WiFi source and working side-by-side with my gen1 iPad that works fine...even tried on other WiFi hotspots.

 

I have read other threads that this is a known issue with the iPad 2.

 

Others suggested: hard re-boot, power on-off, turn wifi on-off, check Location Services ON, and other say it fixes itself in a few days or weeks???

Others suggest mapping my wifi location with Skyhook, but again I have no issues with gen.1 iPad???

 

What is the correct fix for this issue?

 

Does it eventually work itself out?

Or are others living with this problem?

Is this a future OS fix?

 

Again, only an iPad 2 issue.

 

Thanks


iPad 2, iOS 4.3.2
  • marc080 Level 1 Level 1 (0 points)

    I too am suffering from the same problem.  Ipad2 all Internet connections are fine able to browser without issue and up until recently all location based apps worked fine but now I am getting "cannot determine location" my itouch works fine on the same wifi connection when finding location on maps etc... Tried rebooting router reconnecting to wifi router but still the same issue.  Why does the iPad behave differently to the touch?  They are both on the same OS as well.

     

    Any help would be greatly appreciated.

  • alexalex80 Level 1 Level 1 (0 points)

    I've the same problem too..... how to solve?!? It's very boring.....

  • noeldi Level 1 Level 1 (0 points)

    I had the same Problem with an iPad2 32GB WIFI-only. Another iPad2 16GB WIFI-only was working fine at the same time even with the same WIFI access point/router.

    Double checked all settings: everything seems the same...!?! Really confusing... No official help from Apple... Thanx, Steve... 8-)

     

    Solution: Turn iPad completely off and then on again:

    1. Press power button at top right for about 3 seconds (or more)

    2. Swipe red slider to turn it off

    3. After it completes the shut down, it might be a good idea to wait for about 10 seconds

    4. Press power button again for some seconds

    5. Give it a try with Google Maps or any other app with geolocation

     

    See also: https://discussions.apple.com/message/15102651

     

    Good luck!

  • airharvey Level 1 Level 1 (0 points)

    The problem worked itself out in a few days...

     

    The solution is to use normally until it works...period.

     

    I did the complete, red-slider power off each night, re-booted in the morning, and it eventually recognized my location in maps and all apps...but not sure if this was the solution, or it worked itself out...by the third morning.

     

    All working fine for over a week now.

  • Rologica Level 1 Level 1 (0 points)

    Full *red slider* restart did THE trick for me, immediatly…

     

    Thanks very much!

  • imd23 Level 1 Level 1 (0 points)

    Works for me! I've never turned it off since purchased

     

    Thanks

  • Nexvick Level 1 Level 1 (10 points)

    Same problem here. Restarting did nothing. Hard reboot also did nothing. Toggles WiFi and Location Services (among other things, still no joy.

     

    This is what worked for me. Opened Google Maps and just continued to hit the locate icon and dismiss the warning several times. After about a half dozen times doing that, it mysteriously started working.

     

    Hope this helps.

  • ZakGrim Level 1 Level 1 (0 points)

    Well here's my take on this issue.

     

    I'm having the same issues as everyone here, the difference with me is that the location services worked for me for the first 2 days I had my iPad 2. Then last night it stopped working at my home and at my work, but it worked at 2 seperate public-ish WI-FI hotspots.

     

    I called apple support and they told me that it should be working regaurdless. After walking me through the troubleshooting steps (all the stuff everyone here has said: hard reset, reset network settings, etc) she told me that it must be a 'hardware failure' and to go into the apple store and exchange it.

     

    So I did that, just got home activated my 'new' new iPad 2....and same problem persists. What this tells me is that it must be an issue with the iOS when dealing with certain WiFi networks. It's very frustrating and annoying, but hopefully it will be remedied in an update soon...

     

    I haven't tried methond that Nexvick used...continuing to force Google to try and locate me. I will try that next and see what happens.

  • Nexvick Level 1 Level 1 (10 points)

    Let me know if it worked for you also ZakGrim.

  • ctech08 Level 1 Level 1 (10 points)

    I was haveing same problem tech support said to clean install then load backup .And working for now Ipad2 16gb

    wifi only 4.3.3 google maps and find my ipad all working now.

  • ZakGrim Level 1 Level 1 (0 points)

    When you say clean install, do you mean a full restore?

  • ctech08 Level 1 Level 1 (10 points)

    Yes sorry .Pain but working now

  • ZakGrim Level 1 Level 1 (0 points)

    Well I did nothing different, before I could try and do the 'force' method...everything started working again for me...

     

    Maybe something up on a servers end? I'm not complaining...and I don't want to jinx it...

  • Nexvick Level 1 Level 1 (10 points)

    Well as long as it's working. Guess that's all that matters.

Previous 1 2 3 Next