12 Replies Latest reply: Sep 20, 2015 8:53 AM by geabnnea
Steve Darden Level 2 Level 2

After activating 2-step a few days ago I have been very happy. Then I discovered that my MacPro Mail.app can't connect to my Gmail SMTP server (I was using my hosted domain SMTP before).




My MacBook Pro is a clone of the MacPro, Mail.app connects fine on the MacBook Pro, send/receive IMAP or POP3,  (using the same application specific token (AST) which I originally assigned to Mail.app on MacPro). That was a surprise - I expected the MBP to require a new AST distinct from the MacPro Mail.app token.


To make sure all was kosher, I generated a fresh AST for the MacPro Mail.app, updated the settings.


MacPro/Mail.app receives via IMAP, but fails connecting to the SMTP server (which I have updated with the new AST).


Today's further troubleshooting:


(1) I revoked the application specific passwords for Mail.app both Macs, deleted all the associated Keychain entries. Generated new application specific passwords for the MP ==> IMAP send works but the Macpro SMTP server login still fails.


(2) I turned off 2-step verification, changed all Mail.app passwords back to simple pwd. Everything works but SMTP server login fails


(3) In Mail.app I deleted and recreated the account for a *different* Gmail IMAP address. That worked fine, including the associated SMTP login.


This is silly, but there seems to be a curse on one specific smtp.gmail.com login. I have left 2-step verification turned off for the moment until I resolve the SMTP login fault.


If I deleted and recreated the problem IMAP account in Mail.app it would probably fix the problem. But we are in Australia with tight bandwidth caps, I can't afford to redownload 20,000+ emails. And I need them local because we often don't have internet access.

Mac Pro, Mac OS X (10.6.7), 23" Apple Cinema HD, ATI Radeon 3870
Reply by jmegawarne on Jun 18, 2011 4:57 PM Helpful
I seem to be having the exact same problem. Did you ever find a resolution to this issue?

All replies

  • jmegawarne Level 1 Level 1

    I seem to be having the exact same problem. Did you ever find a resolution to this issue?

  • Steve Darden Level 2 Level 2

    I wish I had a solution for you. I'm using my own domain SMTP since I can't get Google to work.

  • jmegawarne Level 1 Level 1

    I think I may have a solution for you that just worked for me.


    1. Delete the smtp.gmail.com entry in your Keychain corresponding to the problematic server.
    2. Revoke and regenerate the application-specific password in Google Accounts. Write it down somewhere too.
    3. In Mail.app, change the password for the SMTP server to the newly generated one.
    4. Try to send something. It will probably hang around in Outbox and spin. Leave it there.
    5. After some time, Mail will prompt you for the password again. Type in the app-specific password and save to your keychain.
    6. Enjoy working Mail.


    I would be interested to know if this works for you. Good luck!

  • Steve Darden Level 2 Level 2

    Very interesting - thanks! Rather weird Mail.app behaviour (delayed login fault).


    I can' test right now as (1) we are heading off for a few days and (2) I disabled 2-Step while troubleshooting this SMTP fault. It's a waste of time to reactive 2-step until we get to the next country (USA) and get new mobile numbers.


    Soon as we have new mobile I will reenable 2-step and report back here.



  • jmegawarne Level 1 Level 1

    Another follow-up…


    I also found that it helped to force the port to 587 in the SMTP server list.

  • martinfromslovakia Level 1 Level 1

    Yes, this is mandatory 7th step. I followed the 6 steps above and nothing happend. Manually changing SMTP port to 587 solves this issue.

  • drschwartz Level 1 Level 1

    How did you activate 2-step?

  • lajlev Level 1 Level 1

    Important note you need to create two application-specific passwords. One for IMAP and one for SMTP

  • Yiribana Level 1 Level 1

    I also had a problem configuring a Gmail POP account in Mail.app. I solved it by using TWO different application specific passwords, one for the POP server and one for the SMTP server.

  • pban02 Level 1 Level 1

    For me, this problem occurs only with Google Apps accounts - these are the ones where you use your own domain e.g. yourdomain.com and not gmail.com.

    Wwo-step authentication is disabled on the Google Apps account.


    Right click on your mail account name (under Inbox) and click "Edit Account"


    Edit the SMTP server list and select the advanced tab.

    By default Apple mail only has your user name in the user name field (e.g. user1)


    Change this to user1@yourdomain.com and reenter your password.


    I also set the SMTP port to 587


    Everything is working fine now

  • jfsettanni Level 1 Level 1

    It works exactly as you said.


  • geabnnea Level 1 Level 1

    For anyone else who is having a similar problem - with 2 factor authentication enabled, you no longer need app passwords.  However, in certain circumstances, you can no longer change your password directly...because it will trigger the 2 factor authentication prompts (where you enter a code that is sent to you via SMS) and not all of Mail's various screens (like the default account screen) have been upgraded to support this.


    So, to correctly update or re-enter your password after triggering GMail's 2 factor warnings (mostly likely if you're using a laptop from a new country etc.) - then go to Mail > Accounts and select your account.  Mail will ask you to enter the password, do so, and then it will prompt you to enter the pin (the 2nd factor).  If you go to Mail > Preferences and try to change/edit the password there - you won't get the 2 factor warning and you'll still have problems.