12 Replies Latest reply: Sep 20, 2015 8:53 AM by geabnnea
Steve Darden Level 2 (155 points)

After activating 2-step a few days ago I have been very happy. Then I discovered that my MacPro Mail.app can't connect to my Gmail SMTP server (I was using my hosted domain SMTP before).




My MacBook Pro is a clone of the MacPro, Mail.app connects fine on the MacBook Pro, send/receive IMAP or POP3,  (using the same application specific token (AST) which I originally assigned to Mail.app on MacPro). That was a surprise - I expected the MBP to require a new AST distinct from the MacPro Mail.app token.


To make sure all was kosher, I generated a fresh AST for the MacPro Mail.app, updated the settings.


MacPro/Mail.app receives via IMAP, but fails connecting to the SMTP server (which I have updated with the new AST).


Today's further troubleshooting:


(1) I revoked the application specific passwords for Mail.app both Macs, deleted all the associated Keychain entries. Generated new application specific passwords for the MP ==> IMAP send works but the Macpro SMTP server login still fails.


(2) I turned off 2-step verification, changed all Mail.app passwords back to simple pwd. Everything works but SMTP server login fails


(3) In Mail.app I deleted and recreated the account for a *different* Gmail IMAP address. That worked fine, including the associated SMTP login.


This is silly, but there seems to be a curse on one specific smtp.gmail.com login. I have left 2-step verification turned off for the moment until I resolve the SMTP login fault.


If I deleted and recreated the problem IMAP account in Mail.app it would probably fix the problem. But we are in Australia with tight bandwidth caps, I can't afford to redownload 20,000+ emails. And I need them local because we often don't have internet access.

Mac Pro, Mac OS X (10.6.7), 23" Apple Cinema HD, ATI Radeon 3870