2 Replies Latest reply: Apr 28, 2011 12:39 PM by mack7
mack7 Level 1 Level 1 (0 points)

My 2003 Power Mac G5 1.8 won't boot.  I get the power light and the chime, then the Apple logo but no spinning disk.

 

I've already tried swapping the RAM around, replacing the battery and a couple of other easy fixes but no luck.  I've read that the problem might be the capacitors.  I can solder but don't know where to get the caps.  Any help on that one?

 

Any chance a very dirty power supply or board might be the problem?

 

Thanks,  S

  • old comm guy Level 4 Level 4 (2,235 points)

    OK, you get power light and chime, then the gray Apple but no progress gear.  That is suggestive of early problems with your boot volume.  I don't think the power supply is an issue, nor do I necessarily thing it's a logic board problem.  Have you booted from an install disk to see if that works.  Also, have you tried a "Safe Boot" by holding down the shift key?  Safe boot forces a pass of fsck during the boot process which checks and attempts to repair the boot volume's directory.

     

    You might try an NVRAM reset using Open Firmware.

     

    NVRAM is read early, by the machine’s boot firmware, and going back to ground zero can help.  To reset NVRAM, you need to boot into Open Firmware by holding down the cmd-option-O-F key combination until you get the white Open Firmware terminal screen.  Once you are there, enter the following three commands:

     

     

    reset-nvram <cr>

    set-defaults <cr>

    reset-all <cr>

     

     

    The last command will cause the machine to reboot and with any luck, you should come up with a normal boot.

     

    If not, the next thing from a troubleshooting perspective would be to do a verbose boot to see what is happening there.  You do that by holding down the cmd-V keys at power on and you should get eventually a black Unix terminal screen with some terminal text output that might be helpful showing where you are hanging.

     

    So far, this doesn't seem like a catastrophic problem.

  • mack7 Level 1 Level 1 (0 points)

    I tried those fixes earlier with no luck.  I have now taken apart the computer and put it back together so now it does very little but whir.  Looks like I'll be trying to recycle it.