12 Replies Latest reply: Jan 24, 2013 9:46 AM by JLaurenson
Fawn Liebowitz Level 1 Level 1

I have a few email accounts.  For my Gmail account if I send an email on my iPhone, it does not show up on in sent mail on my Mac (or anywhere else for that matter).  I am using Apple's Mail application and the emails I am sending from iPhone are also being sent from the mail application as opposed to using the Gmail HTML interface.  Gmails sent from my iPhone do show up in sent mail when I open Gmail in a web page.  Also, emails sent from my Gmail account on my Mac do show up in sent mail on my iPhone. 

 

I only have this problem with Gmail (my primary email account).  My other emails sync up fine between me iPhone and Mac.

 

Other info:

 

Outgoing mail server:  smtp.gmail.com

 

Mailbox behaviors:  "Drafts Mailbox" and "Trash Mailbox" are listed under Mailbox Behaivors, but there is no "Sent Mailbox" like I have with my other accounts.  I have a feeling that this is the root of my problem since I have no way of electing to have my Sent mail stored "On the Server".

 

Any suggestions would be greatly appreciated!


iPhone 3GS, Mac OS X (10.6.3)
Solved by Boomdiggy02 on Jul 1, 2011 11:26 AM Solved

If you set up Gmail on your iPhone as exchange it works like a charm.

  • Fawn Liebowitz Level 1 Level 1

    Additional information:

     

    I have the same problem with my iPad, however when I send Gmail emails from my iPhone, they show up as sent emails in my iPad and vice-versa. 

     

    So, to summarize:

     

    1) Gmail emails from my Mac show up in the sent folder for both iPhone and iPad

    2) Gmail emails from iPhone show up in the sent folder for iPad and vice-versa

    3) No Gmail emails sent from either mobile device show up in the sent folder on my Mac

     

    I also have a MobileMe subcription if that accounts for anything.

  • jsoegandi Level 1 Level 1

    i have the same issues with using an iPhone 3G and Mac OSX (10.6.7)

  • Boomdiggy02 Level 1 Level 1

    If you set up Gmail on your iPhone as exchange it works like a charm.

  • Fawn Liebowitz Level 1 Level 1

    Thanks!

  • Ken Auggie Level 1 Level 1

    If you delete then recreate your Gmail account on your iPhone (I assume this is the only way to do it), do you lose all the "sent" mail that resides only on your iPhone?

  • scott142 Level 1 Level 1

    how do you setup gmail as exchange.....what is the server and domain?

  • Ken Auggie Level 1 Level 1

    I had to "Google" for the answer, but to setup Gmail as an Exchange account:

     

    SERVER: m.google.com

    DOMAIN: (blank)

  • scott142 Level 1 Level 1

    You all are incorrect.  I contacted Apple and spoke to the email specialist and she stated that it was impossible to have web based programs GMAIL, IPHONE and IPAD have messages sent from those aforementioned programs show up as SENT EMAIL in the MAC MAIL program.   She stated that the MAC mail is highly advanced that it sends the "sent email " to the GMAIL, IPHONE and IPAD account.    It will only change when GMAIL updates their mail program.

  • asetia Level 1 Level 1

    Using Google Apps for my own domain names, I find I have the same problem if I set it up as a Gmail account (everything else works). However, I find it works properly if I set it up on my iPhone and iPad as Account (Type as "Other") and manually set as:

     

    - IMAP

    - set Incoming Mail server to: imap.gmail.com (with email id as username and password as appropriate)

    - set Outgoing server to: smtp.gmail.com (with email id as username and password as appropriate)

     

    I would imagine this would also work for gmail.com accounts as well as the Google Apps email seem to work on the same infrastructure.

  • Joelrsny Level 1 Level 1

    For Sent folder not showing on the iPhone.

     

    ALL of these ways work to add a Gmail account to the iPhone. Its not how you add it, its the settings in Gmail causing these folders not to appear.

     

    Do not add the account to the iPhone first. Go to Gmail.com in a browser, log in to your email account and hit settings at the top right.... Select the Labels Tab at the top. On the right, you will see check boxes. Check all the folders you want to appear in imap accounts. Once you check them, go and add the account by just picking add Gmail account on your iphone settings for mail. ALL the folders you checked will appear...

     

    Done!

  • JLaurenson Level 1 Level 1

    This did it -- thanks!

  • JLaurenson Level 1 Level 1

    Joelrsny had the much easier fix:

     

    For Sent folder not showing on the iPhone.

     

    ALL of these ways work to add a Gmail account to the iPhone. Its not how you add it, its the settings in Gmail causing these folders not to appear.

     

    Do not add the account to the iPhone first. Go to Gmail.com in a browser, log in to your email account and hit settings at the top right.... Select the Labels Tab at the top. On the right, you will see check boxes. Check all the folders you want to appear in imap accounts. Once you check them, go and add the account by just picking add Gmail account on your iphone settings for mail. ALL the folders you checked will appear...

     

    Done!