Skip navigation

Macbook wont turn on and not charging

4757 Views 3 Replies Latest reply: May 3, 2011 4:06 PM by QuyenPham RSS
JonathanDS Calculating status...
Currently Being Moderated
Apr 28, 2011 11:21 AM

Hi!

 

My macbook wont turn on! Hope someone can help, and that my long description doesnt scare people off.

 

 

HISTORY:

 

I just bought a used Macbook (white Macbook 4,1 - early 2008 http://support.apple.com/kb/sp5). When I bought it, it was running the OS X 10.5.?? i think. No original CD's came with it when I bought it used, so I did not have the OS on a cd, so I decided to buy the SnowLeopard from the apple store, so I could do a clean install, and get rid of all the old files and settings from the previous user.

 

I inserted the SnowLeopard Disc into the Macbook DVD drive, and noticed that there was some friction that was not supposed to be there when I inserted the disc, but it slided in anyway, and eventually the Macbook recognised the DVD.

 

I reboted the computer and hold down the C button to run the setup. Before I ran the setup, I deleted the "Macintosh HD" partition on the hard drive, and created a new partition called the same. (just so that all the data would be deleted on the computer). Then I started the installation and installed the SnowLeopard OS.

 

The installation went fine, and the computer rebooted, and went into setup where I create my account and password etc..

When the os had started, I tried to get the DVD out of the drive, but it did not work. I tried to eject the DVD in various ways, (itunes, Disc Utility, keybord button etc..), but it peeked out quickly a tiny bit, and then went back in. I decided to not deal with that for now, and let the DVD stay in the drive.

So the OS was installed perfectly fine, and worked fine, I played with it for an hour or so, and also installed a browser and a video player etc. It all worked fine. Then I downloaded the software updates, and I guess that included an update for the SnowLeopard. When I was done playing with it, I clicked the Apple Logo and clicked shut down. Then the computer asked to install the update I downloaded, but I said clicked NO, since i wanted to do it another time. The computer shut down normally, and I left it with the charger plugged in, and went to bed.

 

The next morning the computer would not start when I pressed the power button. Nothing happened.

 

PROBLEM:

The computer wont turn on when I press the power button. Nothing happens.

The computer doesnt seem to be charging when plugged in.

The DVD drive is jammed in some way.

 

STATUS:

The battery indicates full power (when pressing the battery button on the battery, all 5 LEDs light up)

The Magsafe charger LED indicator on the plug does NOT light up when I plug the computer in.

The SnowLeopard DVD is in the drive.

 

WHAT I HAVE DONE:

I have performed a SMC reset by removing the battery and holding power button 5 sec, as described: http://support.apple.com/kb/ht3964 and also done it by holding the Shift-Control-Option key. Nothing happens. And there are still no response at all from the system.

Used another Magsafe charger on my computer, and it didnt work either. Used my own charger on another computer, and it worked fine.

 

 

Could it be the DVD drive that is causing the computer not to start? or does it sound like my computer is fried over night when charging? Could it be the battery not being connected correctly to the rest of the circuit board? Could it be the SnowLeopard messing up, or my drive partition is done in a wrong way?

 

I really hope that someone can help me, or give me a hint in the right direction what to do. I am thinking taking it to the apple store, but if someone has an idea about what could be wrong, and how to fix this, I would really appreciate it!!

 

Thanks a lot for your time!

JonathanDS

MacBook
  • David Bedford Calculating status...
    Currently Being Moderated
    Apr 29, 2011 1:04 AM (in response to JonathanDS)

    Sounds like it may be mother board issue, had the same thing on my old iBook some years back. You may be able to get the DVD out by sliding a credit card in the slot under the DVD.

     

    But an Apple authorised repairer seems the best route to me.

  • QuyenPham Calculating status...
    Currently Being Moderated
    May 3, 2011 4:06 PM (in response to JonathanDS)

    Mine has the same problem has yours. When I plugged in the power cord, the magsafe indicator light didn't flash either green or orange. I checked the battery; and unfortunately neither of 5 lights was flashing. My macbook couldn't turn on.

     

    So i'm not sure whether the problem is the mother board or the battery. so worry now.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.