0 Replies Latest reply: Apr 28, 2011 6:04 PM by Lindsey21
Lindsey21 Level 1 Level 1 (0 points)

I just bought the iPhone 4 and love it. But, when I tried to connect it to my current iTunes account and download my music, there is an error. It says "iTunes requires a newer version of Apple Mobile Device Support. Please uninstall both Apple Mobile Device Support and iTunes. Then install iTunes again." I have already uninstalled iTunes and reinstalled it and restarted the Apple Mobile Device Support but I keep getting the same error message. What do I do?


iPhone 4, Windows Vista