14 Replies Latest reply: Jul 15, 2015 12:47 PM by Al_________
Shaun Conn Level 1 Level 1 (115 points)



my machine (Mac Pro quad core, 10.6.7) is running really sluggish recently, and Activity Monitor shows a massive amount of processor taken by "Quick Look Helper".


I have read through various posts, and tried the following:


1. Turn off spotlight indexing

2. Repair disk, repair permissions

3. Create a new admin user, and reboot, log into that

4.  remove the QuickLookDaemon.plist file

5. killing the quicklook processes (they instantly respawn)


I do not have VMWare or Perian (apparently two culprits for this behaviour), but if anyone knows of any other likely candidates I'll remove them!


I looked in the console log and whenever I kill the process an entry is written:


29/04/2011 14:42:23          quicklookd[327]          [QL] blob database is invalid

29/04/2011 14:42:23          quicklookd[327]          something is wrong, let's close the cache and open it after the reset (index is valid, blob is invalid)


but this could be because I'm killing it (I have tried both killing from the activity monitor, and "killall STOP quicklookd").


I really don't want to have to rebuild my machine!



  • Kappy Level 10 Level 10 (262,780 points)

    Have you tried deleting the /Home/Library/Caches//com.apple.QuickLookDaemon/ folder?  Do that and see if it helps.  You should restart after removing it.  Could be a corrupted cache file causing the problem.  You might also get rid of the /Home/Library/Preferences/com.apple.QuickLookDaemon.plist preference file.

  • Shaun Conn Level 1 Level 1 (115 points)



    Removing the Cache seems to have cured it - many thanks!



  • paulfromhendricks Level 1 Level 1 (0 points)

    Nope, sorry, tried all that.  Just like I've tried other hints.  The fan still occasionally roars like a jet fighter taking off.  Each time, I need to use Activity Monitor to quit Quick Look Helper.  MacBook Pro 2.7 GHz Core i7, 8 GB RAM, running 10.6.8.






  • brightcode Level 1 Level 1 (0 points)

    Same problem here (MBP 15" 2011 with OS-X 10.6.8). After downloading large files the computer starts soaring. QuickLook Helper takes 100% CPU. The system logs shows the following messages:


    Jan 18 11:43:00 ... Dock[104]: [QL] Thumbnailing /... - too many tries

    Jan 18 11:43:20 ... quicklookd[468]: [QL] 'Creating thumbnail' timed out for '<QLThumbnailRequest /...>' (Start date: 2012-01-18 11:43:00 +0100)


    I deleted the QuickLook cache, as suggested above. After rebooting QuickLook Helper immediately started to take up all CPU for a while.


    I also excluded the Download folder in Spotlight settings. Zero effect.


    To "quick look" large files in Finder is pretty useless. How can I shut this thing down?

  • brightcode Level 1 Level 1 (0 points)

    Update to my previous message. I have resolved the 100% CPU issue in my case.


    Some other posts guided me in the direction of QuickLook generators. I was downloading large CSV files, and Microsoft Office seems to have installed a Quick Look generator for those files.


    I resolved the issue by removing CSV from the Office generator. I did this with:


    $ sudo vi /System/Library/QuickLook/Office.qlgenerator/Contents/Info.plist


    Find the line <string>public.comma-separated-values-text</string> and delete it.


    Then I deleted the cache as mentioned above once more and rebooted.


    To be frank, I wasn't suprised that it was Microsoft software messing up my Apple.

  • paulfromhendricks Level 1 Level 1 (0 points)

    I assume that sudo command was to be done in Terminal.
    I did that and the <string>...</string> line you refer to did not appear.

    I have yet to find a hint that actually solves this Quick Look Helper debacle.

  • AriostoSilva Level 1 Level 1 (0 points)

    I didn't bother in editing the file, I just copied it to another place and deleted it. Solved my problem, which was the Quick Look Helper running intermittently and allocating >5GB of memory and making my computer slow.

    Thanks for the help guys!

  • HugoA Level 1 Level 1 (0 points)

    Hi, I seem to be having the exact same problem. My Mac is constantly showing a warning message stating that my startup disk doesn't have enough memory. Sure enough, Quick Look Helper is working at 140% capacity.


    However, I can't find any QuickLookHelper files you describe anywhere! Are there alternative names for these files?


    Thank you.

  • williamfromandover Level 1 Level 1 (0 points)

    Same here. 800% of cpu on i7 MBP.  Running very hot.  One observation... when a new mail document is open with a picture in it, fan and QLH seems to ramp up.  Close mail document, QuickLookHelper shuts down, fan stops.  Maybe it was the particular PNG or zip files in the mail document, maybe not. Don't know if this helps anyone, but it would be interesting to see if others have the problem, then maybe they could find the issue.


    It would suck to be on battery when this happens!



  • paulfromhendricks Level 1 Level 1 (0 points)

    I am running 10.6.8 and this very same problem began for me for no known reason.  QLH became the bane of my everyday life, flaring up at unexpected times.  I learned:


    (1.)  Keep Activity Monitor running at all times.  It lets you easily kill QLH when it rears its ugly head.


    (2.)  HOWEVER . . . I ended the whole problem by reinstalling the OS.  Ever since I reinstalled, I have not had one single issue with QLH.  That doesn't mean it might not explode back onto the scene once again for those same "no known reasons." 


    This was horribly frustrating.  GOOD LUCK.

  • Tweak Head Level 1 Level 1 (0 points)

    Here's how I solved it (with no apparent ill-effects noticed so far)


    I backed up (copy to desktop & zip archive) the "quicklookd" app and and then deleted the original.


    The Path for the app is:



    I then enabled Root User, repaired permissions, rebooted, disabled Root User.


    So far, the 400% CPU problem has completely gone.


    P.S. BTW - I am in Lion (10.7.4)

  • Fuwu Level 1 Level 1 (0 points)

    So i've had the same problem for a year now on my old macbook from the year 2008 running snow leopard. After upgrading ram to 4gb the problem is gone...... i had 2gig before and i thing one of the modules was not working properly. After installing 2x2gb of ram the macbook is like new for just 40,- euro.


    Hope this helps,



  • _Cliver Level 1 Level 1 (0 points)

    I was having the same problem with my Mid 2009 MBP (10.6.8). Turns out it was a corrupt cache file but NOT /Home/Library/Caches//com.apple.QuickLookDaemon/. That didn't even exist on my laptop. I deleted a couple of other cache files from the 2010, 2011 era. Reboot and voila in activity monitor it pegs the usage for about a minute and then calms down and all is good. I am not sure what cache file it was but I don't care at this point.

    No more red hot MBP


    Give it a whirl...

  • Al_________ Level 1 Level 1 (0 points)

    It's a bug for sure [to this very day!], but the root-cause is a cached search in Finder which tries to find every file on the system and runs out of resource handles or something.

    It's an obvious use-case in Finder that I'm astonished nobody has spotted yet (but I have been a Unix/Linux system developer for 20 years).


    When Finder is doing it, you can both get rid of the phantom 'suck search' immediately, but also fix it permanently with 2 button clicks:-


    When you have the issue, on the finder menu bar, you'll see the 4 icons pertaining to switching views, list, columns, coverflow, <something> etc.


    Just click one of the buttons once to change the view to something else from your usual default, then click the button pertaining to your default view preference to change it back.


    You should notice 3 things:-


    - The CPU-spin stops immediately and normality returns.

    - The phantom stuck search gets removed

    - It doesn't happen again - of course until you exercise the Finder design flaw (that's been there, what 7 years now!?!?) again. Just repeat until somebody wakes up and figures it out.