7 Replies Latest reply: Apr 28, 2012 5:52 PM by Hugoniot
Electriz Level 1 (0 points)

Hello everyone. I'm not sure if anyone here can help me with this, but I'm losing my patience with an iPad 2 issue I've been having.


Here's the short version of the story: I can't sign up for 3G service at all on my Verizon 16GB iPad 2 with iOS 4.3.2. Whenever I click "View Account" on the Cellular Data settings tab instead of a form to fill out your information to sign up for 3G, I get some text that says "cannot activate your iPad" and some number for a Verizon customer service line.


Now here's the backstory to this problem: I originally had one of the first batch iPad 2s after waiting online at 1am PST on March 15th to order one. It came with a dead pixel and very bad backlight bleeding issues. I decided to use my warranty a few months later to let the manufacturing errors and glitches minimize. Three days ago I did just that and I walked out of the Apple Store with a brand new iPad 2... that wasn't connecting to 3G. I made another appointment and went in again today to do another swap out. They diagnosed my iPad as another lemon model and sent me out with even another brand new iPad. However, I get home and I update the firmware only to have the same exact problem as I had before: "cannot activate your iPad."


Now for the specifics to my problem: This seems to be a relatively new and undocumented issue. However, seeing that I have went through 2 iPads in a row with this problem makes me wonder if I've walked under any ladders recently without knowing or that somehow the 3G reciever section at the plant in China decided to quit working for a few hours; my guess is as good as yours. Just to clarify, my PRL number is not 0 and while talking to a Verizon representative they could not even find my MEID number on their system.


Now, the problem to my problem: I don't know what to do now because my spring break ends tomorrow and I need to get back to college where there are no Apple stores nearby. I tried to test out the 3G in the Apple store when I was there but apparently Verizon takes a while to actually recognize the system and I didn't have time to stick around (besides, I would have needed to go home to update the firmware to troubleshoot anyway). So... I'm in a pickle. I'm planning on calling the Apple representatives tomorrow to see if they can do anything, but I don't have very much confidence that they would be able to do more than what the Apple geniuses can do. I'm just posting my story on here to see if anyone else can help in the meantime.


But, anyway, sorry for writing a novel and thanks in advance for any help you decide to assist me with.

iPad 2, iOS 4.3.2
  • jennamarietx Level 1 (0 points)

    I am experiencing a somewhat similar problem trying to activate my 64GB iPAD 2 with Verizon. I go to Cellular Data, View Account, and then enter in all the information it asks for in "Cellular Data Account", including the credit card info. When I'm done, it says "Session Expired, Please Login Again". It does this EVERY TIME, and I tried it several times. So Apple, I say to you, your website is highly misleading when you imply that service can be easily added right from your iPAD...   Not quite! 


    I already have a Verizon account for my cell phone, but there's no obvious way to add an iPAD to that account, unless maybe you actually purchased the iPAD directly from Verizon; I ordered mine from Apple. So, I guess I'll take it over to a Verizon store and see if THEY have any luck connecting it to their service, I give up!

  • RAYJPAPILLION Level 1 (0 points)

    I experienced the same thing. Did a 'reset all settings' and that fixed my problem regarding expired sessions.

  • BobTheFisherman Level 6 (12,350 points)

    Electriz wrote:


    Here's the short version of the story: I can't sign up for 3G service at all on my Verizon 16GB iPad 2 with iOS 4.3.2. Whenever I click "View Account" on the Cellular Data settings tab instead of a form to fill out your information to sign up for 3G, I get some text that says "cannot activate your iPad" and some number for a Verizon customer service line.




    So what did they say when you called the number?

  • rikithemonk Level 1 (10 points)

    I have the exact same problem.  I input all the info and hit enter.  I accept their terms of service and it thinks for a while, then gives me a "can not activate." 


    So I called and got an idiot who didnt listen to what I was saying and kept trying to fix a different issue.  Then after 20 minutes she says "Well thats your problem, you never created an account."  I roll my eyes and tell her ive tried several times.  She asks me if the wifi is on and tells me to turn it off and try again.  I do so and reenter the account info.  No surprise, i get the error.  She then tells me to reset network settings, and other things.  Doesnt walk me through it, until i get ****** and ask her where the setting can be found.  After reseting several things and restarting, She has me try again.  At this point were at 40 minutes.  When it fails again, she asks me to test the internet.  Now remember, my 3g isnt set up yet and she told me to turn off wifi.  So obviously i get no internet.  I tell her this and she says "Theres your problem, your Wifi is off.  Turn it on and try again."  Im banging my head on my desk by this point.


    "Look" I say, "Can I sign up via website or can you set up my account for me over the phone?  Its not going to work from my iPad for some reason."  She says "No, its iPad only."  At this point I tell her to go pound sand and hang up.


    My thought is that it may not like "Chase Credit cards"  But I cant test that theory because I only have Chase.

  • Plazar Level 1 (0 points)

    Hy guys,


    I have problem w/ 3G connection to, but 1st, u all talk about : view account in the

    Cellular data section, but the problem is I ain't got view acc. If any1 knows what to do plz help

  • rikithemonk Level 1 (10 points)

    OK,  I finally got it resolved.  Had to call Verizon tech support three times, but eventually I got to Level two tech support.  Heres a hint guys.  If the person your working with doesn't go through a predefined trouble shooting script, ask for someone who does.  Its an idiot proof script.  You know the type. "is your iPad on?"  "Ok, were going to restore to factory settings."  That kind o thing.  But the important point to the script is when they are done, they send you to level 2 support.  The first two idiots I talked to didn't do any of that.


    Ok, I know what your thinking.  Shut up and tell us what was wrong and how it was fixed.  Ok, here it is.  Level 2 has seen this before.  What happens is that the account only gets half activated. (they dont know why.)  What they need to do is delete the half formed account and reprovision the account.  Reprovisioning the account can be found SETTINGS>GENERAL>RESET>SUBSCRIBER SERVICES>REPROVISION ACCOUNT.


    Here are the exact steps that worked for me.  Daniel from Level 2 support deleted my Verizon account and told me to hit the reprovision button.  Then im told to resign up for Verizon.  it works this time and the account is created.  However it still didnt give me bars on my iPad. I decide to reprovision my account again just to see.  I then manually do a hard restart of my iPad.  Bingo.  I have bars and Verizon 3G


    This is the solution to the problem of not being able to complete the Verizon activation only.  Which was my problem.  

  • Hugoniot Level 1 (5 points)

    Looks like @rikithemonk is onto something. My mom bought a new iPad and got this connection problem. She first called Verizon and was given a story that it has something to do with her AOL email address. Tech support wanted her to plug in her iPad to my Mac, which she wouldn't do without me around. That is good, because I could talk to a Verizon rep after reading the discussion boards and get a better idea of how to fix this.


    When I called Verizon, the support guy took the iPad's MEID number, did something, and then had me reprovision the account, as described above. Now I can access the Internet through LTE, even though instill get errors when I try to access my cellular account settings. Verizon said it might take a week for that to get resolved.


    Furthermore, Verizon patched me through to Apple to work on upgrading the OS build.  (This is found in Settings->General->About->Version). I have iOS 5.1 (9B176). Apple then connected me to a high level support guy, who said that I have the latest build. So Verizon was quick to solve the problem, but was still ignorant and had me wait on the phone for a long time to track down a non-existent problem.


    Either way, looks like it is fixed.