Previous 1 2 Next 17 Replies Latest reply: Feb 4, 2015 2:18 PM by tkulla
Bella13 Level 1 Level 1

So I recently upped the security on my computer (an early 2008 10.5.8 MacBook) due to the fact one of my email addresses has remained compromised despite changing my password several times this month. I must have accidently changed some permissions because now I can't seem to change some settings. These are the main points of concern and relevant information:


1) When looking at the "Get Info" on my Hard Drive and my User Account, the Permissions sections say:

- Hard Drive

"You have custom access"

system - Write only (Drop Box)

admin - Read & write

everyone - No access


- User Account (the admin)

"You have custom access"

Daisy (Me) - Read & Write

staff - read only

everyone - read only


- Additionally, the little Lock icon at the bottom right is grayed out, and when I click it, it won't unlock or prompt me for my password


2) The System Preferences Lock icon in the bottom left icon won't prompt me for my password/unlock when I click it.


3) When I tried to change something on my external hard drive with my Time Machine backups, it said "This user does not have permission to perform this task." (It's been almost two months since I last did Time Machine, so that isn't an option).


4) This user account (Daisy) is the admin and my only user account on this computer.


5) I have no idea where my Installation DVD is and I am away at school and wouldn't have immediate access to it anyways (it's probably somewhere back home)


6) I do have a password setup, but the computer still isn't prompting me for it when trying to unlock preferences.


I found this on the apple support site, but it requires the installation DVD... I need to fix the problem ASAP because I need to change some setting on the System Preferences panel. I'd like a solution without the disc.


I also found some forum that suggests typing certain commands into Terminal. However, when I tried the second one, it warned about possibly deleting stuff and instructed me to type in "man sudo" for more information but when I typed that, nothing happened and I didn't want to do anything without knowing more about it.

sudo chflags 0 /volumes/*

sudo chmod a+rx /volumes/*


I am currently trying to verify permissions using Disk Utility but it is taking forever to verify (been over an hour now) and I am getting impatient.


Please help me fix the problem!! Also... My printer isn't working, I keep getting message "client error not possible") and my computer won't uninstall or re-install the driver for my printer (when I click "install" or "uninstall" nothing happens) and I'm wondering if this could be related at all to whats going on with the permissions?

MacBook, Mac OS X (10.5.8)
  • Kappy Level 10 Level 10

    Boot into single-user mode and at the prompt enter these commands pressing RETURN after each:

    mount -uw /

    chown root:admin /

    chmod 1775 /



    After rebooting Set the following Directory permissions.  You can paste these lines or enter by hand, but be careful to enter them correctly.


    sudo su


    Enter your admin password when prompted.  It will not be echoed.


    chown root:admin /Applications

    chmod 0775 /Applications

    chown root:admin /Library

    chmod 1775 /Library

    chown root:admin /System

    chmod 0775 /System

    chown root:admin /Users

    chmod 0775 /Users

    chmod -R -N /Applications

    chown -R :admin /Applications/*


    I suggest you first print these instructions out using a large mono-spaced font so you can read them correctly.

  • Bella13 Level 1 Level 1

    I can't even try that. I restarted my computer and it won't start up. It does the start up sound and goes to the gray screen with the apple icon and the circle that goes around. But it won't go passed there, the circle keeps going around and around and around. I tried a few times to restart it and I've left it going for a while. No luck. I'm now stuck on my cell phone trying to fix the problem.

  • red_menace Level 6 Level 6

    What exactly did you do when you "upped the security"?  If you did something like apply different permissions to all of the system files, you may have hosed your system.

  • Kappy Level 10 Level 10

    If you cannot start in single-user mode then you have a likely hardware issue or a completely hosed system.

  • macrobot Level 1 Level 1

    I have a somewhat similar problem to the OP, except I accidentally misplaced a space (I think) in an Applescript and set the permissions for every single file on my hard drive to:

    (Me): Read and write

    admin: Read and write

    Everyone: Read and write


    Disk Utility fixed some things, but not even close to everything.


    I tried your instructions, but nothing changed... did you leave anything out? Do I have to 'undo' anything or enter something for the change to take effect?

    Many thanks!

  • Djmarksel Level 1 Level 1

    Hi same yeasturday i changed permision on all 4 HDD to admin Me read and write and after that can't start up it starts and gets to the grey screen with apple logo thats it what should i do cant delete anything on main hdd got very expencive software no back up

  • Djmarksel Level 1 Level 1

    The other more important point why I insist we are talking about a bug is: *why shouldnt the system folder be accessible/permissive in the way the admin wants?* In particular if you expand the rights? If you restrict the privileges I could expect the system to fail, but expanding them shouldnt do any harm. What exactly happens after choosing this confounded button "apply to all subfolders"? What would be the correct way of changing permissions to the startup drive? Why is there this button that claims to do the job but instead is hosing my system? Why cant the disc utility restore the original settings? Do you really want me switch back to Windows?

  • Djmarksel Level 1 Level 1

    i changed permision on all 4 HDD to admin (Me) read and write and after that can't start up it starts and gets to the grey screen with apple logo thats it what should i do cant delete anything on main hdd got very expencive software no back up

  • technolemming Level 1 Level 1

    Hi Bella - this same thing just happened to me - can you share how you got this resolved?? Hopefully not the "hosed your system" per red_menace!

  • Bella13 Level 1 Level 1

    Sure thing. Unfortunately, it was a little pricey. What I had to do is purchase a new hard drive, and then Apple transferred all my files from my old hard drive to the new one. This worked because when you copy a file, the permissions aren't copied over, they are refreshed. I hope this helps you out. And I hope you can find a less expensive way of doing this (it may not be TOO bad depending on what capacity hard drive you want/need).

  • technolemming Level 1 Level 1

    thank you so much for replying Bella13! I was able to resolve without going the expensive and time consuming route you had to go. Here's the thread in case you're interested:   I've been a mac person for a long time and the mac people on these boards ROCK!!!!

  • Elaine Morrison Level 1 Level 1

    I'm going to check out your link, and my quasi-answer isn't as good as everyone else's, but...I found my external hard drive often freezes my computer, also during shut-down or start-up, and locks me out of it for adding files. I just detach or reboot the external driver and the Mac regains control of all its functions.


    But the external driver keeps randomly locking me out and demanding I do a disc verification (which seems to automatically reset the permissions but takes 10 minutes).


    That works, but I wanted a better solution. On the Mac info app you can click to change the permissions but not if locked out, so I tried aping the other open driver's permissions using chmod in the terminal. I got an error message that I couldn't use that permission. After just giving up and doing the disc verification I clicked the info settings to match the other working driver and the terminal then showed they both had the same permission settings....the very setting it said I couldn't chmod with an error message!


    Why wouldn't the terminal take my chmod command? I'm assuming the info app with the permissions click option works on that same premise, and as such also locked up. What does disc verification do which changes that? Can't I do the same, or fool it, from the terminal?


    Would sudo have allowed me to copy a file into the locked ext. drive before the fix if the admin still had privileges?

  • ThatMarkguy Level 1 Level 1

    Thank You Kappy!


    I had a slightly different problem.


    I accidentally locked myself out of my computer by changing access. I was in the info pane and changed the Privilege. Bad idea. Somehow, Admin was denied. I think I changed the privileges to "No Access - Everyone". Like a dunce, I didn't realize that meant Admin too. The hard drive icon was replaced by a folder with the red and white Minus sign, indicating No Access. Oops!


    Thinking that rebooting would solve my problem, I rebooted.


    And got a gray screen. I had a cursor, but it did nothing. There was no menu ribbon at the top, no Dock and nothing on the desktop but an empty gray wasteland.  :'(


    Thankfully, I had my other computer running, so I was able to find your post.


    The other problem I had was: in the finder, the little pencil icon had a line through it. Not sure how that happened.


    Thanks to your commands, I was able to get back into my computer. I did have to go to another site to find out how to do Single User Mode (Command S), the link is a bit old.


    I also had to check out some other sites to peice together the proper commands. I had a couple of false starts but was able to get everything going again


    So, for all you folks out there with a blank gray screen, a useless pointer and nothing else, here ya go:


    Hold down the power button and hold down command S until the apple comes up.

    The screen goes black and there will be a lot of command lines.


    When prompted, type in the following commands and then hit RETURN after each:

    fsck -yf

    mount -uw /

    chown root:admin /

    chmod 1775 /


    My computer was fine after that, so I did not type in any of the other lines you suggested.


    Everything seems okay, but my questioon to you is: do I need to type the other stuff in? If so, where do I do that? Thanks!


    I am at the point where I know just enough to get into trouble :~)



  • tallp Level 1 Level 1

    Thanks Bella,


    sudo chflags 0 /volumes/*

    sudo chmod a+rx /volumes/*


    worked fine for my issue.


    Thanks for sharing

Previous 1 2 Next