Previous 1 2 Next 20 Replies Latest reply: Sep 30, 2012 10:35 PM by oregonpete
oregonpete Level 1 Level 1 (0 points)

This is a problem that was described in a post about 2 years ago,  Why does iMovie stretch my images upon importing?   which has since been archived without a solution.

 

Well, I'm having the same problem now that I have finally gotten around to converting some of my old home video on Mini-DV tapes taken with an older JVC digital camera. They were taken in the JVC's Widescreen Mode, which is 16:9 letterboxed in a 4:3 window. iMovie '11 relentlessly stretches these horizontally when they are imported whether I set the iMovie '11 File/Project Properties/Aspect Ratio to 4:3 or 16:9. I am short and wide enough without suffering this additional indignity, so I needed a solution. I didn't find one in this forum or elsewhere, but I did develop a work-around, which I will share. If anyone knows how to fix this problem directly in iMovie '11, I'd appreciate it.

 

Meanwhile, here's the work-around. You will need the older iMovie HD, still avalialable free from Apple.

 

In iMovie HD

-Create a new DV-NTSC (not Widescreen) project

-Go to Preferences/Import and uncheck Automatic DV Pillaring and Letterboxing

-Connect the camera and import the video clips

-Save the project (you don't have to move any of the clips to the movie timeline)

 

In iMovie '11

-Go to File/Import/iMovie HD Project...

-Find the project above and import it.

-Your clips will be in the imported events folder. Select one entire clip. In the viewing window you will see it as a small 16:9 image surrounded by a black border on all 4 sides.

-Select All (Command-A) to select all the clips

-Click on the Crop icon

-Drag and size the green crop outline to exclude the black border and click Done. Now the clips will show properly in the viewing window and also in the project when you drag them there.


20" Intel iMac, MacBook Air, Mac Mini (2009), Mac OS X (10.6.4)
  • geonardo Level 1 Level 1 (0 points)

    oregonpete wrote:

     

    Meanwhile, here's the work-around. You will need the older iMovie HD, still avalialable free from Apple.

     

    Is there still a way to install iMovie HD (6)?  I was not able to install with the link provided.  It is ridiculous that we have to go through all this for such a basic feature.  Does the latest version of Final Cut provide the option to uncheck "Automatic DV Pillaring and Letterboxing"?

  • oregonpete Level 1 Level 1 (0 points)

    Hi geonardo,

     

    The link in my post above still worked for me. It downloaded the iMovie HD installer to my downloads folder, and it installed properly in OS 10.7 Lion when double-clicked. If it still doesn't wotk fo you, here is another link to try http://support.apple.com/downloads/#imovie%20hd

     

    One other possibility for failure: Originally, Apple made iMovie HD a free download for owners of iLife '08, since it was originally a part of iLife. I don't know if the restriction that you have iLife is still there. (I have iLife '09)

     

    I don't use Final Cut, so I can't help you there.

  • geonardo Level 1 Level 1 (0 points)

    I have iLife '09, and the downloads offered by Apple seem to be updates that require that you already have iMovie 6 installed.  I think they were allowing a full installation at one time but it appears they stopped doing that: http://www.macrumors.com/2009/01/27/imovie-hd-6-no-longer-available-for-download / ...  Very frustrating.  Anyway, thanks for your help!

  • oregonpete Level 1 Level 1 (0 points)

    You are right, it is now just an update -I didn't notice that.

     

    However, I've just figured out how to do it without iMovie HD by using the free app MPEG Streamclip. At least this works for my JVC video clips described in the first post.

     

    In iMovie 11

    -File/Import from Camera   (create a new event)

    -Find the event in the Finder (default ~/Movies/iMovie Events)

     

    In MPEG Streamclip

    -Launch MPEG Streamclip

    -Drag a clip from the Event to the MPEG Streamclip window

    -File/Export to DV...

    • In the Settings window*:
      • Compression DV (DV25)
      • NTSC, 720 x 480, 29.97 fps
      • Aspect Ratio 16:9
      • Check Cropping checkbox
        • Destination
        • Top  50  Left   o  Bottom  50  Right  0
      • Everything else as defaults.
      • Click Make DV   (save it to a temporary folder somewhere)

    *You can click on Presets... near the bottom of the Settings window and save these settings as a Preset for future use.

     

    In iMovie 11

    -Create new Event

    -File/Import/Movies    

    Import your saved .dv file(s) from the temporary folder to the new event. You can then delete the previous event with the Camera imports and the temporary folder.

     

    I hope this works for you. You may have to play around with the Top and Bottom cropping settings a bit.

  • geonardo Level 1 Level 1 (0 points)

    Wow! Thanks so much! Worked perfectly.  Hopefully this will help others who run into the same problem.

  • R3X1000 Level 1 Level 1 (0 points)

    Funny how the software apple releases doesn't just work the way we would all hope and expect it to. This is especially funny since its Apples software being released/developed for Apple software.  Should we really have to jump through these hoops in order for it to all work? I don't think so, bad apple... Bad.

  • R3X1000 Level 1 Level 1 (0 points)

    I tried the streamclip method, it didn't work, video still imports into iMovie as a stretched out movie. I also tried the cropping method and it doesn't fix the stretching issue. Once again, its extremely comical that video recorded through the stock iPhone video application doesn't import properly into Apples iMovie software. Lol. Bad Apple! Bad!

  • oregonpete Level 1 Level 1 (0 points)

    I'm not quite sure I understand the problem you are having. I've never had a problem importing videos from my iPhone or from my current Sony videocamera which records in true 16:9 aspect ratio. The only stretching problems I have had were with clips from an older videocamera that recorded HD videos as a 16:9 image letterboxed in a 4:3 frame.

  • R3X1000 Level 1 Level 1 (0 points)

    I've never had problems importing video into iMovie either, until it was video from the iPhone. For example, I've shot a video holding the iPhone on a landscape Horizontal positioning (on its side). when I import it into iMovie the movie is sideways, in order to see the movie properly I need to rotate the video In imovie- upon doing this the video gets distorted (squished) - ive imported video where I've held the camera vertically to record and the video then needs to be cropped in order for it to be played at a normal viewing ratio. But yes I've imported video from other cams and have never had any issues with the viewing ratio (seems the iPhone has an odd video ratio). It seems that the only way I can use iMovie and my iPhone video is to record everything on the iPhones vertical axis and then crop the image for regular viewing ratios. I hope this makes sense to you? If not... Record something using the iPhone on a horizontal axis and bring it into iMovie and then try to get it to resolve correctly. I'm completely open to advice but.. As I noted Ive tried the above fixes and nothing is fixed. In addition it really shouldn't require so much energy on the users part to figure this out, it should just be a plug and play scenario.

  • oregonpete Level 1 Level 1 (0 points)

    ...I've shot a video holding the iPhone on a landscape Horizontal positioning (on its side). when I import it into iMovie the movie is sideways, in order to see the movie properly I need to rotate the video In imovie- upon doing this the video gets distorted (squished)...

     

     

    OK, I reproduced your problem with with my iPhone 4 and iMovie 11. I suspected it might have something to do with the rotation lock on the iPhone (double-click Home and swipe bottom multitask bar to the right to get to leftmost item), so I played with it a bit and I got the effect you described after locking the orientation in Portrait mode with the camera app on and holding the iPhone horizontal. Subsequent locking and unlocking the portrait mode didn't get things back to normal, so I did a reboot (hold down top power button and home button simultaneously until the screen goes black) and now everything is back to normal. Try rebooting your iPhone and see if that fixes things.

  • R3X1000 Level 1 Level 1 (0 points)

    Well that seems to have worked. Weird. Now I have this video which won't resolve properly. Aww well, shoulda bought an htc, next time I guess. Thanks for all your help.

  • danmonsterman Level 1 Level 1 (0 points)

    I'm happy to see this post.  I'm new to imovie.  Just bought my Mac Pro.    I was importing my MP4 videos successfully and they had the correct ratio.  (they were all shot 1280 by 720).   Then something very strange happened.   I imported the next batch of 5 videos, same format and ratio, but they showed up stretched in my event library.  No only that, but some of the video I already had in the library was duplicated and stretched!   To top it off, I can't seem to delete these duplicates.  Oh, and some have a red line through the tops of the videos.  Have I just bumped into a giant Apple vortex?    Since I'm new to this video program I assume I've done something wrong.   And I'm not sure I understand your solution, but will try to figure it out.   This is very frustrating.   I'm afraid I've ruined the work I've already done on this video project.  Thank you for your post.

  • oregonpete Level 1 Level 1 (0 points)

    I'm not sure what's going on here. I've never had a problem importing videos shot in true 16:9 aspect ratio.

     

    The is a setting under File/Project Properties/Initial Video Placement (either Crop or Fit in Frame) that can affect how the clip looks when put into a project, but I don't think it has any effect on the way it looks in the Event.

     

    As far as deleting, you can't really delete clips (without going to the Finder, finding the Event and deleting it there), but you can make them not appear in the event. Click anywhere on the clip, then go to Edit/Reject Entire Clip.

     

    I presume you still have the original clips. I would delete the event (right-click, Move Event to the Trash). quit iMovie, restart your computer, launch iMovie again and reimport to see if that fixes the problem. Also make sure you have the latest iMovie '11 update: Movie/About iMovie -should be 9.0.7

     

    If you are new to iMovie, a great resource is Tutor for iMovie '11 available in the Apple app store ($4.99). It gets great reviews, and I recommend it to everyone starting out with iMovie. There are many others in the "Tutor" series you also might want to check out. The are written by Apple and are uniformly excellent.

  • Karsten Schlüter Level 7 Level 7 (31,630 points)

    oregonpete wrote:

    … a great resource is Tutor for iMovie '11 available in the Apple app store ($4.99). …The are written by Apple and are uniformly excellent.

    nope, by a non-Apple-related company named Noteboom Productions.

     

     

    the Apple-written tutorials a free, video & manual avail here

    http://help.apple.com/imovie/

Previous 1 2 Next