14 Replies Latest reply: Jul 28, 2015 12:13 AM by Dumrat
forbes2000 Level 1 Level 1 (0 points)

Fairly consistently, when I unplug my speakers from the headphone jack, my 2011 MacBook Pro does not switch over to the internal speakers. When this happens, nothing is amiss in the Sounds Preferences pane, but no sound comes out of the speakers... only restarting the computer resolves the problem and starts the internal speakers back on. Does this sound like a software or hardware issue? Is anyone else having this problem with the new MacBook Pro's?


Thanks for your help!

MacBook Pro, Mac OS X (10.6.7)
  • mattgartner Level 1 Level 1 (0 points)

    Was having the same problem, after poking around the web for a bit, came across a MacRumors thread that seems to solve the problem (worked for me) http://forums.macrumors.com/showthread.php?t=1104755


    Go to Audio MIDI Setup (search for it in Spotlight)

    Go to the Built-in Output and play around with the Format.

    For me, 2ch-24bit Integer works for both my headphones and the built-in speakers. Play around with a couple settings, you should notice an immediate change if it works.

  • kyen99 Level 1 Level 1 (0 points)

    Same problem here.  I found a quick fix without rebooting.  Run terminal and do this:


    sudo killall coreaudiod

  • yogic2zones Level 1 Level 1 (0 points)

    Unfortunately, the sudo killall coreaudiod made no difference for me.

  • grantdoug Level 1 Level 1 (0 points)

    My solution for "No Sound Output to MacBook Speakers" - Re-route Sound Input / Output


    I have had this problem on my MacBook Pro, and tried EVERYTHING Apple & Forums suggested - SMC reset, PRAM reset. Apple advised me to send it in for servicing. Since it isn't covered by warranty, I didn't want to do that.


    If you do not want to pay Apple to fix your MacBook optical sound jack hardware, you can overcome the problem with this procedure I came up with myself, which overcomes the hardware failure caused by the headphone jack optical sensor thinking something is plugged in there when there isn't.


    Ironically, this solution requires a jack be inserted into the headphone jack. Annoying, but workable and free.   


    Step 1. Plug headphones in (don’t worry, you won’t use them) 

    Step 2. Change System Preferences -> Sound -> Change Internal Speakers to an Input!

    Step 3. Done!


    Obviously when you do want to use the headphones, you must revert this setting.




  • ym11 Level 1 Level 1 (0 points)

    This problem as apparently caused by the optical sensor inside the audio jack thinking there is a headphone plugged-in, when there isn't.


    Fix that worked for me: Raise the notebook and blow air into the audio connector. Do it as hard as you can.

    After two blows, the speaker icon next to the clock came back to normal and the speakers began working again.

  • HoneyCrispy Level 1 Level 1 (0 points)

    Thank you ym11. This is the best, easiest solution, and with a big laugh! I registered just to give you a thumbs up for sharing the solution

  • deadeyejohnny Level 1 Level 1 (0 points)

    Well, I had the same problem and none of these solutions worked for me but I figured it out. I knew it had something to do with having used headphones, because I was using my iPhone earbuds on my mbp last night. But after trying all the probable solutions listed above and not having any results I figured I'd just try plugging my earbuds back in and it worked to fix the glitch. (Note: I tried plugging in first with a pair of regular, non-Apple headphones and it didn't change anything, in my case it was a glitch that was directly related to my iPhone's earbuds and required me to reinsert them, maybe because the 1/8th jack on them has 3 contact points instead of the regular two typically found on a pair of regular, everyday stereo headphones)

  • Jaewonywon Level 1 Level 1 (0 points)

    For me, rebooting the computer fixed the problem simple, orthodox method to get your computer to work again.

  • PeterConverse Level 1 Level 1 (0 points)

    This method worked from me too!!  I used a can of compressed air, though.  I initially sprayed into the headphone jack, but that didn't work.  Then I went in through the compartment in front of it that has a flip-up door.  I aimed the air in the direction of the jack and presto, the sound icon went black immediately!  I'm a believer... Very 'sound' advice!  Heehee!

  • thedan70 Level 1 Level 1 (0 points)

    Still works in 2015 with Yosemite ... Thanks

  • CheneyPinata Level 1 Level 1 (0 points)

    I would say now that the optical sensor is the most common root of the problem. I took a peak into my headphone jack for the first time in 6 years and I was surprised to see a small red light. Never knew that was there! I took my can of compressed air and sprayed into it a few times, then following another successful trick I went through the flip-up door compartment next to it and did the same thing. Both times the sound icon in my upper R-hand corner came back, but then went grey again . I looked at the sensor again and this time the light was much brighter and more visible (I guess I had 6 years of dust in there). I plugged by headphones back in, removed them again and BOOM. Sound was back on.

  • gogogoducks Level 1 Level 1 (0 points)

    This finally solved my sound problem after I tried all the solutions provided by all sorts of forums.


    Thank you so much!!!

  • crrobins Level 1 Level 1 (0 points)

    I registered just to say blowing into the headphone jack worked for me too!!!!!

  • Dumrat Level 1 Level 1 (0 points)

    Rebooting my lappy works for me, but so does plugging the headphones in again and taking them out again, which is simpler. Will try the air-blowing trick next time!