5 Replies Latest reply: Jul 20, 2011 9:04 AM by indybroughton
indybroughton Level 1 Level 1 (0 points)

I have had problems with Garageband multiple times now when it comes to recording anything outside of the program, be it an electric guitar, an electric piano, or my very own voice. Each time that i attempt to do a recording I always use a Roland Micro Cube amplifier and the program will either 1) pick up the instrument or microphone for the first track I attempt to record and then not for any of the others or 2) not pick up the sound at all. I believe I have had this problem since I upgraded to iLife '10. I have made sure that my amp volume is all the way up and that the input is set to the line in jack (>o<) on the mac but it still won't register my amp. Does anyone have a solution for me?


Mac OS X (10.6.7)
  • HangTime Level 9 Level 9 (50,275 points)

    indybroughton wrote:

     

    1) pick up the instrument or microphone for the first track I attempt to record and then not for any of the others

     

    did you recordEnable the other tracks by selecting them?

    indybroughton wrote:

    2) not pick up the sound at all. I believe I have had this problem since I upgraded to iLife '10.

     

    that WOULD be a problem as there never was an iLife '10 (only '9 and '11) B–)>

     

     

    indybroughton wrote:

     

    I have made sure that my amp volume is all the way up

     

    hopefully you connected the line-OUT and not the speaker-OUT:

     

    http://www.bulletsandbones.com/GB/GBFAQ.html#amplineout

    (Let the page FULLY load. The link to your answer is at the top of your screen)

     

     

    indybroughton wrote:

     

    that the input is set to the line in jack (>o<) on the mac

     

    did you set the correct preferences?:

     

    http://www.bulletsandbones.com/GB/GBFAQ.html#recordlinein

    (Let the page FULLY load. The link to your answer is at the top of your screen)

  • indybroughton Level 1 Level 1 (0 points)

    Everytime I tried recording and it failed I am positive that I had selected the right track/instrument row thing. I have iLife '09, sorry. I'm sure that I used the line in jack because it had the >o< right over it and the other one had headphones. When i went to the input preferences for sound the only option was the line-in jack but the computer only seems to register my the sound coming in through that jack when i pull the male jack end out and put it in (this is not unusual but it shows that the preferences are setup with the proper line-in jack outlet). Other than that I have not changed, nor have I found anything to change in preferences that would affect the input. I'm also positive that the microphone, amp, and double male ended jack (a wire with male input jacks on both ends) function properly.

  • Burgundia Level 2 Level 2 (160 points)

    indybroughton wrote:

     

    When i went to the input preferences for sound the only option was the line-in jack but the computer only seems to register my the sound coming in through that jack when i pull the male jack end out and put it in (this is not unusual but it shows that the preferences are setup with the proper line-in jack outlet).

     

    Did you select Line-In under both your Mac system-wide sound preferences and the GB sound preferences? 

     

    Mac: System Preferences --> Sound --> Input --> select "Line In" option

     

    GB: Preferences --> Audio/MIDI --> Output should be set to "Built-In Line Input"

  • indybroughton Level 1 Level 1 (0 points)

    GB: Preferences --> Audio/MIDI --> Output should be set to "Built-In Line Input"

     

    I do believe that I did that since I saw someone another forum post about this similar problem where somebody made that suggestion. I not completely sure, so I will check, but let's work under the assumption that I did.

  • indybroughton Level 1 Level 1 (0 points)

    Ok, I figured out what my problem was. Apparently, though it isn't marked anywhere, the double male ended jack I was using had an input and an output end. I only found this out when I decided randomly to just try switching the two end and it worked.