0 Replies Latest reply: May 1, 2011 3:01 PM by mammonist
mammonist Level 1 Level 1 (10 points)

I have an Airport Express in my office connected via ethernet to an Airport Extreme base station in our house, about 50 feet away. For years I had a Brother HL-2040 laser printer connected to the office Airport Express by USB. I still do, but it no longer works. I can see the printer and it appears to install just fine, but you can't print anything to it. I've tried deleting the printer, reinstalling, choosing it by IP number, etc. But whenever I print, I just get "connecting to printer" for awhile, then nothing.

 

I have tried connecting the printer directly to my Macbook Pro via USB and then, after turning off printer and turning it back on, it prints fine. So it's not the printer, and it's not the cable.

 

There are some older threads about this issue but I wonder if anyone has lately come up with a solution. It's quite frustrating not to have this laser on our network. Thanks for any help!

 

PS--FWIW, the office Airport Express is set up as a "roaming network" to bring wifi to my office.


Airport Express, Mac OS X (10.6.7)