Previous 1 2 3 Next 84 Replies Latest reply: Jan 12, 2015 11:35 PM by AkashaJSummer
Sean Knudsen Level 1 (20 points)

I have for a while been having problems with watching videos I have downloaded from the iTunes Store on my PC. I'm running windows 7, all my drivers are up to date, and the videos play fine if I open them up in Quicktime. If I watch them in iTunes, however, the audio and video get out of sync rather rapidly... If I watch a show in iTunes, I need to pause and restart it every 30 seconds or so, otherwise it just becomes too annoying to watch. Clicking pause then play again syncs it back up, but again it doesn't last long. I open the files in Quicktime and they play just fine, and considering iTunes just uses Quicktime for video playback, the problem must be with iTunes. I have gone through several iTunes updates, hoping with each one that the problem gets fixed, but it never does... can anyone help me??

  • liamfromhythe Level 1 (0 points)

    I am having the exact same problem but cannot find anyone who can help. Im not brave enough to re install the program but ive been told this does not help anyway.  can anyone help? Please!

  • lee51 Level 1 (0 points)

    I am experiencing this problem too. Video runs slower than the audio. Tried in SD and HD.

  • ikbenaron Level 1 (0 points)

    Having same issue, in VLC Media player it works fine. In iTunes though, it is out of sync.


    Just synced my iPod with iTunes, andd it is NOT out of sync. So the problem is within itunes. I'm going to ring Apple toworrow i think.

  • TechX Level 1 (0 points)

    I have yet to find a resolution with this issue and I've been living with it for months.  I see no resolution posted yet on these forums.

  • XenoZentag Level 1 (0 points)

    I have this issue as well!  It is happening with Dr Who, latest season.  I can't watch more than 20s without having to pause and restart.  I tried turning off DirectX (safe mode) and turning it on.  There is no way this should be happening, as my system is all up to date and can definatly handle iTunes, even when it's taking up 300mb of RAM or more. Videos are fine in QuickTime, I think it has something to do with the horrible bulk of iTunes.



    Windows 7 Ultimate x64

    Quad Core i7 @ 2.9 Ghz

    12GB DDR3 RAM

    ATI Radeon 6870 1GB



    QTime: 7.7 (1680.34)

  • simon_nz14 Level 1 (0 points)

    I'm also having this exact same issue.


    When I purchase movies, they play out of sync in itunes but if I play them directly in Quicktime, they are fine.


    The same occurs with rentals, however with rentals, they won't even play directly through quicktime so i have no option but to play them through itunes.... but run into this out of sync problem.


    I recently got a refund from Apple for my purchase and directed them to this forum.

  • Arbello Level 1 (0 points)

    May as well add my name to the list.  This is driving me nuts.  It doesn't seem to happen with every startup however... sometimes I can reboot and it works fine.  If it's not working though, it breaks across all videos.  When it's working, it works across all videos. 

  • JustinJammer Level 1 (0 points)

    Exact same issue. Itunes   Win 7 and all drivers etc up to date.   iTunes, fix this please!!

  • peterod Level 1 (0 points)

    Happens to me, too in iTunes. Works fine in QuickTime.


    Windows 7 x64 SP1

    ATI Radeon 4670 (driver version 8.881.0.0)

    AMD 3.1 Ghz X3 445 Processor

    4GB RAM

    iTunes 10.4.1

    HDMI output

  • Mr Me Level 1 (0 points)

    Also been experiencing this for some time now, win7 x64 and same sort of pc specs to all you guys, fixed it just this evening so hopefully it's not just a fluke!


    Two things to do, first in quicktime preferences, audio tab, under the sound out field, rate change too 44.1khz, size to 16 bit and make sure channels matches you windows default. Now you need to make sure your audio driver software matches these settings (as that is the software that controls the sample rate and bit depth in shared mode); mine is realtek HD audio manager, so for anyone else who has that, go to the default format tab make sure it is '16bit, 44100hz (CD Quality)'.


    I'm not a big expert on this so I can't say why itunes suddenly has a problem with these settings or why it makes a difference, I just hope that this fix works for you as well because I have been looking for a solution online forever and it's driven me insane!


    Good luck!

  • liamfromhythe Level 1 (0 points)

    Hey, I followed your steps and It didn't work for me. thank you for your advice anyway. When will apple sort this out?

  • Mr Me Level 1 (0 points)

    Ah man, sorry to hear that dude, thought I was on to a winner there! Mine is still holding strong so maybe I had a different issue? Or just a fluke fix!


    iTunes is so buggy these days I've given up hope on it ever being good again... I miss iTunes 4 on my first computer, that was boss!


    Good luck finding a fix!

  • Razgriz2009 Level 1 (0 points)

    After many months of pulling my hair out, Mr Me has shed some light on the problem (at least for me). I am using Realtek High Definition Audio and i discovered that it was set to 24bit192000Hz (studio quality). I changed it to run 16bit 96000Hz (studio quality) and POOF! no more lag/out of sync!

  • TruthWillOut Level 1 (0 points)

    The change from 24 bit 19200hz to 16 bit 9600hz worked for me as well.  It was a b**ch finding that setting on this pc to change it, but once located it cured all my lagging audio issues.

Previous 1 2 3 Next