5 Replies Latest reply: Aug 16, 2011 11:22 PM by hilofoz
morganfrompflugerville Level 1 (0 points)

The computer is only four months old, fans sound like they are working, and the screen stays on when the power cord is out. I put in the Mac Os X disk today so that I could reset the admin password and as the computer restart for the program it's been stuck on the grey apple screen. If you have anything I can try and do that would be great

MacBook Pro, Mac OS X (10.6)
  • eeessttaa Level 1 (60 points)

    When you go to reboot with the disk in hold down the "C" button so it will boot off of the cd.

  • morganfrompflugerville Level 1 (0 points)

    When Do I start holding it down? Cause I've tried twice and it doesn't seem  to want to budge

  • eeessttaa Level 1 (60 points)

    You need to press and hold it down at the exact same time that you press the power button to turn it back on. you have to hold it down for a while to get it to boot off of it.

  • Russa Level 4 (1,315 points)

    Hmm. interesting.. same thing happened to me earlier in the week.


    Has your computer taken progressively longer over the past week or two to boot up? If so, then you may be in for a ride. Hopefully you have backed-up all your data onto another drive somewhere.


    If you have external drive as a boot disk then I recommend you hook it up and try a reboot from there. If it boots, then run repair permissions on the internal disk.


    I brought my MBP to the Genius Bar and they rebooted from an external disk, ran permissions, and it started to work. I then asked them to rebuild my boot drive. They erased my disk, reinstalled MacOS 10.6.7 and iLife '11 for me in the store while I waited; about 20 minutes.

  • hilofoz Level 1 (65 points)

    I had the same issue. I would start up my MacPro Desktop, and nothing happened but for the startup chime and the screen going blank. No Apple, no Beachball, no Nothing. I even tried booting from my DVD, and that would not work. So... it was dead, dead, dead and I could not do a thing about it. I tried all the rubber chicken procedures such as booting with the shift key, disconnecting everything, even the keyboard in the end, and taking out two of my four hard drives, doing all the things that the Mac Tech Support (on the phone) advised me to do.


    Mac Tech support tried their best and booked an appointment for me at the Bondi Genius Bar, and I sat on the stool fully expecting to hear the worst. It turned out that the culprit was a corrupt internal eSATA disk, and when it was removed, the computer started up beautiully and recognised my other system disks.


    Funny, I had removed the disk with Snow Leopard on it, thinking that it was a corrupt System disk, but no, it was another disk which I had fortunately up the night before this happened! I noted that the Mac was taking an inordinately lengthy time to shut down after that, which made me rather nervous about the next start up.


    The defective disk had no system on it, and therefore, I never even thought of taking it out. It seemed to an illogical thing to do at the time, as I did not believe that a disk with no system could cause any problem.


    Now I am sitting at my trusty Mac Pro and it is working Better than Ever, and I replaced the faulty 280GB disk with a Samsung 500GB disk I took out of my slow as a wet week LaCie Big Disk Network Attatched Storage. I re-initiallised this disk and it is now working flawlessly as I have been copying data to the SamSung disk now.


    So, the upshot of all this is, is that nowhere is there any reference to a single disk in a bay that can cause the whole Mac not to start up properly! My advice is to those with that problem, remove your disks out of the bays, one at a time to find out if it is a disk causing the problem.