Previous 1 2 Next 25 Replies Latest reply: May 24, 2011 11:02 AM by The hatter Go to original post
  • ReVeLaTeD Level 1 (10 points)

    I have solved my own issue.  Boot Camp IS broken.  I just don't know why.  I suspect it has something to do with the new AHCI limitations and/or EFI strategy Apple has used that effectively forces the use of Windows 7.


    Before, you could choose Vista or 7 it was a different interface for Boot Camp completely.  It never asked you about downloading anything.  It just worked when you selected the OS.  Seems they excluded some stuff that should have been preloaded - and downloading/burning a disc doesn't help since you can't get the disc to boot without some of it.


    Additionally, this whole SATA cable issue seems to also be part and parcel to the issue.  Yanking my X-25M SSD and putting the garbage 5400 HDD back in and all of a sudden every DVD worked perfectly fine, including every burned DVD.  That indicates a hardware issue, and it's not the X-25M, because I can drop that same SSD back into a 2010 MacBook Pro and do Boot Camp without an issue.


    No...something is funky with the internals of the 2011 MacBook Pro.  My next step is to buy a newer SSD - which should not be necessary - and retest.  SATAIII one this time.  If the newer SSD doesn't work it's definitely an issue with linking...and I will take it to Apple to swap for one of the newer ones that's been silently fixed.

  • Jerome Colas Level 2 (220 points)

    Well, sometimes you have to burn your Windows disks ...


    I bought WIndows on the Microsoft online store and it is downloadable (the funniest is that there is extensive help on the MS store about how to download the files, but could not find any help on what to do with the downloaded files).

    So I burned the downloaded .iso file to a blank DVD, and I have a very genuine WIndows 7 Ultimate 64 bit install DVD.


    Putting it in an external DVD drive (my MBP's superdrive has just been replaced by a second SSD) :

    - my 2010 MacBook Air boots from the Windows install DVD, whether using Bootcamp or selecting the boot disk at startup)

    - my 2011 MacBook Pro (i7 2.3Ghz, 8GB RAM, 2 SSDs inside) does not boot and just shows a DOS like cursor or a "no boot device found" message.



    I can definitely leave without BootCamp, but am still quite annoyed by this.


    Any idea on how to solve this?

  • Csound1 Level 8 (46,972 points)

    Like I said, the only difference between your installation and thousands of successful installations is you.

  • philm80 Level 1 (0 points)

    Jerome, did you try creating a MBRFAT flash drive following the instructions found here:


  • philm80 Level 1 (0 points)

    Csound1, if you've already said it, and it already didn't help anyone, please stop repeatedly picking on people that come here looking for assistance.

  • Csound1 Level 8 (46,972 points)

    For the majority of people the software works, the hardware works, the variable is the person, instead of wasting time sympathizing it makes sense to point out where the problem originates, a cure is simpler once that is accepted.

  • philm80 Level 1 (0 points)

    People don't come here to learn to improve themselves, and if they did what you offer in no way does that.  There are known issues with using bootcamp and windows 7, many of these issues revolve around graphics drivers as appears to be the case here.  Much of the time the person forgot a step, or was unaware of one, but also much of the time, as with mine, a simple hardware failure can cause the rest of the set up to fail.  I commend the original responders advising to make sure the disc is burned properly and such, however, simply repeatedly telling someone that they are the problem is not helping anyone in any way, whatsoever.  If you have a problem with how someone approaches you asking for advice, the best solution is to ignore them, especially when it's on an open forum.  There is absolutely no need to provoke, or as I said earlier, pick on, someone that is simply asking for help.

  • Csound1 Level 8 (46,972 points)

    We'll have to agree to disagree, I hope you solve your problem soon.

  • philm80 Level 1 (0 points)

    I've already solved my problem, I stated that earlier in this thread.  If you'd like to put your experience to use instead of vent frustration it looks like Mr Colas could use assistance.  I'm very very new to Apple so my help will be limited.

  • ReVeLaTeD Level 1 (10 points)

    Additional info:


    Original MacBook Pro was bought first day. Does not boot any DVD except the Apple DVD if the SSD is inside.


    Just bought a new MacBook Pro from the Apple Store two days ago.  DVD's boot fine with the SATA II drive.  That's PROOF POSITIVE something changed, it was broken like I said.

    The SATA III drive works in the newer MacBook Pro but just barely.  There's a substantial lag when first booting up the drive for some reason, but after it's up and running, it works fine.  It wouldn't even do a 100MB file copy in the old MacBook Pro.


    So for anyone who is actually open to the idea that Apple is capable of problems, the early MacBook Pros DO have a problem with Boot Camp / DVDs / SATA drives.  The newer MacBook Pros (built in either April or May) appear to have had something fixed internally which resolves the issue.

  • jucytec Level 1 (0 points)

    AHCI is not turned on in the EFI BIOS.

    Since Windows 7 does NOT support EFI 1.x it has no way of turning it unless you change yer MasterBootRecord to trick windows to thinking AHCI was enabled by BIOS.


    Solution: owtopic=126089


    Might be a bit complex for some users but this will allow your SSD to work in AHCI mode.  Not ALL SSD's work in IDE mode which is how boot camp load's it's HDD.

  • The hatter Level 9 (60,930 points)

    I've cloned Windows (Paragon Suite) to SSD on Mac Pro 1,1 and the performance is as fast and normal as on 2 other comparable or better custom PCs.


    I see this question posed regularly for 4 yrs going back to 2006/7 and Vista x64 (though not about SSD, just AHCI). And in the past I used 10K Raptors mostly of one model or later VRs.


    People have wanted to try to "enable" those two ODD ports to use in Windows as well.


    In some ways, and running Windows primarily, I ditched the Mac Pro except as a backup system probably to go with a 'real' Windows computer.  So I can enable RAID mode, BIOS, OC, use better graphics, and importantly, have better thermal control.

Previous 1 2 Next