Previous 1 2 Next 24 Replies Latest reply: Jul 4, 2011 7:05 AM by jawen Go to original post
  • Eric Shawn2 Level 3 Level 3
    Mac OS X

    I'm still on 4.1 and this is an issue for me as well.  Wifi keeps disconnecting and reconnecting on it's own.  Sometimes, even with my phone right beside my router, and full wifi bars, I get the message "must be connected to the internet".  And either it will just hang until I quit the app and restart, or after you hit OK on the message, the app will just launch.  Very quirky.  What bothers me the most is when I'm downloading something and my wifi is on, sometimes it will automatically just switch to 3G.  Wasting my data for no reason.  I've been told that it's probably the antenna on the iP4.  Which apparently has been fixed on the iP5, along with other hardware issues.


    I've tried all the tips posted here and other sites, and no luck.  The only thing I haven't done is replace my phone.  Which more than likely won't solve it, according to Apple Genius Bar.  I'm tired of having to restore my phone and reinstall all apps from scratch, so I just won't bother until iP5 comes out.  Grin and bear till then.  Never had any issues prior to iOS 4.  Since the inception of iOS4, for me, I've had one problem after another.  At least with 4.1 on the iP4, issues are minimal and bearable.  Too apprehensive to update.

  • gabrielfromsurry hills Level 1 Level 1

    I too am having the exact same issues. Now that I am on 4.3.3 I can't access wifi unless I am standing almost next to the router.


    At work, I sit about 4 meters away from the router and it does work.


    Does anyone know how to restore the iphone to 4.3.2, I would rather have tracking and be able to use the wifi!



  • dragondaw Level 1 Level 1

    Going through the same thing.  In the process of a restore now.  I'll report back.

  • maaat Level 1 Level 1
  • Eric Shawn2 Level 3 Level 3
    Mac OS X

    Not sure what you meant by that link.  Sounds like others are having the same issues.  Which isn't a surprise.  I have tried all possible tips that were suggested there, and other forums I've been to.  No solution.  Some wifi places are better than others.  But not completely stable.  The most logical and viable explanation I've been givin so to date, is the antenna issue on the iP4.  Even when I'm 3G with full bars, it sometimes doesn't connect either.  However, imo this is a small price to pay considering the possible issues I might face if I decide to update to the latest iOS.  I'll wait till the iP5 comes out, and just deal with the issue till then.  It's really the only one I'm dealing with at the moment.

  • dragondaw Level 1 Level 1

    So after I called Apple Support and explained the steps taken they said go into a store and change your phone.  I have the white iPhone, only 5 days old, so wasn't a big deal for me.  I made my backups and traded in phone.  Updated to 4.3.3 and problems are not there.  Restored from backup, and still no problems. 


    So could just be some defective units? Not sure, just happy to have wi-fi back.

  • Eric Shawn2 Level 3 Level 3
    Mac OS X

    Nice.  Glad you got it to work.  Thanks for letting us know.  I wouldn't doubt it was due to a defective unit.  That's what they Apple guy told me to when I brought my phone in witht he wifi issue.  He said he'd swap out the phone, and told me it would more than likely have 4.2 (latest iOS at the time) on it.  I opted out, as I was hearing many people were having issues with 4.2.  Didn't want to take the chance on being one of them.  Maybe I'll swap mine out closer to the date when iP5 is coming out.  At least that way if I start to have issues, I won't have to live with them for too long.  lol

  • Kirk Hayes Level 1 Level 1

    I have similar problems on my new IPAD2 that apple swapped out for me.  Got it home and the wifi worked a couple times, but most of the time it will not get an IP address and uses the which means it isn't pulling an IP from the router.


    My router is fine and I tested this on 2 known good networks.  Took it into Apple and the DFU'd the IPAD2 and reinstalled the firmware....seemed a little bit better according to the "Genius" behind the bar.  However, I took it into work and promptly checked it there and it still fails.  BTW, I am the IT manager at my job and my last IPAD2 worked fine.


    So I either got a defective IPAD or IOS 4.3.3 is a bummer.



  • Eric Shawn2 Level 3 Level 3
    Mac OS X

    So I finally took the chance and updated from 4.1 to 4.3.3.  I've been testing for the last 3 days, and it seems that wifi is a little better especially in the areas I was having the most issues with.  But only slightly.  Meaning, connection time didn't hang as long, and I wasn't getting the "need to be connected to the internet" message as often.  I'm taking this as a possible hardware issue with the antenna.  Will be contacting Apple to get a replacement.  On a side note, I did start noticing more lags on app launches and quits, as well as swipes than on the previous 4.1.  Didn't see the slight speed boost as some have posted.  Keyboard seems to be a little better also.  More accurate.

  • jawen Level 1 Level 1

    I tried doing everything they said in every forum I could find with issues upgrading to 4.3.3 wifi connectivity problems. I recently upgraded my unlocked 3GS to 4.3.3 (because I accidentely screwed up my icons on 4.2.1 - icons went missing!) and everything worked great for about 24 hours.


    The next day I wake up and find my wifi shows connected, but I have NO connection on wifi whatsoever. I did every reset known to man, including a full iphone reset (EVERYTHING GONE) but still no luck. I tried manually inputting some information into the STATIC IP section (even though I have DHCP, still nothing.


    So I found my working old 3G phone, and tested connection...worked fine!! That phone is still on 4.2.1.'s what I did.


    I checked the wifi info on the 3G and compared it with my 3GS. The IP addy was totally "effed up" on the 3GS. I changed all the info again on my 3GS to reflect what my 3G had...and VOILA!!! it somehow has worked...not sure how long it will work, since its only been 20 minutes since tested, but my hopes are high until apple fixes this issue.


    Here's a quick snapshot of what I changed:


    Wifi -> chose my network ->changed to STATIC -> filled in this info, which can be found in your router info:


    IP Address: 192.168.X.X

    Subnet Mask:

    Router: 192.168.X.X

    DNS: 192.168.X.X


    After I saved this, I disabled the wifi on the old 3G just to make sure that my router wasn't maxxed out on the number of devices, plus avoiding IP conflicts.


    I know this was long winded, but I hope it can be of some use to you guys out there. I tried EVERYTHING else except throw my phone out the window.

Previous 1 2 Next