Previous 1 2 3 4 Next 58 Replies Latest reply: Oct 28, 2015 12:26 PM by butterflyturtle Go to original post Branched to a new discussion.
  • querencia41 Level 1 Level 1

    I'm running the newest version GB 6.0.5 (from ITunes) on an older IMac that I've updated with Mountain Lion and have had the same problem as others on this chain. I tried Dagon's method of deleting all GB items from the various folders, reinstalling GB, clicking update missing loops later, but the loops didn't appear after quitting GB and opening the Software Update window. Rather than download GB 6.0.5 again from ITunes like others have described I made a copy of my GB on an external harddrive and then reinstalled it as per Dagon's directions, but after selecting a missing loop and clicking install later and then reopening Software Update window, there were no updates. Any ideas?

  • Clsid Level 1 Level 1

    @querencia Uninstall everything as Dagon says, folders, etc. Then reinstall from App Store, run the program, it will download an additional update, run the program again after the update, choose a loop not on your system so you get the Dowloand additional loops popup, and opt for Download Later. Close the program and then run App Store. You should see the additional loops on the update section.


    I'm running Mountain Lion and didn't have backup CDs. My main advice is that you should avoid copying your old GarageBand to an external hard drive.

  • querencia41 Level 1 Level 1

    Thanks CIsid and Dagon! Thanks for the advice. Reinstalling from the App Store worked.

  • MBiber Level 1 Level 1

    I don't believe a complete uninstall is necessary. 

    just bought new retina macbook two weeks ago and ran into this issue tonight.

    I tried dagons approach to no avail.


    if you look into the folder    /library/audio/apple/apple loops index


    you will see a file named Update Index.......txt

    i moved this file into the trash.


    then opened gb again and clicked a missing loop, got the update dialog, said update later and closed GB.

    I then went to software update (under the apple menu) and the 1.2 GB loops / instruments update was there.

    i didnt verify, but i assume the missing loops are referenced somewhere in that file and when GB initializes a software update the appstore sees nothing to update.....


    hope this helps...

  • Henke456 Level 1 Level 1

    Thank you!


    Worked perfectly on my new Mac Book Pro. Got GarageBand from AppStore and couldn't install the loops. So bad  that Apple couldn't fix this!


    //Henrik, Sweden

  • andrew.ortwein Level 1 Level 1

    Dagon's instructions worked great for me too.  I had GB installed from the Mac AppStore and couldn't get the extra instruments/loops to download.  I tried the suggestion to just delete the update index file, but that didn't work.  Thanks Dagon!

  • consultanator Level 1 Level 1

    When I follow the MBiber instructions, my GB just says that the loops that are missing don't exist.  So no fix for me.  :-(

  • consultanator Level 1 Level 1

    I finally followed Dagon's instructions precisely and had a success.  This was with GB 2012, on a 21.5 iMac, vintage late 2012.  The process that I followed was the one outlined there and it resulted in: (1) a massive download (1.5 GB or so?) to reinstall the original (partial) GB, (2) running GB selecting "download later" for the missing parts, and finally (3) finding the missing packages in the updates and, after *another* 1.2 GB download finally getting a full GB install!  Took a day but it is all working.


    Thanks to all who made suggestions, I probably couldn't have done it with out all of you!  :-)

  • Chris Tuft Level 1 Level 1

    I was also finally able to get this working following Dagon's instructions. I still was having issues with the loops not showing up in the Updates screen, but by reloading the Updates page (command-R) they finally appeared!

  • mteep Level 1 Level 1

    I tried something completely different, and it worked for me. (I had GarageBand '11 installed on Snow Leopard from an iLife DVD Apple sent me for free a few weeks after I bought my Mac Mini. Since then I've upgraded to Lion and Mountain Lion through the App Store. But I hadn't really used GarageBand until recently, which is when I discovered that some Loops and Instruments were missing.)


    Anyway, I tried first the "Download Now" option, then the "Download Later" option. But neither worked. Software Update from the Apple menu found nothing.


    But running software update from the command line worked. (Perhaps it uses the pre-Mountain Lion version, and that's why it works. I am not sure.) It's just two steps.


    Open a terminal and type at the prompt:

    sudo softwareupdate --list

    You will be prompted for your password. (You have to be an administrator.)


    After a while, I got this output:

    Software Update Tool

    Copyright 2002-2010 Apple



    Software Update found the following new or updated software:

       * GBExtraContent-1.0

              Instruments and Apple Loops for GarageBand (1.0), 1170290K [recommended]


    At least if you get the line containing GBExtraContent-1.0, you may proceed. Otherwise I do not know. Perhaps retry with the "Download Later" option from within GarageBand before trying this command again. (Or try the next step anyways.)


    Now, at the prompt, type:

    sudo softwareupdate --install GBExtraContent-1.0

    The update should now download and install. It will probably take a while. Afterwards, restart GarageBand and you'll be able to use all the loops and instruments.



  • Clodimedius Level 1 Level 1



    Would you be a mastermind? I followed your suggestion and how happy am I now: It worked flawlessly. After restarting GB, all loops are there!!!


    Now, does this 1.2 Go file resides somewhere to be erased .... hehe?




  • sirlouie Level 1 Level 1

    Thanks a bunch mteep..

  • SeaKayaker Level 1 Level 1

    Mteep, your solution worked.  Thank you so much!

  • petemat Level 1 Level 1

    This did it for me too. TFT  :-)

  • aag97 Level 1 Level 1

    MBiber's solution worked for me as well. I tried running Software Update from the Terminal as mteep suggested, but to no avail. Guess it's whatever works for everyone