Previous 1 2 3 4 5 Next 70 Replies Latest reply: Jun 18, 2012 3:23 PM by Magiccam Go to original post
  • 5Arrows Level 1 Level 1 (0 points)

    On http://www.apple.com/imac/specs.html, I have a 27" iMac, i7 processor, AMD Radeon HD 6970M 1G

     

    I didn't realize you could force the drivers, I'll poke with that tonight!

     

    <Edited by Host>

     

    -dan

  • The hatter Level 9 Level 9 (60,175 points)

    if you want email's just hide it in your profile and direct people to check there

  • egaille Level 1 Level 1 (0 points)

    5arrows, maybe you could try this driver (catalyst 11.9),

    http://fr.driverscollection.com/?H=Mobility%20Radeon%20HD%206990M&By=AMD&SS=Wind ows%20XP
    (choose v11.9 on the top of the list).

    by either doing normal install or force the install:

     

    to force install on XP

    0) extract the archive (default: C:\ATI\Support\11-9_xp32_dd_ccc_ocl)

    1) goto hardware panel
    2) choose update pilot in hardware control panel

    3) then "> choose driver on my computer"

    4) then "> choose from a list of drivers on my computer."
    5) > browse to C:\ATI\Support\11-9_xp32_dd_ccc_ocl\Packages\Drivers\Display\XP_INF
    6) finish install if it allows you to...

     

    reboot

     

    Tell me if it works for your 6990M, and if it does, i'll include that driver on my download page

  • 5Arrows Level 1 Level 1 (0 points)

    egaille, This worked exactly as you said!  Once I installed the driver (HD 6900 series), XP recognized the card and gave me 3D graphics.  It was a bit late last night, so I didn't get to see if it survived a reboot, but all went well.

     

    Thanks for pulling all this information together.  Would you like me to take screen shots of the process?

  • egaille Level 1 Level 1 (0 points)

    did you succeed with the driver (v11.9) in my previous post?

    if so, i'll update my download page

     

    It would be good to find a better place for the download package, but i don't know where...

     

    Maybe Apple is interested, as XP support is no more provided for 27" core i5 / i7 ???

  • 5Arrows Level 1 Level 1 (0 points)

    yes, the 11.9 driver worked just fine.  I think I found this dirver on AMD's drivers page...

     

    Now I have another slight problem.  Plugging in headphones doesn't seem to make the audio switch.  Any ideas?

  • egaille Level 1 Level 1 (0 points)

    Sorry, i've never plugged anything behind my mac under Windows (i only use it for a 3D software)...

    That is strange, because it is an apple licenced driver... But maybe not for imac 27"...

    I'll have a look in the future weeks...

  • vaskelovo Level 1 Level 1 (0 points)

    Egaille,

     

    Inspired by your example I got a sandy bridge MacBook Pro 13" (rather than an older version) and managed to install Win XP on it.

    In addition to your package I had to find a graphics driver for the integrated Intel 3000 graphics.

    Now the graphics works fine and I can run RAW shooter Essential and ACDSee (the main reason for XP).

     

    However there are still a couple of minor issues. I feel that the touch pad is not fully supported, e.g. can't get it to right click via ctrl or such.

    Another is there's no sound or wi-fi, the camera works fine though. Do you know where would I go for sound support? Intel? Thanks, SD

  • geitemuil Level 1 Level 1 (0 points)

    Thanks egaille,

     

    Your drivers work except for two, I can't seem to get to work:

    - Network Controller (Atheros)

    - Cirrus Logic CS4206A

     

    Like you I'm working on a iMac 27" i5, can you help me out?

  • egaille Level 1 Level 1 (0 points)

    > vaskelovo

     

    My archive is for imac 27" core i5. this is normal some of your components don't install. Not the same hardware.You need to find what type of hardware is your touchpad, wifi, etc.

     

    In Lion, go to "about this mac" in apple menu, and try to get any informations about the hardware. After that i may be able to help you.

  • egaille Level 1 Level 1 (0 points)

    > geitemuil

     

    2 questions:
    - How many hardwares don't work in the control panel?

    - What are their names (in windows control panel)?


    Maybe you have to force the install (if the hardware id doesn't match the driver's information in the .inf file).

     

    To force the install:

     

    1) right-click on the yellow marked hardware

    2) select "update driver"

    3) "not now" (radio button number 3)

    4) install from a list (number 2)

    5) "don't search, i'll choose the driver by myself" (last)

    6) select disk (browse to the driver directory).

    7) next and finish (you may get warnings).

     

    carefull ! you need to point the right driver for the right hardware:

     

    Atheros driver is for wifi (network adapter).

    Cirrus logic driver is for the audio.

  • geitemuil Level 1 Level 1 (0 points)

    Thanks for the quick reply.

     

    When I follow you instructions it starts installing, but it keeps giving an error:

     

    "Cannot install this hardware

     

    There was a problem installing this hardware:

    Cirrus Logic CS4206A (AB 32)

     

    An error occured during the installation of the device

    The parameter is incorrect."

     

    And the same with the wifi network adapter:

     

    "Cannot install this hardware

     

    There was a problem installing this hardware:

    Network Controller

     

    An error occured during the installation of the device

    The parameter is incorrect."

     

    What am I doing wrong?

  • geitemuil Level 1 Level 1 (0 points)

    Succes with the Atheros wifi driver!

     

    But the Cirrus Logic CS4296A (AB 32) keeps giving the same error...

     

    Hope you can help me out here, maybe download another driver?

  • egaille Level 1 Level 1 (0 points)

    maybe you could try in safe mode.

     

    - Reboot the mac
    - Press Alt to choose Windows

    - Immediately press F8 before the splash screen
    - Choose "Safe mode"
    - Try the install again

     

    If it still doesn't work, it is either a problem of hardware change, or a problem of windows version.

    My XP CD installer is SP3... for the hardware change, the ways of Apple are inscrutable   ... Try what i asked to Vaskelovo in my previous post, and tell me if you get a name, or a brand, or something.

  • geitemuil Level 1 Level 1 (0 points)

    In safe mode I logged in as Administrator and did the install again. Still an error but another pop-up:

     

    "The file 'CS420x86.sys' on Cirrus Logic HD Audio Codec Installation Media is needed.

     

    Type the path where the file is located, and then click OK."

     

    Does this ring a bell?