10 Replies Latest reply: Jan 20, 2016 3:06 PM by Mattisaboss Branched to a new discussion.
bennarsson Level 1 Level 1

I am trying to create a new folder on my desktop, but this message pops up:  The operation can't be completed because you don't have the necessary permission.

 

I am the sole owner and user of this Mac, and bought it at the end of last year.  Up until about 4 weeks ago, I hadn't encountered this problem before.  Any possible solutions to my problem?


iMac, Mac OS X (10.6.7)
  • baltwo Level 9 Level 9

    Select HD->Users->username->Desktop, click CMD+I, and ensure that you're the owner and have Read & Write permissions.

  • bennarsson Level 1 Level 1

    I'm not sure what CMD+I is.  I right-click on Desktop, click on Get Info, and it says under sharing & permissions:  You can only read.  Yet under Name is my name (front part of my email address), and across under Privilege it says Read & Write.  I'm not quite sure what to make of this.

     

    Also, I'm not sure where to look to ensure that I am the owner, other than knowing that yes, I am the owner of this Mac.  I am a Mac novice when it comes solving problems like this.  Thanks for the prompt reply!

     

    -bennarsson

  • baltwo Level 9 Level 9

    When you select an item, file or folder, right-click and select Get Info is the same as pressing the command and I keys. Both pop up the info panel for the selected item. If you've selected your Desktop folder, then something is extremely wrong if it says [i]You can only read[/i], while showing you under name with read and write privileges. This what it should be showing:

     

    owner.png

     

    The only thing I can recommend is to restart and see if the Get Info shows consistent information.

  • crampy Level 4 Level 4

    Go to system prefences and click accounts- are you the administrator? Are you logged in as admin, or as guest?

    The CMD+I ("eye" not L I THINK) are keys on the keyboard to press all at once.

  • ~Bee Level 7 Level 7
    expertise.macosx
    Mac OS X

    crampy --

     

    Do you realize that this thread has been dead for over six weeks?

    And that you are simply repeating info that baltwo has already posted in here?

  • crampy Level 4 Level 4

    Hello Bee.

    How did it come up on the current discussion page for me to see it?

    That is embarrassing.

    I had not noticed the date. I figured if it was on the discussion page, then it was new...

    Part of how I learn is seeing situations I had not dealt with and try to research it for someone..

    Oops.

  • ~Bee Level 7 Level 7
    expertise.macosx
    Mac OS X

    That's OK, crampy.

    I was overwhelmed with trying to help to an extreme degree too -- years ago.

     

    I think you got great advice today from another helper, who encouraged you to read more and maybe post a little less.  You're obviously well-intentioned and enthusiastic.  Just be patient, learn all you can, and answer when  you very sure you know the answer.

     

    Just always remember, our posters here really need answers.  Not just Wild A** Guesses.  You need to read the whole thread carefully, do some research, and then answer responsibly.  If you do all that, I know you'll be great.

  • David Criswell Level 1 Level 1

    bennarsson, in case you're still having this problem, here's the solution that worked for me:

     

    In the Desktop folder's Get Info window, there's a "Locked" checkbox that somehow had become enabled.  When I disabled that checkbox, all was well.

  • smnyc Level 1 Level 1

    David, your post way back in 2012 solved my problem after much searching. Thank you!

  • Mattisaboss Level 1 Level 1

    What is HD?