Previous 1 2 Next 19 Replies Latest reply: Jan 24, 2012 2:50 AM by John Cogdell
jpbilderback Level 1 Level 1 (0 points)

When attempting to download video to imovie; as the program reads the camera, it will stall when it is generating poster images in iMovie.

 

It has always worked, but this time, it just will not progress through the generating poster images step.

 

Anyone ... ? Help, please!

 

Thank you kindly,

 

John


iMovie '11, Mac OS X (10.6.7)
  • John Cogdell Level 5 Level 5 (4,605 points)

    Hi John (snap),

     

    Just a quick thought that may help. Firstly, I'm assuming that you are importing AVCHD clips. If not, please ignore this advice as it applies only to AVCHD clips.

     

    After connecting the camera to iMovie, rather than importing the clips, click Archive All at the bottom of the Import window that opens. In the Save As field, type a name for the archive. Choose where you want to save the archive, and then click Create.

     

    Tip: Don’t save the archive inside the iMovie Events or iMovie Projects folder. This could make iMovie operate more slowly.

     

    Having archived the clips using iMovie's Archive All feature, try importing them from the archive to an Event in iMovie. To do this, go to iMovie's menu and select File>Import>Camera Archive.

     

    Possibly, iMovie will now import without any hiccups. The problem may be with the camera, rather than iMovie. Copying the camera contents (to an archive), rather than going through the full import process, may help smooth the way.

     

    Another thought: The import problem may also be caused by a corrupt clip on the camera. On the camera, go through all the clips and check for any black (or blank) clips, possibly of short duration. Delete these from the camera. I'm assuming of course that you are not using a tape based camera, such as miniDV tapes. Now try importing to iMovie.

     

    John

     

    Message was edited by: John Cogdell

  • jpbilderback Level 1 Level 1 (0 points)

    This worked .... THANK YOU !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

     

    This worked ... I was getting nervous that I would lose some important video footage (first year of my son's life) ... so thank you many times over.

  • John Cogdell Level 5 Level 5 (4,605 points)

    jpbilderback wrote:

     

    This worked ....

    Glad it worked for you John! But just to clarify, what fixed things for you - the tip to import from an archive, or deleting corrupt clips from the camera?

     

    John

  • Lennart Thelander Level 8 Level 8 (38,220 points)

    jpbilderback wrote:

     

    I was getting nervous that I would lose some important video footage (first year of my son's life)

    You should *always* have a backup of *all* your files, preferably stored off site. Think of fire, theft, flooding, thunderstorms, hardware error, software error, user error...

  • jpbilderback Level 1 Level 1 (0 points)

    Sorry for the delayed response ... the archive all function was the trick!

  • jpbilderback Level 1 Level 1 (0 points)

    Yeah, I know ... I have backups ... but they are all in  the same place (in my house!!) ... multiple harddrives, but they are all here ... I need to take the backup of the backups to work ... or find a cheap online storage site.

  • eltik Level 1 Level 1 (0 points)

    Hi John,  I tried the same thing, but unfortunately I've still got the same problem.   When I try to import from the "Camera Archive" directory -  I still get the "Generating Poster Images" message.

    The only thing I can add is before I got into this situation - my iMac got stuck importing about 1 hour worth of video into iMovie, and I had to power-off my iMac.

     

     

    Any other ideas. 

     

    Appreciate your efforts!

  • John Cogdell Level 5 Level 5 (4,605 points)

    Hi eltik,

     

    Powering off your iMac may have corrupted iMovie's preference file. The corruption can occur in some circumstances, such as when iMovie quits unexpectedly or is Force Quit. In your case, simply powering off may have corrupted the file.

     

    If open, close iMovie. In Finder, go to your User (Home) folder Library/Preferences and locate the file named "com.apple.iMovieApp.plist". Drag this file to the Trash, but as a safety measure, don't empty Trash just yet. Note that this is the .plist file for iMovie '11. If you are using iMovie '09 the file is named "com.apple.iMovie8.plist" (8 being the version number for iMovie '09). Earlier versions of iMovie have a similar name for the preference file, some with a number, others with no number.

     

    Note also that if you are on Lion (OS X 10.7), the Library folder is hidden. To access it, click on the Desktop so that you are in Finder view, then Option>Click on Go in the Menu. Your User>Library folder will now appear in the drop-down list.

     

    Now that you have trashed the .plist file, open iMovie. A new file will be created with the default settings. These can be changed by clicking on the iMovie menu item iMovie>Preferences and checking (or unchecking) the appropriate settings in each of the tabs. If iMovie is now working OK it's safe to empty the Trash.

     

    Please come back if this doesn't fix the problem, as we may have other possible solutions to offer.

     

    John

  • AppleMan1958 Level 7 Level 7 (27,390 points)

    Sometimes the thumbnail files themselves can get corrupted.

     

    In this case the best thing to do is to delete the thumbnail folders.

    Shut down iMovie. Then, in the Finder go to the Movies/iMovie Events folder and look for your event. You should see your video clips in this folder. Take care not to delete them. You should also see two or three folders called Thumbnails, Cache, and maybe Stabilization. You can move these three folders to the trash.

     

    Then restart iMovie and it should create the thumbnails. It may take some time. Let it run.

  • eltik Level 1 Level 1 (0 points)

    Thanks for the reply John.   I trashed the preference file and restarted iMovie.   iMovie starts up great, unfortnately, when I connect the camcorder, the "Generating Poster Images" message pops up and hangs at near the end of completion.

     

    I tried AppleMan1958's suggestion of removing the thumbnail files, no luck either.

     

    After I've connected the camera to the computer, the "Import From: Sony HDR-SR11" window pop-up, and I can "Archive All...", but none of my clips appear from the camera.

  • eltik Level 1 Level 1 (0 points)

    Do I need to format the SONY drive to get it to work again?

  • golfsiss76 Level 1 Level 1 (0 points)

    Hi,  I am having the same problem.  In the middle of adding a new event Imovie got stuck and now I get the "Generating Poster Images" whenever I try to add a new event.  I cannot find -folder Library/Preferences.  I searched and still could not find a file called "com.apple.iMovieApp.plist".  Any ideas?  Thanks.

  • AppleMan1958 Level 7 Level 7 (27,390 points)

    To find the Preferences folder, open a Finder window. Then, select GO from the top menu bar. Press the Option Key and you should see LIBRARY as a choice.

  • golfsiss76 Level 1 Level 1 (0 points)

    Thank you, I am in preferences, but do not see the file.  Sorting alphabetically, I see com.apple.ilife09.plist and then com.apple.ipod.plist.  No imovie.  I have a MAC 10.6.8 if that helps.

Previous 1 2 Next